Pimax 8k Disconnects every 5 seconds

Every few seconds my pimax will disconnect and I’ll see the grey screen with the steamvr logo. The headset then reconnects and I see the game content. This will repeat endlessly.

If I’m in discord I can see that my audio also drops every few seconds even when a game isnt loaded.

I have installed various pitool version up to the latest beta. My nvidia drivers are up to date.

I have tried every combination of USB ports on my computer, both 2.0 and 3. I have tried it with and without the vive link box.

16b 3200MHz
Asus Hero IX Motherboard



I have had massive disconnect too with my 5K+.

Solved by using an extender usb cable (the one I was previously using with my 3rd rift sensor, branded monoprice. Picture below).

I think it is faulty shielded cable (will ask for a replacement for mine).

Monoprice usb extender:


By the pattern, seems like something is disconnecting your pimax and then, after sometime checks again.

Are you using the Intel USB back ports ?

1 Like

the gpu is gtx/rtx and the hmd is connected by DP without any adapter or extensions?
try to use a usb (preferably powerd, can be 2.0 does’nt matter) or the htc vive link box between pc and hmd
did you try the latest pitool beta?

1 Like
  1. Press the headset cable firmly to push it in.
  2. Change the usb port.
  3. Unplug the power adapter and plug it in again.

The 8k is a 2 and 1 cable with a usb and display cable going from the hmd into the pc. I’m curious how adding an extension onto the male end of the usb cable would resolve the issue. Is it just one of those things or am I missing something?

The 5K+ has a 2in1 cable too.

If I connect the usb directly to my PC (desktop) the HMD will disconnect like crazy. It was even hard to just power ON the HMD.

I have initially tried a lot of things, including using another 5V powersupply (with more than 2x the Amp of the original PS), trying all usb ports, disconnecting everything from USB and just leave the pimax, push the connector (HMD side), even pulled this connector out to clean and inspect the pins.

Nothing worked, and then I tried usung this extender USB cable and this magically solved the disconnections. I have been using the HMD like this for weeks now and it works like a charm, not a single disconnect, and HMD powers ON on demand by a single press on the power button.

My best guess is my cable has faulty shielding (know issue from Pimax, they told us they could make sure to send the new version for the last HMD sent to backers). I think the faulty shielded cable pick interferences from the PC when the USB is connected directly to it, and using the extender USB cable allow to have this USB away the PC (maybe the extender cable acts as a filter too, idk).


Wow, thanks for this explanation. I’m going to give it a shot as soon as I can. Some of these issues are wild :).

1 Like

I tried a 10foot usb cable extension. The audio was popping, probably due to the length. However, the issue was still there. It’s not always going grey. Sometime the game just completely stops responding for a couple of seconds, all the players stop then catch up, almost like a giant lag spike.

I did try all of the USB ports on the back and front of the computer. I’m wondering if a pci-e usb card would help? I’m thinking if I get a smaller cable I’m still going to have the issue with the non responsiveness since it’s happening with a longer cable a well.

1 Like

You are welcome. Let us know your results :slight_smile:

By the way, when I swapped the powersupply I have also measured the current draw of the HMD and it was drawing much less than the rated current of the Pimax power supply.

I have not used my DMM for a precise measurement, I was using a GTpower RC that is for measuring much higher current and has less accuracy at low current, but I think it was accurate enough to get an idea.

Here are the current I measured for my 5K+:

  • 60mA when in standby (red led)
  • 50mA when “powered-off” (led not lit)
  • 350mA when both panels are ON
  • 250mA when the HMD is going in standby by itself (after there was not movement of the HMD for a while)

I have tried all usb ports and a vive link box. The headset cable plugs directly into the GPU.

1 Like

Yes, I am yusing the UBS back ports. Tried 3.0 and 2.0 ports.

1 Like

Was it just a simple USB cable extension ?

The monoprice one I posted is amplified (active cable), I think that can make a difference.


if he already tryed the htc link box i think its unlikely, its kind of the same, a powered usb hub
also i’m using a 5m usb 2.0 active cable that is powered by the usb port so what “exits” on the other end its <500mA, i even chained two of them giving it 15m with the 5m from the original cable - so its not really about the current from USB or USB 3.0 (also the hmd has its own psu)

if it would be the voltage then the htc link box should have fixed it i guess

1 Like

I have not said it was the voltage, my guess was interferences (because I knew Pimax had faulty cables with improper shielding).

I can just share my personnal experience regarding the disconnections. I was already prepared to ask for a RMA because nothing I had tried was fixing the issue, and then that active USB extension fixed it completely.

I have a vive link box too, I could try it with my 5K+ to check if the disconnections come back when I use it instead of the monoprice cable.


that might save him some time and money if you can try this
maybe also reconnecting the cable on the hmd cant hurt

I got everything working! I was on WiFi. Even though I was downloading at 100mb and uploading at 115mb, running an Ethernet cable down the hall and connecting to the router resolved the issue. To test I put it back on WiFi and grey screens started up again. I never had an issue with my Vive on WiFi. Thanks everyone for the help.


wifi/bt can interfere with usb 3.0 but imho should not with 2.0
or is the wifi connected by usb?

WiFi was connected with a USB netgear nighthawk WiFi adapter