Pimax 8K 8 flashing red, green, blue

My 8K8 flahsing RGB after failed firmware update blocked by Norton. Causing me to uninstall the Pitools After reinstalling the tool I found no luck in updating the HMD. Now im facing the issue that device manager keeps refreshing every second with the STM Device being detected followed by undetected.

Meanwhile the HMD still flashes red, green, blue followed by a now steady red for a sec before it goes back to blinking. I think the steady red dot correlates with STM device being detected in Device Manager.

I have reinstalled many times, I even remove Norton, I also removed Thrustmaster which a reddti user was suggesting. I have no luck in detecting the headset nor have I only luck in manually updating the firmware neither by CMD, or via DFU.exe, I even tried running the ‘‘stm_dfu_3040_64’’ but no luck.

I even tried to reset my motherboard thinking if I cleared the cashes it may recognize the STM device. Nope.

This is very frustrating as ive been spending my entire day off trying to fix this.

I really hope for the sake of my headset that it’s okay and fixable. I dont care about the wasted time off work I took today to enjoy VR gaming. I just want this to work :frowning:

2 Likes

https://community.openmr.ai/t/solution-for-failure-upgrade-to-latest-firmware-on-pitool-259/28151?u=cazman321

3 Likes

I had a some what similar experience. Very frustrating.

I would do the 3 finger sequence to enter “firmware download mode”, the LED would flash red, green, blue for a couple of seconds and then go back to dim red. Unfortunately, the firmware wasn’t usable; the headset could not be detected. Eventually, I tried flashing with an even earlier firmware, carefully timing it, so that DFU started just after the red-green-blue began. From there, I was able to successfully enter programming mode and flash with the latest firmware.

Even now, I find that I need to uninstall and reinstall the latest PiTool fairly often, to fix the dreaded “headset not detected” error in SteamVR. At least I determined that I didn’t need to reboot my PC as part of the process.

I wasted at least 6 hours trying to resolve this problem, but at least I can actually enter VR, albeit with extra aggravation on a far-too-frequent basis. I sure hope Pimax can fix these software issues!

3 Likes

Hello Neal,

So your solution is reinstall the Pitool, and reflash the earlier firmware to resolve this?

Actually we have forwarded this issue to the Pitool team, they are working to debug this, hopefully it can be done by within these 2 weeks.

Thank you so much! - I was able to see the STM in Device manager as soon as those two folders were deleted! - the CMD ran smothly now and it looks like my headset has been restored!

Thank you. I will forward this thread to Reddit, in case anyone else have this issue.

3 Likes

Sadly it looks like I ran into another problem. I made a video to explain Pimax 8KX issue - YouTube

2 Likes

Hello,

Please create a service ticket at Submit a ticket : Pimax Support

Please attach this video in the ticket when reporting the problem.
Our technical staff will evaluate it and inspect your headset.
It’s possible that the headset’s flashing lights are caused by the most recent software problem.

Aside from that, they may request a log file from you for additional investigation.

Regards.

1 Like

Yes and no. I just need to uninstall PiTool and reinstall it. I don’t need to reflash my firmware. I’m not even sure I need to uninstall PiTool before the reinstall. (I haven’t tested that, but I will, next time it fails.) I’ll post my results.

The very first time I installed the latest PiTool, my 8KX was automatically flashed and had black screens. When I manually flashed the latest FW, my 8KX flickered badly with video noise, but did show the correct images.

I eventually fixed it (after many hours of trying various things), by installing PiTool 270 and an older FW (I think it was 298). This was painfully time-consuming (hours), since for some reason, my 8KX would not stay in FW download mode. (The red-green-blue flashing LED would turn white after about 2 seconds.) I was then able to flash with the latest 299 FW, which worked great. I then upgraded PiTool to 272, which did not auto-flash the FW.

Everything is now working, except that sometime SteamVR cannot detect my headset. What’s even more remarkable is that I’m using an MSI RTX 2080 and 90Hz works great. Even the 1/2 refresh option works (but is not required).

I will also note that I do not have a “Guillemot STM DFU Device”, nor to I use Sim Racing Steering. The only VR game I’m currently playing is Elite Dangerous: Horizons.
@hammerhead_gal

Great! I hope they can find and fix the problem.

3 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.