Pimax 5K+ with Eye-tracker - Impossible to get to work

Hi everyone,

As I had problem with the Pimax 5K+ I ordered, I finally received my replacement HMD, and after checking that it was working ok went straight to test the eye-tracker.

So I installed it, plugging it on the top usb-c port of the HMD, cutting the confort kit as necessary, plugged it, and launched the calibration. And nothing… I mean, the Unity scene actually loads, I see two green dots for a second, and send the dots disappear.

I spent all day going through the forum, trying different things, and nothing works. I’m running Pitool (with aSeeVR, but I have also tried installing aSeeVR I have the same trouble. I’ve checked using the recommended AMCap software, but cannot get to find the options mentioned on this post. I do get a green screen when i select Droolon Pi1, with 320x480 resolution and 60Hz. My understanding is that it should be running at 120Hz, so I wonder if something is wrong with the eyetracker.

Also, I’ve checked through the log C:\7invensun\aSeeVR_UserSDK\runtime\aSeeVRServer.log, and get the following error (like the server does not manage to establish the socket connection to the eyetracker).

[2021-03-11 21:40:39.262]: sdk path: C:\7invensun\aSeeVR_UserSDK\runtime\devices\Pimax\config

[2021-03-11 21:40:39.263]: service addr:

[2021-03-11 21:40:39.796]: sdk path: C:\7invensun\aSeeVR_UserSDK\runtime\devices\Pimax\config

[2021-03-11 21:40:39.813]: internal sdk init: 0

[2021-03-11 21:40:39.813]: internal sdk set image callback: 0

[2021-03-11 21:40:51.174]: internal sdk start camera: 0

[2021-03-11 21:40:51.174]: internal sdk start gaze callback_ex: 0

[2021-03-11 21:40:51.174]: tracking mode: [3]

[2021-03-11 21:40:51.174]: internal sdk start tracking: -3 -3

[2021-03-11 21:41:18.654]: 3 socket err: 0 0 2340

[2021-03-11 21:41:18.654]: 3 socket err: 0 0 2340

[2021-03-11 21:41:18.655]: breakdown: 1

Before logging a ticket, I was wondering whether anyone had any feedback, or idea about what I might be missing.


You might need to get closer to the headset to get it to track Your eyes during calibration (i.e. thinner foam or try pressing your face closer to the eye tracking unit).

It might also be worth a try to try using a different USB port on the PC.

That worked for me on the 8KX.


Hi, thanks for the advice. I also already tried that to no avail :S


Did the ET driver install okay? Maybe try the lower usb-c port. You may need to rotate the connector by 180 as it appears 7invensun is not utilizing the Usb-c standard properly.

Another test is to use a usb-c adapter with a webcam as it was discovered some 5k+ units the Usb-c expansion ports are configured wrong and only working in usb1.1 mode which is not compatible with HT and ET as they need a min of 2.0.

A webcam if detected and works should help identify if your unit is affected.

You can also use usbtreeview and like programs to see.

1 Like


We have pinged @7invensun-JC in this post, he might able to provide solution to resolve the installation failure issue.


1 Like


Is there any other program occupying the camera of droolon Pi1 during calibration?
Please send me the USERSDK.LOG to


1 Like

Hi, I do not think that there is a program using droolon Pi1 during the calibration. None that I am aware of in any case (I’ve also tried closing whatever could have influenced it, and have had the same problem).

Anyway, I have sent you the requested file by email. Thanks for your help.


Hi @7invensun-JC,

I contact you related my problem with getting the Droolon Pi1 to connect on my Pimax 5K+. I have made a test on another computer and have exactly the same problem, with the calibration dots disappearing directly, and similar errors in the log file (as in the one I sent you last week).

I would like to know what is the next step to follow in order to fix this issue. Should I open an official support ticket with pimax?


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.