Pimax 5K+ still unusable after 3 months (Help needed)

Hello everybody

After not using my Pimax 5K+ for almost 3 months, because almost nothing worked when I received it, I decided to give it another try today. Sadly, it still doesn’t work for me and I’m still experiencing all the same issues.
First off, these are my hardware and software specs:

CPU: Ryzen 1800x
RAM: 2x16GB DDR4 3000 MT/s
GPU: RX 580 4GB

Windows Pro 64bit 1809 (fully updated), completely reformatted since last time I tried Pimax
Pitool 1.0.121 BETA 211 (I’ve tried several other Pitool versions in the past, though I don’t remember the numbers)
AMD Adrenalin 2019 Edition 19.4.3 (I’ve tried several other drivers in the past, including WHQL drivers and latest beta drivers)

After first installing Pitool today since the latest hard disk reformat, I was greeted with this friendly message:
Obiously, in reality there’s nothing wrong with my OpenGL, it works without issues everywhere else.

Then, after restarting, it opened Pitool and recognized the headset, but still nothing appearing on the HMD screens, so I decided to open SteamVR, which gave this error message:Error2

After restarting the HMB with the restart HMD button in Pitool, this error appears:

It didn’t go away, so I restarted the PC.
After restarting, finally for the first time today I got an image on the screen. The image has a horizontal line and on top or bottom, the colors are wrong (green and red). Different colors on each screen (left and right):

After restarting the HMD again (with the Pitool button) it finally showed a correct image of the Pitool environment, so I decided to launch SteamVR again. At first it appeared that SteamVR finally recognized the headset correctly and started correctly, but then it caused to PC to crash (monitors black, everything frozen, including keyboard not even being able to toggle Caps Lock, Num Lock LEDs, etc.)

After booting up the PC again, I tried to open Pitool and it immediately crashes Pitool like this:

So I killed it, tried again and eventually could open it again, but now the HMD was not recognized anymore, even after replugging it several times:

Finally, after rebooting the PC again and also trying to reboot the HMD via physical buttons on the headset, eventually it showed up again:

However, the LED on the HMD is red and the screens are black (turned off).
I uninstalled Pitool and reinstalled it again, but still nothing showing up and this is the diagnosis error:

So right now, it’s not working at all, but in the past, after randomly restarting, reinstalling everything etc. I could usually get it to work (often takes more than 3 hours) for a few minutes until it crashes after a few minutes and the whole process starts all over again (there are more bugs than the ones listed here, these are just the ones from today).

I don’t think this is an acceptable experience and am hoping that someone can help me get it to run somewhat stable.

1 Like

Hm. Is it maybe a problem with using an AMD GPU? Is there anyone here who uses an AMD GPU who could verify theirs run without issues?


Currently, this is the error message, after pressing “Reboot HMD” in Pitool:

I cannot really help you, but you can try to have a look at the log files in the Pimax folder (which is probably somewhere in %AppData%/Local). There is a server log and some other logs which are more verbatim than the “Diagnose” in the PiTool. My guess would be the AMD GPU though.


Crashes with AMD GPUs have been reported by other users.


1 Like

It almost looks like a great deal of DLL version and/or permission conflicts.

If you have an old spare HD you might disconnect the existing drive and connect the old one then install a clean copy of Windows on it. Then patch Window up to the latest, install your AMD driver, PiTook and Steam/SteamVR.


These are the the most recent logs I can find:



This is already a very new and clean installation of Windows 10 (a few weeks old) and it didn’t work with the previous installation either (was about 2 months old in January, so also very new and clean)

I just now installed vcRedist that is linked in PiTool, still crashes the PC when I finally manage to get it detected and start SteamVR, it crashes the PC.

Also, this is another error (blue screen) I got half an hour ago:

Since I can’t easily reinstall Windows right now (and I recently already did that, so I doubt it will solve anything), I reinstalled Pitool again and deleted everything in AppData\Local from Pimax. Still same issues (crash when I start anything like SteamVR when Pitool is running).

These are some of the new logs:




Any ideas how I can solve my problems? I tried reinstalling everything, including the entire OS, with no result.

Just by comparing your DiagnosepimaxService.log to mine (https://pastebin.com/raw/T0RDpMs4) I noticed that the very beginning in yours says

21:01:48 T:7980 LOGERROR: cannot load path:C:\Users\Nico\AppData\Local\Pimax\PiService\diagnose.json

while mine says:

23:51:02 T:12880 LOGNOTICE: adapter0 :NVIDIA GeForce GTX 1080 Ti
23:51:02 T:12880 LOGNOTICE: adapter1 :Microsoft Basic Render Driver

I have the file diagnose.json in the directory your log points to, so I would have look into this. There is also a difference at the end of the log file (mine reports the GPU registry keys, while it is missing from yours).


Thanks, the file is there for me too. I ran the diagnose again, to recreate the log file and now it correctly says:
21:46:33 T:8424 LOGNOTICE: adapter0 :Radeon RX 580 Series
21:46:33 T:8424 LOGNOTICE: adapter1 :Microsoft Basic Render Driver

Try to disable “Start PVR Home” (if it is enabled) and also try to disable lighthouse tracking (as if you do not have them).


Your gc seems to be in cause but you should also check the usb side. Be sure you disabled usb suspend and let it always powered. Last resort I’d check if there are instabilities due to usb controller. Some usb controller like Asmedia have problems with vr headset (that’s why I use a Fresco Logic controller).


I usually keep PVR disabled, but I’ve tried both ways. I tried keeping lighthouses disabled in Pitool, it still usually crashes when I start a game or SteamVR.

1 Like

I disabled USB suspend, no difference, still crashing my PC. I have 2 USB controllers, one is Asmedia, the other is proprietary AMD. I usually use the 3.0 outputs of the AMD chipset and try different ports. The problems are there either way.

1 Like

Can you reinstall & ger application integrity to pass?

The error 20300 says Antivirus might be interfering & check that pi servers are running in taskmanager. I will either today or tomorrow stop being lazy & hook up the i5 6500 16g r9 390 8g machine & test.

My apologies on being tardy.

1 Like

One issue could be related to 4gig card but should have better results than he has.

1 Like

I just tried disabling realtime protection (I don’t have any additional AV installed) and then reinstalled Pitool. It crashed my driver again.

PiServiceLauncher service is running and pi_server.exe is running. Also, it’s usually using 100% of a CPU hardware thread, which seems to be another bug, but I read from other people that they are experiencing the same bug.

1 Like

@Raujok reported Asmedia can be problematic.

1 Like