Pimax 5K+ mic not working once SteamVR starts up

So this has been a long standing problem but I’ve never been able to lock down exactly where it existed until today. I started up a program where mic usage was expected and tried to talk and absolutely zero input from the mic was being accepted. Nobody could hear me, and in any VR recordings I made I could not hear anything at all from my mic.

I tried going through all the windows 10 settings to enable the mic and everything was already enabled. I tried testing the mic from inside VR and got no response to any sounds. At this point I’m thinking maybe it’s a windows 10 problem. I boot into Windows 7 and check the mic without SteamVR running. I’m seeing input so I know the mic is fine. So now I go back to windows 10 and try again… same exact test and… I’m seeing mic input registering. IT’S FIXED! YAY!!

I start up steam VR and get ready to record and… holy crap it’s not recording again… WHY? I don’t get it… so I shut down steam VR and try again to get any response out of the mic but nothing works. I reset the headset from pitool and now the mic works again… I start making noise at the mic and start up steam VR and as soon as steamVR loads up and takes control, the mic goes dead silent. Is the mic set to the proper input through steamVR? YES… Does the mic register input on any other software? NO… not as long as steam VR is running.

SO to make it simple: The mic works just fine until SteamVR starts up, and then it stops responding until steam VR is stopped and the headset is reset… If I reset the headset AFTER steamVR is running it still doesn’t work until SteamVR is shut down.

Currently on windows 10 using the beta pitool, pimax 5K+ with the latest firmware, using the latest nvidia drivers (Just installed yesterday so don’t even suggest it as an issue)… everything is as up to date as it should be, the mic works just fine until steamVR kicks in and then it dies until I close steamVR and reset the headset, or reset the headset and close steamVR. Oh and this issue exists both in and out of the steam VR beta, so don’t even suggest that to me either.

Actually I just tested ONE more condition and so far it seems like it might be a different program interfering… I uninstalled the Open VR advanced settings program and so far it seems like the mic still works… so I’m going to try a test run without the program installed and see if this fixes the issue… if it does, I’ll report this as a bug to the openVR advanced settings team.

1 Like

Are You sure it’s not just a matter of selecting the right microphone in SteamVR → Settings → Audio tab?

Random image from aGoogle image search on “steamvr audio tab”:

1 Like

ABSOLUTELY POSITIVE… and I verified it just now that the program interfering was the open VR advanced settings program… I uninstalled it, the mic started working again, I tested it in VReal where I recorded a 30 minute play session and the mic worked perfectly.

So yeah, I originally thought SteamVR was the culprit but then on a whim I uninstalled that other program to see if it could be causing the issue and that was it. For the record, I did NOT have it set to mute the mic for any reason, even though there’s a setting in there to mute the mic when you’re not wearing the headset.

I actually tested that option FIRST to see if it wasn’t detecting when I had the headset on and it made no difference if the setting was on or off, it still muted the mic permanently…


Interesting. If you have another usb mic see if it affects it. Nvidia driver though shouldn’t affect mic as it’s not part of Nvidia driver.

If you have FpsVR it might help track as you can adjust mic on desktop instance.

I was just trying to cover all my bases since it was pretty frustrating to see the mic not working. I don’t have another USB mic I could easily use (and the headset mic I do have uses the regular headphone/mic jacks)

I’ve posted a bug report to the OpenVR advanced setting team. Now I’ve got an entirely DIFFERENT problem though. New post coming up

1 Like

OK, I don’t have openVR advanced settings installed on my computer anymore, yet the mic stops working the minute steamVR starts up still… it may not have been openVR after all…

I start up the computer, everything is fresh, I open the sound properties page so I can see when the mic is receiving sound… I can thump the pimax with my finger and see the bars go way up so i know it’s working in windows.

Then I start up steam VR, and the minute steam tries to get control, the mic stops working entirely until I reboot. It’s really weird because I’ve been able to get it to work before in some other games/programs so I don’t know what’s causing it to drop the mic on me.

The one time I noticed that I had steam VR running and windows still showed the mic working was when the audio settings were set to the wrong mic. Once I switched it to the pimax mic, it just stopped cold. It’s really frustrating.

Check SteamVR settings (the little window with the green icons for headset, basestations, controllers), specifically the Audio tab.

As the microphone is working well in Windows, I suspect this is a SteamVR issue. As always when something screwes up in SteamVR, I would suggest to exit SteamVR, then remove (or just remporary move away) the config file:

C:\Program Files (x86)\Steam\config\steamvr.vrsettings

Then start SteamVR again and a new config file will be created. You might need to re-apply some custom settings you had in SteamVR before, but often it can solve a lot of issues in SteamVR. Thats because the config file can store a lot of weird things, that apply upon SteamVR startup - especially if you had OpenVR Advanced Settings installed in the past

Let me know if that helps!


I’ve checked and rechecked and double-rechecked the settings and nothing would fix it. According to steam the correct mic was selected and the mic was not muted. I was able to click the mic icon to change it to a mic with a / through it and then click it again to restore it to unmuted status.

1 Like

I’ll give that a try. Maybe it’s a lingering effect from the openVR settings? They said it was because pimax didn’t have a sensor for detecting if you were using the headset, though I tried everything I could to prevent openVR settings from selecting to mute in that case as well. It’s normally not a problem for me, but last night I tried to hang out with a friend in VR and no matter what I did, the mic wasn’t working.


I actually had a similar problem with my Blue Yeti mic in the past after a Windows update. I ended up uninstalling the mic from windows hardware, rebooted, mic was found again, new drivers were installed automatically and it all worked again. Maybe worth a try if removing the SteamVR settings file doesn’t work?


Well I was able to get the mic working under windows 7 (same hardware/dual boot). For some reason it was set to CD quality by default and switching it to DVD quality seemed to keep it working. I’m going to try again with windows 10 in a bit. How would I go about uninstalling the pimax mic? Device manager?

1 Like

Yes device manager.

Interesting find about the dvd quality (48kHz instead of 44.1 I assume). I will test this on Windows 10 as well! Thanks

1 Like

It seems like if I can get the mic working before steam starts up I can keep it working, but I can’t do any adjustments to the settings while VR is running or it dies and won’t come back.

Also, I found out that fpsVR has a similar setting to OpenVR advanced settings where it looks for the Vive proximity sensor to turn the mic off and on. I disabled that and hopefully it’ll improve…but maybe it might be helpful to get pitool to report that the proximity sensor is always on rather than not there so that software like that won’t just mute the mic on its own.


Hmm interesting. What if you click on “Disable Power Management” in SteamVR under Developer tab? (make sure to restart SteamVR after this).

And also disable “Pause rendering when headset is idle” ?

1 Like

I haven’t been using my Pimax for the past week so I don’t know if that will help or not but I’ll check it out next time. I don’t think it’s power management though because I think I had that disabled from before after my controllers would turn off quickly even while I was playing.

As for Pause while headset is idle, as far as I know, the headset is never idle to SteamVR because where my Vive and my Index would turn off the screen after a while of being idle, the Pimax seems to stay on 24/7 (requiring me to unplug it or manually turn it off if I wasn’t planning on using it).