Pimax 4K - USB and HDMI showing as connected but still have red X

Wondering if anyone can help, since I have upgraded the PiMax software I seem to be getting the above issue. Under Device it actually shows the device as disconnected.
My current setup is as follows:
Windows Version Microsoft Windows 10 (10.0) Professional 64-bit (Build 17134)
DirectX Version 12.0
Number of cores 4 (max 4)
Number of threads 8 (max 8)
Name Intel Core i7 4820K
Codename Ivy Bridge-E
Specification Intel® Core™ i7-4820K CPU @ 3.70GHz
Package (platform ID) Socket 2011 LGA (0x2)
Core Speed 4288.2 MHz
Northbridge Intel Ivy Bridge-E rev. 04
Southbridge Intel X79 rev. 05
Graphic Interface PCI-Express
Graphics Cards 2 X AMD Radeon R9 295X2 (4 GPUS)

Reinstall piplay Newer version has connection issues & more ghosting.

Thanks for the suggestion, is there a place where I can obtain the previous versions?

1 Like

Here is a link


1 Like

what keybord do you have ? cos i had this same issue and then i unplug my super old razor keybord my pimax start working just fine, and i could plug my keybord back in

1 Like

I got the exact problem.

I interchanged the HDMI for my monitor and PIMAX and got it working but after 2 reboots it is same and this time the previous solution(interchanging HDMI ports) doesn’t work either.

I noticed that windows has detected another display and i can move my mouse on it without actually seeing the cursor.
Tried to delete the display by going to multiple displays in control panel but no luck.

For me the above solution works sometimes but it is more like trial and error.
But i can assure you that changing to different PIPLAY versions is absolutely not the solution.
I will contact their email for this.


I just now did one thing and it solved my problem.
I attached an image file which is taken after i solved this problem.
I went in multiple displays section in display settings,there i disabled pimax 4k and saw blue light on headset, then restarted the device and got blue light this time along with a message that pimax is connected.I’m so happy now.
I think that my PC treated this device as a monitor.

Do reply if this works so that it helps everyone else with this problem.
And sorry for any spelling mistakes here.