PiMax 4K solid green light, no sound, blank screen

Hi All,
I hope someone can help, I received my PiMax 4k and am really struggling to get it working, I’ve been going through the various threads on this forum since opening the box to avail, so I’m hoping someone here will come to my rescue.

I’m going to try to be as descriptive as possible.

First I’ll describe my setup:
I have a Razer Blade 14 (late 2016)
Core i7 6700HQ with integrated intel 530 graphics
Nvidia GTX1060 6GB (latest drivers)
512GB Sumsung NVMW SSD
Windows 10 (fully patched and up to date)

I have a PiMax with a 100xxxx serial number and it is on the latest firmware version.

The problem I have is when I plug the HMD into the laptop I get a green LED on the top but it never turns Blue, the screen never turns on and there is no sound. SteamVR and PiPlay can see the device and the tracking is working in SteamVR but no video in either extended mode or Pimax mode.

I can disable and uninstall the integrated graphics from device manager but not in the BIOS, there’s no option. Aslo I have selected the Nvidia GPU in the control panel.

I have also disable Windows defender Anti virus and Firewall and uninstalled Avast Anti-virus.

I have tried the following versions of PiPlay:
1.1.92 - Pimax detected as Rift DK2 and never connects to app, in device manager I see another generic monitor and a PiMax audio device
1.2.91 - Pimax USB and HDMI detected solid Green light no audio or video, no monitor detected in device manager
1.2.93 - Pimax USB and HDMI detected solid Green light no audio or video, no monitor detected in device manager - installation fails saying disable Anti-virus but it already is disabled - Pimax USB and HDMI detected solid Green light no audio or video, no monitor detected in device manager - Pimax USB and HDMI detected solid Green light no audio or video, no monitor detected in device manager

All installations were run as admin.

With regards to the audio, I’ve made sure the PiMax is selected as the audio device.

Could this be a driver issue?

I also considered trying to install it on a friends Desktop with dedicated GTX 1080 but can’t do that until the weekend.

Any help would be much appreciated.



@Community @Pimax-Support @PM_Sean

1 Like

your laptop does it use Optimus? Iw Nvidia gpu runs through intels as a passthrough?

Added pokes ti your post.

Also ensure your using hdmi in an hdmi port (not adapter) a usb powered hub maybe needed as laptops usually don’t put out a lot of power output

Hi I believe my laptop does use Optimus, I don’t think the HDMI passesthrough the Intel GPU because while doing all of my troubleshooting yesterday I had the Intel GPU disabled and tried starting steam VR and received a message say the main monitor and HMD couldn’t be connected to different GPU’s. I haven’t seen that message today though.

Also I’m only using the HDMI port on the laptop.

1 Like

May need support on this. Have you tried a powered usb hub as its possible your usb port might not be supplying enough power.

@Enopho might have some ideas as well.

No I haven’t, I’ll give it a go and let you know.


1 Like

Powered USB renders the same results.
An interesting this that happened just before I plugged into the powered hub was that I was changing some settings in the NVidia control panel, set PysX to 1060 rahter than auto and added piplay to the application list (it should have been picking up the global settings anyway) after I did that It started detected the piMax as an additional screen, still no audio or video though.

I should add Nvidia control panel doesn’t see my main display now, only PiMax

1 Like

im just off to bed as its late here so will check posts tomorrow when on the train to work.

if your seeing a monitor in the windows display properties then pimax is in video mode aka extended, try switching it to pimax mode and see what happen. The video mode option is for watching movies and 360/180 videos and windows sees the pimax as another screen to do this.

when in pimax mode, there is no screen shown in windows desktop properties, and the LED should initially turn green and then blue. if it stays green, please unplug the usb (only usb) for 5 seconds and then plug it back in. start steamvr and see if you get the steamvr home (beta version) or gray room with lines everywhere.

Will check back tomorrow…

night all.


1 Like

No worries, thanks for your help so far.

Switch from video to pimax mode and it did as you said, display in windows disappeared, I unplugged and plugged it back in LED was solid green and never change to blue, tried reseating the USB only several times



1 Like

@mynamesriz Cable connect:

  1. HDMIcable directly inserted into HDMI port of computer independent graphics card
  2. USB cable is inserted directly into the USB port of the computer
    Helmet status:
    What color is the LED on the helmet after the connection?
    Blue: normal connection state
    Green:Please check the HDMI connection
    Red: Please check the USB and HDMI connections. Replace the USB port to re plug.
    Display card driver:
    please download latest driver:Official Drivers | NVIDIA
    When installing, anti-virus software / all kinds of security software must be turned off.:
    If the installation is not closed in time, please completely uninstall piplay and reinstall it.
    piplay download address:http://pisetup.pimaxvr.com/PiPlay_Setup_3.0.0.81.exe
    if you still have problem, please leave your teamview id and password, We could book a time for remote control help, and our available time is 10:00 to 18:00 Beijing time.
1 Like

I have done all of the above and my helmet LED is green, it never changes.
I’m running the latest version of piplay and latest nvidia drivers. I actually uninstalled the anti-virus rather than disable it.

I’m in the UK so will have to be in the morning for me how’s 5PM Beijing time? Also where shall I post the Teamviewer ID and password?




@mynamesriz please send email to me by sean.huang@pimaxvr.com for id and password before 5PM Beijing Time.

i will arrange technical support to link with you by teamviewer.


Hi Sean,
I’ve sent the teamviewer details. hopefully speak to someone soon. :slight_smile:

1 Like

Hi all, just an update.
I had a support session today and after an hour didn’t have any luck, I’m going to try the headset another pc at the weekend and report back.


1 Like

Thanks for the update… Good luck on the 2nd pc! Keep us updated with progress

1 Like


1 Like

Unfortunately that doesn’t work every time I uninstall the Integrated graphics and reboot the laptop just reinstalls the device again.
I tried disabling the service too but made no difference,Thanks though.

I’m really hoping it’s a faulty unit so I send it back and get another. :slight_smile:

If it is an Optimus Nvidia laptop. I don’t think tge igpu can be disabled as the Nvidia Gpu passes through the Intel one.

@VRGIMP27 I think if memory serves might have an idea on this.

1 Like

I’m 90% sure that the HDMI is directly connected to the 1060 from reading multiple threads online relating to my specific laptop (Razer blade 14 late 2016).
It looks like the Oculus rift has similar port requirements from what I’ve read and people have run that on the Razer Blade so with that logic the PiMax should too right?

Also this is how the Nvidia control panel illustrates the connection:

A picture says a thousand words right? :wink:

I’ve been doing more troubleshooting today, I read on another post here that the Oculus software stopped the pimax from working, I had it installed along with Revive for my RiftCat setup, so I completely uninstalled all traces of revive and Oculus runtime, %appdata%/local and roaming, program files, OCVR drivers and registry entries. That didn’t fix it.

I then tried different nvidia driver versions, firstly the original driver that came with my laptop and then version 384.94 which was recommended on another thread on this forum. still no luck.

I’ll be testing the headset tomorrow on another PC, we’ll see what happens.

1 Like

@mynamesriz waiting for your update on another PC on weekend,Tks.
For your laptop, please try to disable GTX1060, try to use Intel graphic to connect 4K with video mode, and tell us whether the screen is on or not?

1 Like

Good suggestion, I just tried it and piplay would recognise the HDMI, as soon as I re-enable it PiPlay detects the HDMI again. So I guess that proves that the HDMI is directly connected to the 1060…

Will update you all later once I’ve tested on my mates PC.

1 Like