Pimax 4k - NoloVR in 2020 - Not Working? [solved]

Hello evrybody, it was a long time

so i decide to play agaéin on my pimax 4k and my noloVR
but i m stuck, because no way to found how the nolovr works with my pimax :

SO i install pitools and the headset works no probleme, but the nolovr nothing ??

What i miss, i think we need piplay, but all link are dead someone can explain me how play again on my pimax4k thanks all

My pitools :

1 Like

after hour of search

Pimax don’t support the Piplay who make works nolovr and the pimax. :cry:

so i can put my headset and the nolo in my museum of hardware :’(

Not sure on Nolo in pitool. However the Artisan was at one time packaged with Nolo.

@SweViver might have some ideas once he is back.

As for Piplay and all links Pimax checkout @Playa repository.


Link near Bottom of page. He also has a new Firmware for the p4k that greatly reduces ghosting but introduces some motion blur(haven’t tested). This was released a couple of months ago.

1 Like

There were specific pitools that mentioned Nolo. Though don’t recall which versions.

1 Like


u get my hype i will try,
i don’t know if my old headset can works, i really want try the launcher PE !!!

But if my nolo not worls :confused:

First try :
i remove my pitool and i install : PITOOLSETUP !

Second try, if my nolo stil not working
i remove all pitools and i install the last piplay 3 and i try with this

hope that’s works

now i download

i keep in touch !!

very thanks

1 Like

Your very welcome! Good to see you again. Hope your enjoying the Holidays

1 Like

thanks !!

for now with the lateste pitools, my nolovr tracking not working :confused:
i found someone who tell me to use an old versioni will try

but for now not working :’(

1 Like

@PimaxQuorra can you ask the team about the Nolor support?


Well, after on day to make it works,
headset works but no way to make the tracking works :cry:

hope to have the support of nolo

1 Like

There was a user here that was using Nolo on the 4k. Not sure if he is still around. @TheDeaX

1 Like


We will ask the technical support team to look at this issue and try to sort out for you.



Try this guide from @park if you haven’t already.


1 Like

I am personally using Nolo with the 4k.
I am using PiTools, but all Versions should do it.
The Trick is to install PiTools first, then uninstall all Nolo driver related stuff (Close Pimax stuff and Steam for this) (also delete the Device Drivers in the Device Manager when connecting them). After everything related in uninstalled, you can just download NoloHome in Steam, it should install the fresh Nolo Drivers right away. Now, always start NoloHome(or SteamVR) after you have startet Pitool, it should work this way.

If your Devices are still not shown in OpenVR, check the VR Driver CMD Tool from the SteamVR Folder to verify that the Nolo SteamVR Drivers are correctly registered.


Hello thanks for u tactic

now i got the tracking with headset, but no way to make the controleur works on steam VR ??

what i mess please

1 Like

to resume my situation today :cry:

I removed the folder and files :


i remove from steamVR :


i remove Pitools

i used revoUninstaller to remove all trace of it

i closed steam

i install Pitool V1.0.1.264

so now i start SteamVR, i do the room setup, i repair all nolo (controlers, base, headset tracking)

Now :
i start Pitool V1.0.1.264
i start Steam
I start SteamVR

and now

the headset tracking works, the controlleur are not in the 3D view, but i can push buttons.

i can turn in 360 with controlleur.

But i can’t show the controleur nothing are in the 3D view

is better, but still missing the controlleur in the 3D view - i can’t found them in the 3D view !
i reset position, i push button nothing appear

the things is i can move, only the head in 360 and not move far way my place:/

is better, still missing a thing

thanks for u help

1 Like

so im still looking to make my nolovr + Pimax works together

for now still not working

so i got a new information

my base station is still the red light fix that’s means a sync problem with controleur :confused:


so my base station is still red light fix on it

and the other things :

on the face of the bases station u need to have 2 red light blinding, and on my nolo i have nothing

This a normal base station :

and this mine :

and red light in the face of it

so maybe i got a hardware problem finaly :cry:

what i can do please

If you turn on the base station, it should power its Motors, you should be able to feel the shaking in your Hand. If this dosent happen, the IR Markers wont power on. Make sure your Base Station is connected to an good Power Source (2A), even doe it runs on Batterys, its worth a try. Also check that all your Nolo Components use a Firmware Version that works with each other. This Collection of Tools and Knowledge may can help you > GitHub - DJPlaya/Tesseract-Cobra: Tools and Information on how to flash Nolo VR Hardware manually

If you still run into Problems, you may should contact the Nolo Support, they are great, they even replaced half my Nolo Gear over the Years for free :slight_smile:


Thanks for this link,
but is all in chinese :

i can t do nothing with it

i talk with the support and they tell me my base station is dead

because i don’"t thave the 2 led on the front of it, when i start him

Hi pimax_fr,

Have your problem:Pimax 4k-NoloVR in 2020-Not Working been solved?
If not , you can ask for help in ticket again.


1 Like

Hello thanks
my base stations is broken; the led not working i ask to the support and they send me a new one, and now works very cool

thanks !!

this topic is solved !

I can’t edit the first post to add [SOLVED]