Pimax 4K,missing driver, and not visible in PIplay

I have today recived my new 4k pimax vr + nolo controllers.
( actual you guys send me 2x boxes with nolo controllers )
And for the last 14 houres ( that is no joke ) i have been trying to make the headset work, but now i have kind of given up.
Status right now is that i have a blue light on the VR glasses and I can use it in steam VR in example a flight simulator, and i can see the Pimax logo… BUT In the PIplay software it say the VR glasses usb and hdmi is unrecognized and hdmi is disconnected.
( but it is working in steam, that is a bit odd ).
It does not help to remove and move the usb cables ect.

And in windows it say that a device driver is missing for BCM2045A0
I think the 4k glasses are firmware are up to date by the way.

I did manage one time to make everything work where i could see the VR glasses and nolo controlers in the Piplay software, but once i restart the computer everything went wrong somehow.
I also tried installing the mod that allow ocolus games to play on vive, named revive.
And somehow before i formated my computer steam,piplay and ocolus pop up and i hear usb connections turn on/off all the time and things went a little crazy… After this i format the computer and made piplay work and i could see my vr gear, but after restart everything fucked up again.

I tried formatting my computer 2 times and installing without antivirus, and with admin rights… it did not install missing drivers.
I installed ocolus rift software, Piplay, and steam.
Also the glasses seem rather dark when i use them in example DCS world/flight sim, and the text is a bit hard to read also, compared to my previous VR gear from Oculus.
Yes the image and distance vision is better than ocolus, but not the lack of colour / brigtness and is annoying and hard to focus and read the instruments due to some text being a little blurry.

PS… if someone could send me the missing driver then I would be happy to try it…:wink:

  • Help :wink:

Piplay v
Steam up to date 15 dec 2017
oculus up to date

My computer
windows 10 64bit pro ( everything up to date.
Amd x370 corshair ryzen 1800X ( 8 cores 16 threats ) 3600mhz
16gb ddr 4 ram.
SSD drives ( 2x500gb in raid 0 ).
windows on an M.2 drive
Nvidia Gtx 1080 with up to date driver. 390.777
No antivirus or firewall installed ( i am still installing software ).
Joystick x55 rhino


1 Like

I have added Pimax-support to your post. Putting @username helps to draw attention to your post.

Just heading home will look over your post better & see if i can offer some suggestions. Awesome details in your post. :beers::sunglasses::+1::sparkles:

Sorry to hear that your experiencing startup issues.

@LukeB might have some insights as he has a 1080 & hotas. @Sjef & @Enopho are also Nvidia owners among others who are very knowledgeable.

I think that you will need some input from support for this one.

I use an Intel i7 6700K 4.5GHz and ASUS Strix GTX1080 8GB with latest NVIDIA drivers and haven’t experienced any issues.

However, early on (around 9 months or so ago) I did try installing OCULUS Home and that did cause me some issues with stability and so I removed everything Oculus. Though that was a while ago and I haven’t tried it again. I don’t see the need.

Some have had success with Oculus software, but not me so I keep away from it. After all the Pimax 4K is not an Oculus Rift or HTC Vive and so I don’t expect that it will be fully compatible.

Most of what I use runs well under SteamVR and so I just stick to that.

I don’t have a Nolo unit (haven’t read anything good about it yet) and so make do with what works with either Xbox 360 and Saitek X52Pro HOTAS.
It would be great if some of the controllers Pimax is working on for the 5K/8K could also work for the 4K.

I don’t think the issues you are experiencing have anything to do with Windows so reformatting the PC is not likely to help. You need Pimax support to help get to the bottom of what’s going on.

You will need to install TeamViewer for Support to check your PC.
Good luck with it.

1 Like

Hello there.

Regarding piplay not seeing the hmd but still able to play in steamvr… That’s a new one and Pimax support will need to jump in there…

But regarding Nvidia and brightness.

  1. There is a brightness slider in piplay once pimax 4k is detected @Pimax-Support need your help here please

  2. Once pimax 4k is detected and brightness slider has been set high… If it is still too dark, you can switch to video mode in piplay and then open Nvidia control panel and then you will see the pimax monitor, click on it and choose use Nvidia graphics options… Increase Gamma, digital vibrance, brightness and contrast if needed. When your done click apply and then switch back to pimax mode and try your games… If still to dark, switch back to video mode and increase settings again…

  3. The latest Nvidia driver seems to cause micro stutters in a lot of games, has been reported in forums for Vive, Oculus and Pimax the best Nvidia driver for pimax is currently 384.94 (July 2017) driver.

  4. When you install piplay make sure that you dont have Klite installed, as this can affect the smooth install of piplay… If you do… Uninstal it prior to installing Piplay also during piplay installation will install Klite again anyway.

  5. Personally I do not plug in the hmd before installing piplay or windows will try to install drivers for it… I install piplay and when it gets to the part where its looking for the device I plug the hmd in… And it pretty much always goes in smoothly

Good luck



Hi @delevero, regarding the situation you have met, It seems that it has to do with USB driver and Graphics card driver in your PC.We suggest that you may firstly check whether you have installed fully USB driver and the Graphics card driver or not.
Regarding the color and brightness, there is the brightness adjustment in the Piplay software.
You may also adjust IPD (Interpupillary Distance) in Piplay setting. May I ask that are you farsighted (hyperopia) ?
Usually we recommend that nearsighted users with over 3 diopters or farsighted users to wear their prescription glasses for better VR experience.
Please also try the following solution:

If these still cannot work, Please send the ID&password of Teamviewer13 to support@pimaxvr.com
We are willing to help you with remote control.:slight_smile:

1 Like

Thank you all for the feedback.

But unfortunatly non of the suggestions is working, and i will ask for a refund.!
I tried reinstalling my usb software, all of the chipset drivers and my video card driver and such things.
I reinstalled steam, piplay, ocolus software. And i even tried making a fresh format of the computer and ONLY installing windows and computer drivers and piplay… the software did not find the headset. I later installed steam and Vr worked now and then… sometimes i had to restart the pc a few times for it to work. hmmmm
I even tried other solutions such as running the pimax firmware updater ( the stand alone version ) hoping i could update the VR glasses ( though it previous when i one single time was lucky to actual running piplay, that my firmware was up to date ).
I was able to run the firmware tool, and lights on headset flash all the time very fast now, and then i was ready for
updating the firmware, but I again and again get an error by the firmware software saying the update software
have a fault press OK to close…And when pressing the button to return to ordinary VR mode again, the update software also make a fault so now im stuck in firmware update mode forever.! wow.

Well I now spend about 18-20 houres trying to make this headset work, and It simply do not work out of the box.
I formatted my computer 2 times and installed everything 100% clean, 100% upto date drivers and windows 100% up to date and so on, and even then the piplay software or the VR 4k helmet worked properbly.
in general the software for the pimax have to many issues and bugs that im amazed anyone would official release it.!

I have reached a point where I do not want to spend more time with this shit, it is clearly not working out of the box
as any consumer would expect, and i even went far beyond installing and updating stuff and it still do not work.!
No consumer should experience something like that. Funny thing is many of the erros I ran into, i could see where reported here on the forum in 2016 but still are a problem for me today.!

I will ask for a refund by pimax and send everything back to pimax.
If they dont, i will be happy to share my review video with you, im sure it will be interesting to watch. :wink:

This crap have cost me allot of money investing in vive base stations and other junk,… The two times I was able to use the VR googles I could see the image was better than the ocolus and look promising, but to be honest the software is “shit” from a-z and I would call it in “early alpha stage” and conflict with to much and dosent work properbly… They should really stop selling the 4k glasses. I could not even find a driver for the headset that i coudl download anywhere, and not even inside of the piplay software that windows could use as a driver.!
I could not even find a driver on the website, or here on the forum.
even the guides that can be found here and there, as well as the manual link to download location and pages that does not excist anymore, many are outdated and photos and videos show older type of piplay software.
And by the way, in the above helpfull forum post if i drag the tool to (C:\Program Files\Pimax\PiPlay2), then it say that some dll files are not there… THe missing files are in C:\Program Files\Pimax\runtime by the way. :wink:

I will ask for a refund and that is it, enough is enough.
goodbye :wink:

Simple truth your experience is not typical. If you would consider support’s request for teamview they would be able to determine exactly what the issue is whether it’s something in your configuration or a defect.

The driver is in the headset (firmware) & part of piplay software install. There is no direct driver like your graphics card.

But its up to you if you don’t want the help offered. Checkout vrkommando & @sweviver reviews on tge 4k.

If you do decide to accept support’s help its 927am here at the time of this post. Its 927pm in china