Parallel projection not working when launching from steam VR home

I use Pitool 180 Beta and SteamVR beta.
Don’t know if anyone else has this issue, I noticed following:

  1. I set PP in Pitool, then Apply and just to be safe also Save.
  2. Start (or restart) steamVR (after PP was applied)
  3. I start application that requires PP (like Redout but also others)
    3a) When I start from steamVR home PP is not applied (double image)
    3b) When I start from desktop (steam) PP is applied (image correct)

This is bit annoying as now I finally have controllers it is more comfortable to launch directly from Steam VR home. On the other hand it suggests that it might be possible to work in both modes without restarting steam VR, which would be great if true.

1 Like

SteamVR needs to be restarted when toggling PP.


That’s why I put step 2. there. SteamVR IS restarted after applying & saving PP in Pitool. After that, if I run from steamVR home, PP is NOT applied, but if I run directly from steam, then PP is applied.

1 Like

Sorry. Didn’t read it all. My bad… :wink:

That’s really weird. I’ve never experienced that.

I always start start SteamVR from PiTool but always thought it was just a shortcut.

I mostly run either PP on or off sessions and start games from SteamVR dashboard.

I suspect this did not happen (correctly). When the SteamVR starts (correctly) it reads the headset data and if PP is on, it cannot magically turn it into off.


You are probably right, yesterday it worked from steamvr home (though this time I started steamvr from Steam instead of from Pitool).

If I have some time maybe I will try to see if I can reproduce it consistently (or if it was just temporary glitch).