Oculus Rift games without owning a Rift or Rift S: how?

Hey folks,

I see in the Pimax Experience that we can launch Oculus games, so I installed the software for the Rift S and also one of their free games to try it out. I started PiTool and it already saw the game, so I launched it. First off, it was laggy, which is probably due to my machine, so I will lower the video settings before I run it next.

I don’t see any controllers (I have the Sword controllers) on-screen. I assume Oculus has no idea my controllers exist. How can I get them setup? Any ideas? I assume most people running Oculus games are hardcore enthusiasts who already had a headset. So setup you did won’t necessarily apply. For example, if I try and setup a headset, it obviously doesn’t detect the Pimax as a valid headset.

Which makes me also wonder if there is a room setup I should do similar to SteamVR.

I’ve seen a video posted on here, but they were using different controllers. I don’t know whether that makes all of the difference or not. I did notice that the banner at the top of the Oculus app had the same prompt to setup the headset and controllers, so obviously, whoever did the video didn’t have to.

Anyway, if anyone has done this before, I’d appreciate some tips. Or perhaps I’m SOL with the Sword controllers?


I managed a work-around, which was to use Revive and launch using that. I think buttons were remapped a little, but at least they worked.

As for being laggy. It was my bad. I had crypto mining still running. Forgot to turn it off.


crypto made me laugh

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.