Obduction 1.8.0: Promising Update (PP no longer needed)

FYI - There was a big update to Obduction Yesterday :slight_smile:

Just tried it to see if the shadow issue and/or PP was fixed but I don’t get any visuals at all on the Pimax, just “black” background (I do see the world moving on the monitor when I move the headset though)… :frowning:

UE4 upgrade to 4.21.2

  • New saved game path location for Mac users - this change is being handled by the UE4 engine and not Apple’s macOS (*see additional notes below). Save games and config files are now stored in: library/applicationsupport/epic/obduction

  • Performance improvements

  • VR Improvements:

  • Ability to backstep while using VR teleport

  • Index and Index Controller support added

  • Windows Mixed Reality (via SteamVR) support added

  • Turkish [fan] localization added

Support for canted displays came in UE 4.18 but I’m unsure if Cyan would have to change something in their code to make it work?

  • Added support for non-parallel projections for HMDs that have canted display panels

EDIT: They mention the shadow issue so guess they haven’t fixed that:

Ambient occlusion differences in each eye visible in some areas:

  • Under some conditions, a difference in shadows and lighting can be noticed in each eye in some VR headsets.

Could someone else give it a go and see if they’re getting the same result? :wink:

EDIT2: Seems it might be a “local” issue on my install as it works for @brian91292 (even without PP enabled)… :wink:

EDIT3: Strike that. Lots of other people have chimed in, saying they have the same issue as me… :crazy_face:

EDIT4: Seems like it’s fixed in latest PiTool ( FW 255):

EDIT5: Still the same issue for me as soon as I resume the game (menu is fine) and I can still see the little loading icon shortly when I press the menu button for example.


@Heliosurge could You maybe split this topic? :slightly_smiling_face:

I think we need Pimax to look into why Obduction doesn’t work with the latest update.

EDIT: Doesn’t look like a Pimax issue after all.

1 Like

Give me a list of posts & will split topic

1 Like

I was thinking from the update announcement and on?


New thread could be called:
Obduction 1.8.0: Promising update but apparently breaks compatibility with Pimax.

1 Like

Thanks @Heliosurge:+1::wink:

1 Like

The game works fine for me… Didn’t have to do anything special.

1 Like

Did You just install it or did You upgrade it?

Are You on PiTool .180? SteamVR beta or stable (I’m on beta)?

I wonder if it will work to remove/re-install it for me?

I just did a fresh install, and yes I’m on the .180 beta. Also using the SteamVR beta branch.

Doesn’t even seem like parallel projections are required to me.


Nice! Guess I’ll have to try a reinstall of the game then… :+1::slightly_smiling_face:

1 Like

One thing to note: it doesn’t seem to allow me to launch the game through PiTool, I have to launch it directly through Steam.

Launching through Steam presents me with this window:

Whereas when I launch the game through PiTool it just shows an Obduction splash and instantly closes.


I’m also launching it through SteamVR (choosing HTC Vive).

I’m using the following options in PiTool:

1 Like

Same, not sure what could be going wrong for you. I’m not using smart smoothing- maybe it’s that?


Might be. I’ll give that a go too after reinstalling it. Thanks :wink:

EDIT: I’m on 72Hz and You’re on 90Hz, but I’ve tried using 90Hz too but not without Smart Smoothing.

1 Like

Reinstall didn’t help either. Also tried disabling the custom resolutions I’ve added for vorpX as I thought that might have something to do with it, but no dice there either.

That sucks, not sure what to suggest. I can save you some time, though- the game is still incredibly bad in VR and I was sick after playing it for 5 minutes. Still would not recommend.

The optimization seemed a bit better than it used to be, but the game is just so poorly done in VR that nothing can really fix it other than a total redesign of the controls.


Thanks, but I already played 5 hours with the shadow issue… :grin:

I wrote a mail to support@cyan.com hoping they can give me a hint as I know there has been issues with no image in HMD a long time ago (when they launched the VR feature of Obduction).

Told them I could send them debug info if I was given instructions too… :wink: Fingers crossed.

Just tried the old version in “publicpreview” and that works but PP has to be enabled.

Next up: Try new (1.8.0) version without ReVive installed even though it shouldn’t be used at all.

EDIT: Didn’t work with ReVive removed either.

It doesn’t work for me either. I choose new game and then play and no display in HMD anymore.

@brian91292 I only get 2 choices by launch not 4, are you sure that you are on 1.8.0?

1 Like

You get two choices when starting from SteamVR dashboard, but 4 when starting from Steam game list… :+1::slightly_smiling_face:

Thanks for reporting in.

FYI: Gave Cyan support a link to this thread.