No display in 4K HMD

System specs
win 10 64bit
i5-2500k CPU
It is a while since last used my Pimax 4K and at that time it worked perfectly.
I came to use it today and there is no display in the HMD and the green LED is lit but does not change colour.
The HMD is connected to a HDMI port on the GTX1060 and the USB3 connected to a powered USB3 hub.
The Piplay software detects that the HDMI cable is connected.
Can anyone offer any advice please?


1 Like

Mine does the same thing with Pitool. If I use the old PiPlay software I can at least get the blue light but SteamVR wont connect to headst or something like that. Alos I get black borders , like shaders, on either side of the lenses. Its sad because I can still plug in my OG Vive and play but Pimax decided not to support their 4K. Sure they will try to help resolve situations as they come up but nobodys making sure that they are gonna work next year.

1 Like

What does your serial number begin with 100xxx or 102xxx ?

1 Like

@Enopho @TheDeaX or @Century might be able to recommend a pitool that works best.

Serial number is 102xxx Piplay checks show both software and firmware are up to date.
If I switch to video mode i do get an image of the desktop in the HMD

Well, I haven’t launched Pimax 4K for a very long time, so I can’t judge the relevance of suitable versions of PiTool. But now it works with PiTool 1.01.258, which was installed last.


1 Like

There is one way to remove the black borders around the edges of the P4K.

It is necessary to replace two lines in the file C: \ Users \ Username \ AppData \ Local \ Pimax \ runtime \ profile.json, setting their values ​​to zeros:

"fov_level" : 0,
"fov_outer_adjust_degree" : 0

Then you need to save this file and set the “read-only” attribute so that the values ​​do not return when you restart the piservice.

After restart service, the black borders will disappear :beers:

1 Like

More information.
If I have PiPlay running and replug the USB3 connector what looks like an alien landscape flashes in the HMD, the LED flashes blue, this lasts maybe a minute then the display is black and the LED reverts to RED
If I click on the link icon in PiPlay it states USB and HDMI are connected.

Add images

Tried the HMD on another PC with a Radeon graphics card and it worked so now i have to figure out why it won’t work on the much beefier PC it has been working on for ages.
I wondered if it was the latest Nvida drivers so went back one step but that hasn’t cured the problem

Is your 1060 have the firmware bios update? They released a firmware update for dp1.3/1.4 features.

I have just installed the 1060 firmware update Heliosurge and the problem is still there.
Looking at Pitool (v1.0.1.132) it appears that the HMD is connecting and disconnecting with error codes of 10600 & 20300.
I have tried the USB3 connector on both the mo/bo and a powered hub, no change

1 Like

Might need to file a support ticket.

OK. Thanks for your help

1 Like

Finally solved, phew :slightly_smiling_face:
I was using a 3ft HDMI cable: plugged the HMD directly into my graphics card and the HMD worked as it should. So it would appear I need a replacement HDMI extension cable.
Thanks for everyones help.


PS Is it better to use Pitool rather than the original PiPlay program and if so is v 1.01.132 the best for the 4K?


Is your Pimax 4K unit working?? Im having issues with mine :pensive: . Can you tell me what Pitool version and what firmware your using. Thanks!

1 Like

I hope @Enopho and his family are well during these troubled times as he could likely give some good recommendations if he is still running his p4k.

@Century might have some good input as well. Last p1 firmware I believe was 265? I do recall some recommending pitool 132 for the p4k.

1 Like

I was on the old “recommended” PiPlay software, cant remember version, for the 4K to reduce ghosting. It worked good until the shader issue plagued me…

1 Like

@stixvr firmware is and PiTool is
I found the PiTool version in another thread but I see Century is using V


Well sadly I think I’ve given up :sob:
My Pimax 4K now just shows a green LED and no display despite Piplay and Pitool confirming that the HMD is connected.
I’ve tried replugging the USB and HDMI cables, I’ve tried disconnecting other monitors connected to the GTX1060 apart from the main monitor.
I still don’t understand what changed since it worked correctly but it means I’m now VRless until I can afford a new HMD

I guess my Pimax 4K has finally died, unless a Pimax guru can advise otherwise.
This is the display I now get, still plugged into HDMI on my GTX1060 and a powered USB3 hub.