New Pimax 8kx firmware no screen & no audio with optical cable

I just got a 8kx and replaced the stock cable for the optical cable and the screens never turn on. The stock cable works…

please note this optical cable works flawlessly on my 5k super…

I also have no audio. DMAS headset

1 Like

Are you by chance have a Gigabyte card? Does the copper one work?

1 Like

gigabyte rtx 3080

im having a lot of issues with this 8kx… didnt have any of these on my 5k super.

The revised 8kX seems more finicky. I have observed posts of people having some different issues with Gigabyte Aorus cards things like Fiber Cable not working but copper og fine.

I would suggest filing a ticket and see if they can try a remote session.

Reflashing the 2001 FW might also work as your unit may have a bad flash.

1 Like

alright i’ll hit them up

1 Like


Did the error 10936 pop up?

Please file a ticket and allows our tech specialist to reflash the 2001FW for you.


i know how to use the flashing software. i’ve done it with my 5k super before

this is the strangest thing. i was able to get audio to work on the origional cable after some tickering. I dont remember how i got it to work but changing cables broke the audio again. I was having audio issues and still am.

1 Like

yes error code 10936 sometimes i can get video and sometimes its completely dark.

1 Like


Some users have reported the same error code, our tech team is analyzing the logs and finding the ways to address it.

I had everything working perfectly for an hour. turned the headset off and turned it on again and it would not start up. then I somehow got it working again and bam no audio at all. what is happening?

I’m having the same issues. power-cycling the HMD repeatedly eventually turns the screens on. Pimax suggested that I disable the screen saver option within PiTool, haven’t verified if this works yet.

I also wasn’t getting audio with the DMAS. I went into windows sound settings (right click on speaker in systray) and changing the Pimax audio device from stereo to 5.1 seemed to fix it for me.

1 Like

heyo ima need some help. support gave me firmware


to flash to my headset. I flashed the headset and now it atleast turns on each time but I get bad artifacting on my right eye only. whats goin on? this firmware cant be the same as the one that came with my headset. i didnt have this issue before.

1 Like

I sent an email to support on the issue. And it is confirmed to be happening on both my original cable and the optical cable. so its not cable related…

1 Like

alright im gonna have to pull out my rtx 3060 media pc with known good usb ports and amd 3600x instead of a 12900k. this pc is rock solid stable. if this doesnt fix the problem then i will wait for a response from pimax.

1 Like

update: on two different systems with two different cpu manufacturers and two different gpus and two different cables I get the exact same artifact on the right eye… i give up. this must be related to the firmware i received from pimax support because this was not happening before.

1 Like

just showing for any doubters


i’m an engineer so i know how to diagnose stuff pretty decently. went into the forum and found two different firmwares for the 2001 version of the 8kx. version


is supposedly the firmware that ships with the headset and is confirmed to not be 299 but is in-fact 2001. this solved my artifacting issue perfectly. however… the headset does not always turn on when the power putton is pressed and pitool is open. these are the same issues I had before. so I got things from this experience.

  1. the firmware pimax support gave me fixed the headset not showing up on every power button start. but this firmware introduces artifacting in both eyes.

  2. the audio issue I was having before was related to firmware wanting 7.1 surround for some dumb reason

  3. pimax needs to fix the headset not always turning on when needed. this is a MASSIVE issue. you need to restart the headset about 3 times in order for both the headset and displays to turn on. there is an issue where the headset is on but the screens do not initialize.

  4. I kinda picked up on this before but sometime the microphones will spaz out on the headset and show up as random spikes with the original firmware. I didnt test this on the firmware pimax sent me.

I will relay this information to pimax.


Agreed they need to be properly testing Firmware before releasing it. And step up hmd testing during mfging.

Interesting that one of the 299 flavors seems to be 2001. One of the auto updating 299 firmwares bricked my old 8kX model and to get rid of baggage it left had to flash 296 to clean it as flashing 298 I had SteamVR crashes. 298 prior did not give me this problem.

Debug 296 fixed it. Should be able to install 298 again.

1 Like