New Pimax 8K not tracking

Here is what works for me: When HMD loses tracking and will not be found by lighthouses, delete lighthouse directory and restart service as described above. THEN, move HMD out of view of lighthouses completely. THEN bring HMD back into view of lighthouses. Tried it several times and was able to get to work every time.

4 Likes

Thanks. But does it happen often? I have never seen this problem with the review units, nor the m1… :thinking:

1 Like

Not really. I never lose tracking once acquired. If PiServer can’t find the HMD at start-up it is usually enough to just move it out of sight of the lighthouses for 10 seconds and then back in view.

2 Likes

You know, this is the good thing about being backer 6XXX : fortunatly all these ‘early backer’ problems will be solved by the time (march 2019 ?) we will get our Headset :wink:

1 Like

That almost sounds like M1 had better tracking signal due to thinner plastic. Not sure, but this might explain it.

2 Likes

I have created a batch file that will go through this process (except restarting your PC).

It is untested (I don’t have PiTool or my headset) so I would appreciate if @anon33864247 and/or some other code monkeys would take a look at it.

EDIT: It is extremely ugly but heavily commented. Who knew that commenting in a batch file would look that bad.

EDIT Here are the contents of the batch file (in case the Dropbox link gets broken at some point). To make your own batch file just copy the contents into a text file and change the extension from “.txt” to “.bat”.

REM Everything after REM is a comment.
REM https://stackoverflow.com/questions/11269338/how-to-comment-out-add-comment-in-a-batch-cmd

REM Variables in case of future changes
REM https://stackoverflow.com/questions/10552812/declaring-and-using-a-variable-in-windows-batch-file-bat
REM https://superuser.com/questions/284342/what-are-path-and-other-environment-variables-and-how-can-i-set-or-use-them

set LighthouseConfigLocation=“C:\Users\%USERPROFILE%\AppData\Local\Pimax\runtime\config\lighthouse”
set service1=“Piservicelauncher”
set service2=“PiService”
set Service2Location=“C:\Program Files\Pimax\Runtime”

REM This deletes Pimax’s lighthouse configuration files
REM https://stackoverflow.com/questions/1502913/how-to-delete-all-files-and-folders-in-a-folder-by-cmd-call

del /q %LighthouseConfigLocation%*
for /d %%x in (%LighthouseConfigLocation%*) do @rd /s /q “%%x”

REM This restarts service1
REM https://www.coretechnologies.com/blog/windows-services/essential-tools-for-windows-services-net-command/

net stop %service1%
net start %service1%

REM This restarts service2

net stop %service1%
REM net start %service1% &REM This command will restart the service.
%Service2Location%%service2%.exe &REM This command will restart the service from a specified location.

4 Likes

Thanks! Very confusing though in my case: moving HMD out of view and then back into view worked for me, but so far only once. Tried to repeat the action after restarting the PC (head tracking was lost again after that of course) several times and couldn’t repeat the initial outcome.

1 Like

Thank you for your advices,
For two weeks I was travelling and did not have acces to my pimax.

I have purchased and installed an additional USB card (Inateck) installed PiToolSetup_1.0.1.84, but my pimax is still stuck in black (black screen, black led), I was not able to turn it back on.

I have tried to set the pimax headset in dfu mode as described by @SweViver on his 1st november video:

The led color did not change (still black) but I still tried the dos command only to get the message “0 Device(s) found. Plug your DFU Device !”

I tried connecting the pimax to a second computer but it is not detected.

I have once again measured the voltage out of the power brick. It is about 12V.

I have reached out to pimax support and will wait for their answer.

1 Like

Have you heard back from Pimax support? I haven’t. I sent them an e-mail on Friday.

@Pimax-Support @Sean.Huang @Matthew.Xu the 2 gentlemen sbove need your assistance.

2 Likes

Dear @Ronanbuzz, Dear @SweViver,

I’m very sorry for the inconvenience.

I need to trouble you, please submit your question to the service desk.

We will transfer your questions to our technical engineers, who will help you solve them as soon as possible.

http://feedback.pimaxvr.com

Thank you very much.

1 Like

SOLVED!

Hey guys.

I have a big issue.
Got my Pimax 8k now and I’m using Pitool 1.0.1.84

My lighthouses and controllers aren’t detected.

I tried all current versions of Pitool like 76, 84 and even 90 and the best 1 to use is 84.

I got a “not disconnected” status on 76 and if I try to update to 90 it always gets the message that the files are corrupted at …/user data/local/temp/ ,which are not actually. So now I stay at 84. How ever i also tried to solve the Lighthous issue by flashing the firmware but nothing happend. I pluged the pimax into another PC with another GPU and another 2 lighthouses but they also weren’t detected by pitool.

So my guess is its not my PC its a software issue.

But what exactly…?

Any advice?

Cheers Hank

1 Like

Did you try deleting the lighthouse config directory, as discussed earlier in this thread? That seems to be needed for most people. Pimax really needs to fix this by the way @Sean.Huang @Matthew.Xu

1 Like

Yeah I did. No effect at all. Even with different LH from another Vive didn’t help…

1 Like

Well I just had the exact same thing. Couldn’t get it to work. Manually stopped the piservicestarter from the services list, killed all other pi*.exe from task manager, restarted the service, nothing … Then did it again and then it suddenly detected the LH’s … It’s buggy for sure.

1 Like

Oh by the way, did you go to help/diagnose in pitool? See if that gives any errors.

1 Like

I did the solution with the service restart but no effect at all. Btw. If I quit the Launcher from the Task manager every .exe file gets closed but pitool exe. HMD gets detected but still no LH nor Controllers are detected. Pimax realy needs to fix this issue.

Btw. My Rig:

CPU: I9 9900k
GPU: 1080ti
Ram 16Gb @3000Mhz

Could there be something wrong in the bios?

1 Like

In pitool go to help/diagnose and see if it reports any errors, did you try that already?

1 Like

Initializing or reinstalling os will fix the problem

In the diagnostic there were no issues. Everything passed.
I reinstalled windows again from scratch. So the only installed elements now are Google Chrome, Pitool, Steam with Steam VR and some Windows updates (not fully complete since there are tons of it to download)

In the windowslog I found an error 7030.
Translation: “PiServiceLauncher” is marked as an interactive service. The system has been configured without possible interactive services. The service may not work properly"

My newest guess is:
there must be an issue with the PiService.

@Sean.Huang @Matthew.Xu @Pimax-Support

2 Likes