New 8k+ owner - I'm a bit disappointed

Hi, I’ve just received my full bundle ordered from the Pimax store and have encountered some ‘issues’…

1st issue - I had a less than pleasant experience getting the bundle here; the headset first of all - FedEx charged me on 2 separate occasions for import duty and VAT, first £173 then £251 and to top it off, the Index bundle arrived with another tax demand of £114. So on top of the Pimax store purchase price of $1800 which included $310 for VAT, I’ve paid an additional £540.06 ($683) in tax! Pimax have promised to refund the original $310, but even still I’ll be out of pocket twice that amount.

2nd issue - ran PiTool for 1st time and it flagged an update available. No problem there, downloaded and installed the PiTool update. It also showed a firmware update for the HMD, so ran the update. Left it running and checked back a few minutes later to see a dialog box stating that the update had failed and I should contact customer support. ffs great start. However everything seemed to be working; the headset showed the latest firmware as being installed and it was tracking. Maybe just a bug in the updater.

3rd issue - fired up SteamVR and put the set on. Really bad out-of-focus image. Play about with the IPD settings for an age and unable to get an image that doesn’t feel like it’s destroying my eyes. Take the set off and go away and do something else for a while. When I come back I wind the mechanical adjustment to its minimum setting and reset the software setting and I’m able to put the set on without feeling dizzy. Okay getting somewhere now.

4th issue - fire up War Thunder and fiddle for hours trying to get an image better than my Rift S. In the end I get something that resembles what I get with the Rift S, but I was truthfully expecting way better. Detail is still lacking; in cockpit is perhaps not as sharp as the Rift but then I can enable SSAA with the Rift but the frames drop unacceptably low with the 8k+ when I try that, distance detail is comparable. Not what I had hoped for at all.

5th issue - there are ‘glitches’ when in VR with the 8k+, like the tracking is not 100%; something I’m not used to with the Rift S which is supposed to have an inferior (for accuracy) tracking solution (inside-out).

6th issue - if I change anything in PiTools and reset SteamVR, chances are it won’t restart and I need to restart the whole PC. Quite frustrating and exhausting when you’re trying to fine tune performance…

So on the whole, quite a disappointing experience with the 8k+…I’m really questioning my purchase decision…

Edit: my system specs - Rysen 7 2700x @3.9GHz, 16GB DIMM DDR4 3000 MHz clocked @ 1500 MHz, Gainward Phoenix RTX 2080Ti, Samsung 970 Pro NVMe PCIe M.2 1TB

4 Likes

What is your IPD? Are you something like 58-57mm? If so, you will need to go to the Pitool and play with the IPD offset option

2 Likes

It will be way better than the Rift S, but you will have to tinker some more. The pimax headsets will generally get you the best clarity but take a degree of configuration.

Change the IPD software offset, also experiment with vertical offset until you have a picture that feels true to you geometrically and eye strain wise. I have my 5k+ set to the minimum mechanical and then with another -1.5 software and -5.5 on each of the vertical offsets. But this is very particular to each individual user.

Make sure you have changed the maxrecommended resolution line in the steamvr config file. You’ll find instructions on this forum if you search. Start with normal FOV in Pitool because large can be tricker to get working well. Next, turn off auto resolution scaling in steam and manually set both pitool render scale and steam resolution scale. Look at the reported render resolution in steam, it should be around very roughly 2,500 by 2,500 at the very least, potential up to much more than that, around 3,000 odds.If it isn’t, manually scale it until it is. Make sure you have catalyst set to zero if you have stutters. Next start at 90hz in pitool to make sure it isn’t auto scaling to hit a high hertz target.Test a game that doesn’t need PP turned on.

See how you get on with that lot then report back.

8 Likes

This:

Otherwise, SteamVR won’t let you use the full resolution of your 8K+ and everything will be blurry. It’s a real pain-in-the-butt. Here’s info on what you need to do…

8 Likes

If you have the Rift S I thought That you did not need Steam VR. I have the S and use the Oculus software. I’m thinking of getting the 8k and I thought that you could run both types of games (Oculus and Steam) using pitools. What do you software do you need for X plane?

2 Likes

I had this too with the pimax 8kplus… ANd also the focus issue because i could get close enough too the lenses with the comfort kit…

1 Like

Best use some area to test it under constant conditions. Like @john2910 said, I also had to use a different foam because otherwise I could not get a view as sharp as the 5k+.
If it is setup right you do get a nice image.
Its just a bit more tweaking.

3 Likes

X Plane can run in Steam if you got the steam Version.
Like you said the nice thing with Pitool is that we can play almost all the games, I did play Asgard Wrath, Lone Echo, Vader and Stormland that way.

2 Likes

Thanks https://community.openmr.ai/u/Fitzy, yes I did already set the maxrecommendedres in steam to 8192 and set the render scales manually; PiTool to 1.75, steam to 100%.

Apologies, I have tried everything I found but didn’t add to my OP as, well I was pretty knackered by the time I wrote it.

In PiToold I had set the FOV to potato, scaling to 1.75, tried all the refresh rates and settled on the 72Hz to give the best chance of hitting that. FFR at aggressive, PP on, FF on. In War Thunder res set to 25x14, all AA off and the rest set to Sweviver’s setting he used with his 1080Ti.

Lastly I tried ED and wasn’t really blown away again.

I should also say I need glasses to game, I’ve tried with and without and really do need them, so I’m sure that will have an impact on focal distance…

1 Like

Did you get that sorted?

well I had tracking issues recently with my 5k+, while index was tracking ok, Im not sure what was the solution, but I unplugged all usb devices from the bandwidth where pimax was plugged in, also try to disable catalyst setting as was recommended above, there also was lot of information regarding correct light houses positioning, try to be at least 1-2 meters away of LHs & put them as on starter pitool guide (3x4m square, 5m diagonal) or something close to those values. Try to do room setup with exited steam vr then.

At least for me tracking started workng then, also I noted that on my HDM at 65Hz it works not as good as on all other modes (90,120,144)

Try pushing the resolution up higher. Disable FFR.

Have you experimented with software ipd and vertical offsets yet?

No i sold my 8kplus,i had still eyestrain(could get close enough to the lenses with the current design) and didnt like the colors at all

Also the tracking was not as good as my valve index

2 Likes

I use one base station and found that tracking is not great like 5k+ and 8k, it always has jittering, still wait to test with 2 base station.

1 Like

Yes I spent some time with the IPD today and set it to minimum value mechanically and -1 in software. I also adjusted the vertical offset to max. I took my glasses off and tightened up the straps to pull it into my face and I was able to get into the sweet spot. Just, but it’s rather uncomfortable.

I was able to force War Thunder to render the world at 2x scale and things improved a lot, however I’m not sure this won’t also do the same for my Rift S, I’ll check tomorrow. But with that set, PiTool to 1.25, potato, 72 Hz, FFR agg and smart smoothing on and SteamVR set to manual 100% and no supersampling, I was able to achieve quite pleasing fidelity at just under the target 72 frames.

Still not blown away though…

2 Likes

My tracking issues disappeared completely when I got my base stations high in the air angled down and covered my mirror. When they were at body level I had weird issues.

1 Like

Why would You be “blown away” with Potato FOV and 72Hz? That’s like using a Quest.

9 Likes

Try taking the velcro face cushion off and see if that improves anything in terms of sweet spot and sharpness.
I have never used potato mode… Do you have Alyx or Asgard Wrath? The Sims I play are almost all not that great in performance since most seem to be more or less single threaded and ancient API orianteade and have poor VR performance.

5 Likes

Yeah, I think OP needs to try some different games.

And agree with above. Why use Potato FOV, it’s a joke mode not really intended for use. Why use FFR aggressive as well? Especially with such a small FOV, how much screen space will be left for the high resolution focus point on that FOV? Start testing at normal FOV, 90Hz, FFR off, and go from there.

4 Likes

Basically, potato, 72Hz because that’s the only way I can get an acceptable frame rate. I play mainly War Thunder and that’s what I wanted to upgrade my VR experience for. True I haven’t tried much else as I’m truthfully not as interested in them. I have finished downloading HL Alyx so can try that of course.

FFR and smart smoothing I have on in an attempt to increase frames. I’ll remove FFR and see what the difference is if any.

In terms of FOV, I agree more is better but I’d prefer a sharper image over FOV if that is what’s required to get it. I should also say that gives the same FOV as the Rift so A) I’m used to it and B) it provides a good comparison.

I am a little hesitant to remove the face cushion as I’ve heard some have damaged the set by doing this…

1 Like