My 5k plus headset cannot power on

No light at all , already plug in adapter and usb+ display port cable. Pls help , get it this morning

Is there any led or has the light chevron on the front lit up? Or do you mean nothing in the headset is on?

Does pitool say it’s connected?

Do you have lighthouses as well?

Pc spec please… Including pitool version and firmware?

Have you restarted since connecting the hmd?


1 Like

no led light up , even I pressed the power on button, the pitool say disconnected both usb and dp 1.4, computer is old gtx 660 pitool is the newest version . Had tried restart but same.

That is a really old card and im not sure that it will work - it might be disconnected because it does not meet the minimum requirement. A 1070 would be a minimum for a 5k+ I would say.

1 Like

@Sean.Huang @Alan.sun @Doman.Chen

Please check this problem and solve this issue

can the dp1.4 changed to hdmi?

you mean that I plug In the adapter but still no power on the HMD? No led on the HMD !!!

You will need to wait for the pimax support to reply as I don’t think your 2gb card has enough power to run the pimax 5k+.

But from past posts in this forum, a gtx1050 (6gb) card will struggle to run a pimax 5k+…your 2gb card may not be able to power the headset.


1 Like

I got gtx 980 ti at home. Just want to know the led of the HMD. it need to load the pitool to make it light up ? if not , the HMD itself had problem .

1 Like

just go home and test. No led at all even in 980 ti win 10 .Very poor QC.

Mine cannot light up and no response. Like a dummy sample… Can anyone answer me how to do ? Horrible experience.

The minimum specs for the 5k+ GPU wise is a 1070… it is shown on the website

So even if you get it ‘lit up’ the GPU may not be able to run much if anything. you are now saying that you have a 980ti card but when you 1st posted you said you had an old GTX660?

a 980ti is still a 6gb card and a 1070 is an 8gb card, it is below min spec but there is no harm in trying to get it working - it may not work though!

1st of all, are you plugging the P5K+ into the GTX660 as you 1st mentioned or are you plugging it into a 980ti?

Make sure you are plugging the video port of the HMD into the dedicated GPU card (the higher the cards spec the better), make sure that the video cable is pushed all the way in at the HMD end as we have seen a few where the cable was not fully plugged in (HMD end)
make sure that the power adapter is connected properly and there is power going to the unit. plug the USB cable from the HMD into a USB 3 port (if it is not detected as a USB device try other USB ports (we have had a few HMDs that did not get detected on some USB ports)
ensure that your WIN10 machine is fully patched and has been rebooted.

when you installed pitool did you have any errors during installation?

also note that this is a community forum… we dont work for Pimax, but we do help out where we can… just because someone has not replied to you in the 2 hours you posted follow up questions it might be because we are dealing with family or other RL issues… be patient.


1 Like

Most likely the power cable. You can get a 12v power cable in Amazon. Someone posted a link to it. There were a few that had the same issue then it got fixed when they changed the power cable.

1 Like

Yes most likely the power supply. But is also going to struggle with gpu.

Finally I powered the HMD with c type charger. Then the HMD light up but always flashing with screen. Now Ican see picture from the HMD with flashing. Can someone help ?

The headset with only wall adapter plugged into headset cable (not connected to pc) the led by power button should show red.

Gtx 660 will not be powerful enough to run the headset…

980ti has been tested by @fresco with decent results in some titles. SkyrimVR is reported to work well on this gpu.

1 Like

Your wall psu is likely defective. If you have one that is 12v 2amp min it should work.

1 Like