MSFS & SteamVR not starting in Pimax PE


I received a Pimax 8K X and I am having a terrible time starting MSFS. I have managed to get X-Plane to appear in the HMD and have flown for a couple of hours but I am not impressed with the lack of crispness that I was expecting so I would like to try MSFS to see if it appears better in the HMD.

I successfully imported the .bat file into PE and started MSFS but SteamVR starts with an error saying that 2 Add-Ons are blocked - They are Pimax and Gamepad Support. Once I select “Unblock All” I am asked to restart SteamVR and the errors continue. I am faced with “SteamVR Fail” asking to restart SteamVR again and then the first error appears saying the 2 Add-Ons are blocked and this continues in an endless loop.

I have tried the following which was suggested by @coverman without success.

I have OpenXR installed and I am at my wits end. I have been at this, according to SteamVR, for 76 hours over the last 2 weeks. I have not been able to get a clear view in X-Plane no matter what settings I try and no matter how much I adjust the IPD manually and by using both PiTool and PE.

This has been a very frustrating exercise so far. I would welcome any suggestions.

I have the latest version’s of PiTool, Pimax headset firmware and SteamVR.

Thanks in advance.

Hi Robert, i’m not sure if youre aware of this, but msfs does not start in VR. You need to start the game in 2D mode then once you get to the menus, press ctrl+tab which takes you into VR.


Yep. It’s frustrating. I’ve reported the problem to Pimax, along with logs. You have a few options:

  1. Unblock the errors, but do NOT restart SteamVR; just exit it. Reinstall PiTool (same version). No need to reboot or anything. SteamVR should now work for a while, but will probably refuse to start and display the same error eventually. When that happens, repeat the procedure.
  2. Uninstall PiTool and install PiTool 270 or earlier. Do NOT upgrade, if prompted. You might need to manually flash your headset (using DFU), but I didn’t need to.
  3. Wait for a new beta firmware and/or PiTool. I was told that a new beta firmware fix for the 8KX would be released soon, but it’s already been a week, so I’m not expecting anything in the near future (but I’d like to be wrong).

I’m currently using solution (1), but (2) is a lot more convenient (and I used that for a while). Note that 90 Hz refresh support is in the firmware, so you can use 90 Hz refresh if you use a newer firmware, even though PiTool 270 didn’t originally offer firmware with that mode.


@tykey6 and @neal_white_iii, thank you so much gents for your answers. I was able to enter into VR mode using @tykey6 's method but MSFS hung when I started PiTool and SteamVR first so I started MSFS first then PiTool and SteamVR from the main PiTool Status screen and then pressed Tab + CTRL and finally VR mode started. I will attempt the other options and see how that goes.

Like X-Plane, MSFS appears grainy and over exposed so I will have to find settings that are suited to both sims. I currently have a nVidia GeForce 2080Ti GPU and a i9-9900KF CPU, would upgrading to a nVidia 3080Ti make a difference?

Thanks again for your help!


To fix the overexposed issue, in PiTool, try adjusting the backlight brightness (mine’s set to 90) and the Contrast (+1) and Brightness (-1). Those 3 settings can be adjusted while the game is running; no need to restart the game or SteamVR.

Yes, a 3080Ti would allow you to increase framerate / graphics-quality / resolution, but maybe not all 3 at once. I have an overclocked 2080 and an i7-8700K with 32GB. MSFS is on a 2TB NVMe. I have PiMax Quality at 1.0, SteamVR at 100%, and in-game background at 50%. I also use Small FOV when playing games which require Parallel Projection.

I suggest trying some of the settings above before buying a new video card. Personally, I’ve decided to wait for a 4080, which is rumored to be a real powerhouse and will hopefully be available by the end of 2022. It’s also supposedly a power hog: up to 600 Watts. Be sure to save some money for a new power supply. :grin:


@maxam about the grainy and over exposed visuals in msfs, this is an issue with vr in general, on the msfs forums you’ll find users of hp reverb g2 and quest 2 complaining about it too, its not limited to pimax hmd’s. its very frustrating.

As neal has suggested you might be able to counter it somewhat in pitool. A 3080ti will improve your fps and allow higher graphics settings but i dont think it will solve the over exposure. Really, MS/Asobo will have to do that for us.


When I was using the Cyborg RumblePad before, I got into a similar stop loop.

In my case, that happened when I used that gamepad with rear USB ports and USB hub.
The front USB port was fine.

It is safest not to use a gamepad.

  1. Remove the gamepad you are using

  2. Make sure PIMAX & OSVR & GamePad Support is turned on from Add-on Management.

  3. Try the MSFS2020 & PIMAX & steamVR startup check.

I bought another gamepad and connected it to a USB front port.
Currently no trouble.

1 Like

@tykey6 @neal_white_iii @coverman - Thanks for the feedback. I will give the settings a try.

Can someone search their C:\ drive using the cmd prompt and tell me where the openxr folder containing the 3 .json files are located? I read that some issues can be resolved by deleting the openxr folder and I copied it to my docs folder for safekeeping but forgot to write down where it goes in case it needs to be copied back. I am pretty sure that it was in AppData\Local folder somewhere.

Search for this file: system.generated.flightsimulator.exe_knuckles_2_binding.json

  1. Press the Win + R button and type cmd to enter the Command Prompt.
  2. Type CD and press Enter. …
  3. Type DIR and a space.
  4. Type the name of the file you’re looking for. …
  5. Type another space and then /S, a space, and /P. …
  6. Press the Enter key. …
  7. Peruse the screen full of results.

This is what the contents of the folder looks like:

I hope this helps: I’m not sure if these are the json files you’re looking for, but I found some similarly named ones in C:\Steam\config\openxr

Thank you for your reply. Hmm, that may be the location that it belongs in. Worse comes to worse I can uninstall OpenXR, Pimax and Steam and start over.

Incidentally MSFS is not starting using tykey6’s instructions so I will have to follow the steps you laid out above. You wrote that there is a new beta firmware for the 8K X, what do you suspect will be fixed?


1 Like

I was told that it would fix the SteamVR disconnected headset issue. Every few days, SteamVR stops recognizing my 8KX. The fix is to re-enable the headset in SteamVR settings (when prompted), but do not restart SteamVR; exit it instead. Then reinstall PiTool (same version) and the problem will be fixed for a while.

It’s a pain, but one I can live with. Still, I am really looking forward to getting new firmware to fix the problem.


This file does not exist on my PC.

What is the (error) message shown when you try to enter vr via ctrl+tab?

1 Like

A fix can’t come too soon. I’m now at 90 hours trying to get everything working properly with only about 2 hours in any given simulator, it shouldn’t be this difficult. On the bright side, I increased the resolution per eye in SteamVR and the difference in the sim was noticeable.

1 Like

Thanks for checking for the folder and files. I have reinstalled Steam, SteamVR and PiTool. The error that appears with MSFS is below. MSFS just seems to hang for about 5 minutes when I press CTRL+Tab or Tab+CTRL then the error appears.


1 Like

What you can try is this:

  1. Open the steamvr app, view the app in your pimax (not the desktop)
  2. Head to Settings (system/menu long button press to bring up menu, then bottom right)
  3. Select Show in Advanced Settings
  4. Head to the Developer tab
  5. Set Current OpenXR runtime as “OpenXR runtime”
    (OR if there’s another option here ^ like “SteamVR”, select that one if doing step 5 doesn’t work go through the step again but select the other option).
  6. Launch MSFS
  7. Once you get to the menus, press ctrl+tab, see if it starts vr
1 Like

@tykey6 - Thank you. MSFS hangs when PiTool and SteamVR are running, I had to shut both apps down for the MSFS main menu to load. I tried CTRL+Tab but VR would not start.

I only have the SteamVR as an option in SteamVR advanced settings.

I just found this:

SteamVR Settings > Developer > Set SteamVR as OpenXR Runtime button
displays if it is not the current OXR driver.


I will see if I have the most recent OXR driver and I will check Windows Mixed Reality to see if I can find anything.

1 Like

Hi Robert, thx for doing that, your steamvr settings appear the same as mine (apart from me using steamvr “beta”) and mine works ok. For reference when I start msfs in vr i do the following:

  1. Start pitool, make sure my basestations are detected in pitool.
  2. I don’t manually start steamvr at any point.
  3. I start msfs. When the menu loads up, i press ctrl+tab to go into vr (you can also enter vr through a button on the menu’s, think its in general options).
  4. Step 3 automatically starts steamvr for me.

Try enabling steamvr “beta”:

  1. In your steam library, right-click steamvr, and then and select Properties.
  2. Go to the Betas tab.
  3. Select the beta you would like to opt into : select beta - SteamVR Beta Update.
  4. Steamvr will now automatically do a small update.
  5. Try msfs again following the steps above.

Edit: You do not need this installed on your PC, it is only for hmd’s like the HP reverb G2. This can confuse things. Please uninstall this from your PC (

1 Like

I uninstalled Windows Mixed Reality and started PiTool then pressed CTRL+Tab once in the MSFS main menu and a message popped up saying that the headset was not detected. I will try the SteamVR beta tonight.

I just read the post you linked to and it said to unplug the headset, I did not do that when I uninstalled Microsoft MR.

Ok, if steamvr beta doesn’t work then ive ran out of ideas im afraid. Afaik you did get to msfs vr previously but now you can’t, so something has changed. If you still have no luck with steam beta then i suggest you trawl through the large msfs thread on this forum, may be even create a new thread asking for help on the msfs forum.

I was able to run MSFS in VR using the SteamVR Open Beta, thank you so much, I really appreciate you sticking in there to help out.

Now for the fun part of figuring out settings that will work on the HMD.

Thanks again!


1 Like