Mic stops working for VRChat when SteamVR starts oddity and solution

There have been a couple of old posts mentioning this issue, but rather than raise the dead, I wanted to post what I found here for anyone with a 5K+ who gets caught by this.

So this started when I was trying out VRChat and found it was not hearing anything from the Pimax 5K+ microphone. I could switch to my headset mic, but nothing out of “USB Audio Device”.

When digging I found that it was not just VRChat, any audio application such as Audacity or NVidia Broadcast could not record from that mic until I closed SteamVR. But why? Also it wasn’t just silence as Audacity would hang when attempting to access the mic.

More digging I found it only happened when the 5K+ SPEAKERS, not mic, was set as default playback device by SteamVR launching, and fixed by SteamVR closing and setting back the original default.

Even more digging I found it wasn’t even SteamVR, as starting a desktop capture using GeForce Experience would also stop the mic when the 5K+ was the default playback device.

Now I wish the solution was a simple software setting, but I stripped out every other audio device and tried many combinations of settings such as ‘exclusive mode’, ‘format’, ‘enhancements’ and none made a difference.

In the end, I realised after a cable re-shuffle I had the Pimax plugged into my Sonnet Allegro USB expansion card. Swapping it to a motherboard USB port fixed the problem. In the name of science, I tried the other ports on the expansion card and they had the same issue.

For anyone interested, I recorded a silent video showing the odd behaviour, the sound waves being me screaming into the mic from having wasted hours diagnosing the issue:


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.