Losing Nvidia HD audio after updating to Windows 1903

I am still running a prehistoric Pitool, but just yesterday I updated my Windows to 1903 (May) release. After that I noticed Nvidia HD Audio was no longer present as an option in SteamVR Audio configuration. USB Audio was working fine though.

I installed the latest Nvidia drivers (430.86), which updated also Nvidia audio drivers, but it did not help with Pimax (or SteamVR).

I am just wondering if anyone with the newer Pitool, who already updated to 1903 release and the new Nvidia drivers, noticed the same problem with the Nvidia audio, or the new Pitool is supposed to fix that. (This could be a good reason to finally update the Pitool.)


I ran into a problem long ago with Wolfenstein with Audio in steam. If Nvidia HD Audio still available in Windows Audio you may need to disable ones your not using.

I have four “Nvidia Output” devices listed in the audio panel “Playback” tab, but all are “not plugged in”, even if I turn the HMD on.

1 Like

Will need to check mine & verify if Windows is fully updated.

The headset Audio though I believe runs through USB vs Display Port.

You don’t need to install Nvidia HD audio, it will just work with your motherboard audio chip’s own driver, and using Nvidia is just adding other useless audio devices using GPU processing power…

I actually prefer using HDMI/DP audio over using USB audio to save USB bandwidth/latency for tracking. But we are diverging from the topic which is, does anyone also observe the loss of Nvidia audio in Windows 1903 update?


There is a new Nvidia driver out today. Have you tried it?


Are you saying it used to work with the Pimax? Mine only uses USB currently, and honestly I can’t remember it ever using DP, although I could well be wrong.

My HDMI Nvidia audio still works fine to another destination though.

1 Like

I have never seen anything except speakers (usb audio device), mic (usb audio device) on pimax, do other have Nvidia HD Audio… like i had on htc vive?

1 Like

I believe it did, as I was only using Pimax since I got it (in January), but I cannot verify it anymore :frowning:.

It seems I have the latest one (430.86).

1 Like

I disabled the devices as I wasn’t using them (and they were all “not plugged in” as You say), but AFAIR this was before upgrading to 1903.

I remember using HDMI Audio on my Vive and had I known that the Pimax supported it (if it does?) I would at least have tried it too, but I’m pretty sure they were always “not plugged in”… :wink:

Latest PiTool (beta .129), Windows updated to 1903 and 430.64 (not latest) Nvidia driver.


The Windows 10 1903 update introduced sooo many problems for me when I updated.
Try uninstalling all sound devices in the device manager. Then reboot the PC.
That finally solved my problem.


If anyone manage to get anything else then “usb audio device” please tell me how you did manage that.

1 Like