Left View is distorted in Elite Dangerous (Pimax 8k) [SOLVED]

Hi everyone,

I am really struggling with this.

I am trying to play Elite Dangerous with the PiMax 8k+.

I have it up and working but have a strange issue whereby when I view the main screens on loading, etc with the goggles everything is clear via both eyes. This includes menu systems and fairly small print/fonts on the screen.

However when the game moves into the cockpit view, the right side is crystal clear but the left has jaggies. This makes text look distorted, but even lines on ships, etc are jagged and unclear. The result when viewed through both eyes is a slightly blurred image.

I can guarantee this is not poor eye sight in my left eye (which is what everyone tries to say it must be), and if there is a way to record what the left and right sides are projecting I’d love to record both to show the issue.

The weird thing is that for the last week, the problem had gone away. Everything was beautifully clear and I was amazed at how good it all looked.

Today I installed the latest PiTool update V1.0.1.260 and the problem has frustratingly returned. (Firmware is V2.1.255.264). I have tried downgrading to V1.0.1.159 but the problem remains.

I am running Windows 10. With an NVIDIA GeForce RTX 2080 Ti card.

Can anyone help me narrow down what is causing it? I now know that it can be rectified, but I have no idea how to track down the cause.

I am so frustrated by this and cannot seem to get help anywhere.

Kind regards,
Wayne

1 Like

I play ED and haven’t seen this problem. (I just retested it.) I’m using PiTool v1.0.1.260 and the latest nVidia drivers: v451.48.

I’m not sure what to suggest, so I’ll list a few possibilities.

  1. Have you enabled Fixed Foveated Rendering in PiTool? If so, try turning it off (the “closed” option. This is usually seen as a “blocky” right-eye problem, but it’s worth a try.
  2. What nVidia video driver version are you using? You might want to try a newer and/or older one.
  3. Have you set maxRecommendedResolution in steamvr.vrsettings ? If not, search the forum for details. That usually exhibits in a blurry view, but if you haven’t done this, your Pimax headset will run in a lower resolution than it should.
  4. Have you enabled Parallel Projections in PiTool? If not, you’ll see a double-image effect in many games, including ED.
  5. When changing PiTool settings, some of them require SteamVR to be closed and restarted, before they take effect, so it’s possible some of your testing might have missed a setting change.
  6. Have you tried a full reboot? If not, it’s worth a try.
  7. Downgrading won’t rollback the headset firmware. You could try manually flashing the firmware to a earlier version, to match the PiTool version you reverted to. Just search the forum for details.

If you run into problems, just post in this thread and someone will likely have some advice.

Good luck!

6 Likes

Thank you so much for your reply.

Your first point on Fixed Foveated Rendering fixed it! Legend!

I have also taken the time to ensure I am running the latest version of both the PiTool and the nVidia drivers, and put the maxRemommendedResolution line in place so as to hopefully avoid issues with other games in the future. With more testing ED seems to work great still.

Purely out of interest, what other settings do you run for ED in terms of FoV and Render Quality? I will go play with both now I have this main issue resolved.

Thanks again!

Wayne

1 Like

My system has an i7-8700K, RTX 2080, 32GB, and a Pimax 8K. I play everything on Normal FOV. Wide FOV just isn’t worth the decrease in performance, imo.

My system is actually borderline for running ED at acceptable quality, mostly because of the need to enable Parallel Projections, which is a compatibility hack that increases the GPU workload by ~30%. In particular, inside stations or driving on a planetary surface requires me to use settings that are unpalatable, just to achieve an acceptable framerate. Luckily, your 2080 Ti should alleviate that issue.

My number 1 “go to” fix for low framerate is to set Fixed Foveated Rendering to Conservative. :rofl: I don’t like the effect, but I it’s a easy way to boost the framerate. (On my system, FFR works properly.)

In the past, I found Smart Smoothing to introduce annoying visual artifacts in ED. I recently tried it again and it appears to have been improved, so you may want to try enabling that, if you need to increase your framerate.

I have to leave Catalyst at 0.0, otherwise I get judder and double-vision. I have Quality set to 1.25, so that small text in ED is easily readable. I also have Hidden Area Mask enabled. I’ve set Contrast to +1 and Brightness to -1, to counteract the dullness of the LCD panels.

I set SteamVR Resolution Per Eye to 100% (2768x2600).

If I need to temporarily boost my ED framerate in game (on a planetary surface perhaps), I use the in-game Graphics setting to lower the HMD Image Quality to 85 or 75%.

Here are my ED settings:

3 Likes

Interesting, I had a very similar problem on a 5k+, but for Boneworks in the right eye, where ED and others have been ‘fine’ with FFR. By which I mean, it’s extremely over-aggressive in ED even when working correctly on the most conservative setting, but the extra performance is still useful.

I haven’t played Boneworks again for some months so haven’t had a chance to retest the feature and performance was good without it. There are any number of updates that may or may not have fixed it by now. It seems off the top of my head there are various possible causes (or combinations), as it’s not fundamental to one game or another, as far as I know.

  1. VR hardware unit and firmware version
  2. PiTool version / problem with update to, or installation of, newer version / settings
  3. Steam VR version / settings
  4. Graphics card and driver version / settings
  5. Game version / settings
  6. OS + DX version / settings

I guess there’s only way one to be sure (apart from nuking it from orbit hehe). Clean install of all the latest versions wherever possible with default settings, one by one. A pain of course I know, esp as latest PiTool does not equal greatest :slight_smile:

If I were to start somewhere without resorting to the most drastic option first, then it would be PiTool. FFR issue is in one eye only, and randomly on one app or eye over another where it is not universal for all? PT bug sounds like the first port of call to me, before moving to other areas

2 Likes

Also Keep the Nvidia Driver and pitool both updated. I had this in Alyx before, it seemed that the FFR was working on a small FOV from one side and so distorted a lot more of the other side of the view, it was not centered. I am not sure what, but some update fixed that for me in that example.

2 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.