Latest version of PE...can't use index controller in desktop mode

@arminelec Has something changed with the desktop functionality in PE? I noticed today that I couldn’t use my Index Controller to select anything on my desktop while in desktop mode. When selecting the desktop mode it would default to mouse mode and when I deselect mouse mode I couldn’t use my controller to select anything in the desktop view. It would just flip back to the PE menu screen when I tried to select anything. Is this a bug in the current version or am I doing something wrong?


Nothing has changed in the code nor the interface regarding controllers or the Desktop mode. However, since you have explained it to me, I can go and check what else could be causing it for your index controllers not working correctly in Desktop mode.

Just to be sure I understood you correctly:

  • When PE starts up, you can interact with the dashboard using your index controller (trigger and joystick)
  • When you activate Desktop (monitor) mode, your index controller does not move the mouse on your monitor, nor does it click/double click/tripple click.
  • When you deactivate the Desktop mode, your index controllers work just fine.

Is that correct? If not, please write me the correct situation description.


Yes, what you describe above is correct. Using my mouse is the only way I can interact with my desktop in monitor mode now.

Thanks for checking into it.


@arminelec It must have just been a random bug, because it worked fine when I started PE the next time. thanks

1 Like

I had something similar today.

Not work, work, not work.

I could not reset 8Kx to upscale - computer hang
I could not reset 8Kx to native - computer hang (think I tried changing to 60Hz and 90Hz)