Jitter after Updating to PiTool and Firmware M248

Hey there,
i’ve got some serious jitter after the last PiTool Update and Firmware upgrade. As you can see here in this Video:

The Video is edited, because i can not record the jitter with screen capture. This means the tracking is fine. It is just something inside my Pimax 5K+ which causes the Image to “jump” back for a second.
This is vertiginous and make me dizzy =(

My System:
Windows 10
Nvidia Diver 441.20 WHQL
GTX 1080
8gb DDR4 2600
Ryzen 2400G


A large subset of users get this problem. Roll back to pitool 144 and potentially the firmware as well until they fix.

I can mostly eliminate it by NEVER dropping any frames above target sync. IE 90fps 120 fps, etc.


I had the same problem when I upgraded to the latest PiTool and firmware from v1.0.1.132. I observed it when I was just looking around in Elite. It was so bad, I had to revert back both the PiTool and the firmware.

I have Ryzen 5 2600X, GTX 1080Ti and 16GB RAM, I wonder if this might be a coincidence. The old PiTool and FW were smooth (in Elite), without any problem.

The problem has been fixed and reintroduced in a previous pitool. They reintroduced it trying to increase graphics card utilisation.


Rollback of PiTool Version to 144 does not fix this issue. Firmware rollbacks are always scary.
I like the 120hz mode, well i guess i have to wait than.

1 Like

Yes the old 144 PiTool has worked flawlessly. So i did not upgrade over a year, until yesterday. Because i thought they improved the PiTool, but the Jitter is so bad i get motion sick.

With current price drops I would recommend upgrading your Cpu to an r5 2600x as this should help improve things. I think the r5 2600x can be bought now for around $200.

Some have also noted faster ram may help as well. I think others have reccommended 3000hz.

You might be able to assign pi processes to you last core to improve performance.

@Douglaster posted some good details on core optimizing.


@Heliosurge thanks for the response, I will get 16GB 3600Mhz soon. The CPU isn’t even 50% loaded while gaming, so i do not think this is a CPU bottle neck.
I found out that, when there is an spike in frame times, the jitter occures.

So i guess the Headset wants to repeat the last frame, if there is no new frame present? But it is not repeating the last frame, but the pre(pre) last frame. So it looks like the image is jumping “back”.

1 Like

Quite possibly. Just know I had the same issue on the i5 6500 no cpu spike issues. But had jitter & terrible aliasing with the cpu gpu matchup.

Now your only running a 1080 vs the 1080ti so might not be as big of an issue. Bottleneck calculator said cpu was bottlenecking gpu by a fair bit.

I am running r7 2700x with 16g 3200 ddr4 corsair ram.

That fixed my issues. I have the i5 6500 with 16g 2400 or 2666 ddr4 paired with the old r9 390 8g & also xp decent performance on it with 5k & 8k.

@bubbleball might have some ideas as well as he was using an fx8350 with I think 1070 or 1080?

1 Like

Pimax just need to fix the issue. They’ve introduced, fixed, then reintroduced this exact problem. They even had patch notes for it.

It looks exactly like that in the headset.


im running i7 4790 and I I have never had this issue. Either on 0.180 or

Bottleneck Calc says my cpu is a 44% bottleneck.

However its common knowledge that high pixel counts such as 4k will cause the GPU to slow down by at least 50% meaning the cpu bottleneck is hardly as bad as it seems

Hi Helio
Please stop making people upgrade their RAM and CPU :smile: even though it allways a bit better with faster components, it’s not allways the source of their issues.
Im running an “ancient” i7 3770K @4.6GHz with 32GB DDR3 1600MHz RAM @2000MHz a GTX 1080Ti and im not having jitter or bad aliasing as you describe. Last time I saw some hicckups / stutters in ED I was able to get rid of them by disabling CoreParking👍
Just saying, more, bigger, better, expensive is not allways the solution :blush:

Iirc Bottleneck Calc is an online website that just looks at your hardware components, and then “by some definitions” says if it thinks some parts are too slow.
it does not take OC of components into consideration and so on.


I use 1070, get the same effect sometimes. But I think it caused by low gpu and high sampling.

1 Like

I don’t make anyone upgrade anything. A fee users mentioned higher freq ram. Cpu wise was my direct xp. 2400G is an Apu and usually not as strong as straight cpu in my xp.

1 Like

Hi Helio
Did not mean to offend :slightly_smiling_face: offcourse you do not tell people to upgrade, but some might do it because they think an online Bottleneck Calc is right :wink:

Yes the 2400G is an APU, but thats just a CPU with builtin GFX thats farer than Intels equivelant. Whats important is its IPC, Core count and Speed.

But my pc is a great example that high RAM speed is great but not whats making systems stutter i VR😀

A new CPU with high IPC and Core count, would bring the Minimum framerate up a notch, and thus make the VR experience more fluid and better agreed :+1:


Well didn’t take offence. Just wanted to ensure no one thought I was using mind controlling hypnotism. Lol

But yeah there are different factors that can affect a variety of things & nothing is ever as simple as A or B.

Why computers can be quite irritating that some have success & some don’t.

I remember when computers were much simpler & less complicated with components.

But that was a long time ago


Yeah but alas it was not that simple back then… rember problems with IRQs and DMAs and UART… :smile: I sort of miss the old Days (back on topic now)

1 Like

I don’t know what happend, but it look Pitool become worse (or steamvr).

It get a lot of jitter and you will see look like watching mirror in mirror (Infinity of image from bigger to smaller).

I ever played gunheart and now it can’t be played although I don’t set sampling.
Can’t open the Arizona Sunshine. May I have to test other headset to compare what is wrong.

edit : Okay, I know the cause. It look my cpu run to 100% and still don’t know what happened. Have to solve this first.

It look Pitool use much cpu too.


Just make sure to run pitool once.
Then make sure the client is not running at all, and just use steamvr after.

I use to get stutter on beta .180 and someone suggested to exit Pitool software after setting whatever your settings are, then run steamvr
(I make sure to uncheck all 3 boxes in the pitool settings/generals tab)

when i did this, all stutter that was introduced in .180 went away for me.
it was super rare that i seen it come back, and that was sometimes in VRchat.

So, i do this all the time now, even on .197.

my Specs are:
CPU: Intel Core i7-4790k @ 4.6GHZ
GPU: MSI GeForce RTX 2080 SEA HAWK X (OC: +100 core +1000 memory +104% Power)
Ram: Corsair Vengeance Pro 16GB DDR3 2400mhz
Liquid Cooler: Corsairs H100i
OS: Windows 10 Pro 64Bit
Sound Card: Sound BlasterX AE-5


Another source of jitter/stutter might be nVidia Experience.

Personally, I only install the nVidia drivers, not the Experience app. That app does things like creating a 5 min video buffer (it’s always recording) so that you can save a video of something amazing in your game, after it actually happened. If you do want to use the app, be sure to disable unneeded features during a VR session.