Is there any explanation about the 10600 error?

I just got my new 8k+ and was exited to test this since i never owned a HMD. I knew there would be problems but ill worked with computers all my life so how hard could it be! -i thought.

Oh man. How many threads are there with people struggling with this problem? And every solution feels like black magic. Like, install an older versions of Pitool and then upgrade inside the program then start Steam VR before Pitools second start but after a reverse reboot etc…

I have done it all now i think and done it on two computers, one with Nvidia 1080 and one with Amd RX vega 64.

My last guess now is that its the cables fault and on some GPUs the signal isn’t strong enough so the connections shuts down. I got the same error, when you see the desktop for some few seconds in the HMD when connection the cable before it disappears again, on other setups with like cheap long HDMI-cables.

Do Pimax have any explanation for this?

1 Like

With the 10600 error simply try your other USB ports and if needed try other Display Ports on your GPU.

With the 1080 have you ensured the Nvidia firmware bios is up to date?

Maybe post your system specs with mobo info.

1 Like

Yes i tested them all.
And i got:
Asrock B450 pro
AMD ryzen 2700
And XFX rx vega 64.
And the other computer got a
Intel i5 4570k
EVGA 1080
Dont remeber the mobo

I also swiped the GPUs. And they all got the latest BIOS.

And tried every USB on it and with an powered USB-hub and even with and USB-A to USB-C adapter but no difference.

The amount of things to try are astronomical at this point. To test every release of Pitool with every firmware for the HMD with all releases of graphic drivers connected to every USB on the motherboard and every DP-port is just impossible.

I tested a HTC Vive and an Oculus Quest on this setup and they work.

1 Like

There you go.
@Heliosurge was there a way to make the P2 model work with the red team?


I believe it worked later on with Vega 64 and the like. @Willyfisch might be able to answer that. I know the older r9 390 works quite welll.

There was another user as I recall that was using vega gpus and had it working.

@Skav having issues with the 1080 is odd if he has performed the Nvidia Firmware update; I would submit a ticket.

Just in case here is the link for Nvidia update not to be confused with standard driver or say evga updates.

1 Like

Pimax as a 1st HMD? Don’t let this turn you off of VR. I believe that is written in the fine print in chinese on a pamphlet inside the box.:upside_down_face:

1 Like

Thanks but the 1080 got the latest firmware for the DP 1.4 support.

It’s quite confusing that the HMD is so picky when it comes to graphic cards.
The frustrating thing is that it feels like i fall on the finish line since the computers recognize the HDM screen and then looses it.

I guess i have to find another card some how.

1 Like


Yeah, after a long search i found that the Pimax got the attributes i wanted. Like the wide FOV. I have tried a lot of HMDs but never owned any.

I will definitely get another HMD if i can’t get this one to work :slight_smile:

1 Like

I would try a ticket as this is odd. The 1080 at least shouldn’t be causing a big issue like this.

I have a
Asus b450-i mobo with a 1080 ti Zotac Mini.

1 Like

Hi Skav,

Have your problem been solved?
If not,please submit a ticket through the following link, where our technical support team will provide individualized solutions for you.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.