Install Piplay Beta v1.1.92 & Firmware v1.0.0.236

In this beta version …

  1. You can make the screen brighter than before.
  2. You do not need to install Pix.exe because 2K resolution selection option is built-in.
    And the drift that appeared after running steam vr has disappeared,

This version is worth a try.

Update Information :

Piplay v1.1.92 Download : MEGA


Where can I get the version?

Piplay v1.1.92 Download : MEGA

How can I manually download and apply firmware update. PiPlay refuses to connect to the internet for me.

First, install Piplay v1.1.92 and update the firmware.
In my case it was solved.

Glad it was solved for you!!! Maybe you can’t read what I said?

PiPlay is stuck on “Searching device…” and the PiPlay app won’t do anything after I check firmware. It gives me an error message that it can’t connect to the server.

I manually upgraded PiPlay to 1.1.92 but I cannot upgrade firmware.

I think there’s probably a problem with the server, and you’ll have to try again at another time.

I have the same problem. All the afternoon trying it and no update.

I will try tomorrow, but it could be better the dfu file in MEGA, and update with the tool for pimax manually.

I have the new piplay 1.1.92 and the 2k resolution set in my pimax. Now i have more problems to recognize the HMD, i have to restart windows many times.

I have found this firmware link in this forum

but for me is offline.

I don’t want to recommend a manual firmware update. because it could cause a bigger problem for a user’s mistake.
If the firmware is not updated, it is better to use the older version until the problem is resolved. And I think it is one of the ways to turn off firewalls and anti-virus vaccines as a reason that may interfere with the update.

I don’t know if this will help anyone, but this is what I did to update the firmware etc.

  1. Download Piplay beta v1.1.92 from Mega and install.
  2. Make sure everything is normal with Piplay/Pimax.
  3. Put Pimax into Pimax Mode.
  4. Select Participation in Pimax beta and firmware beta in Piplay settings.

Then the Firmware Update selection button will appear under the Mode selection box in Piplay main screen.
I found that if I was in Extended Mode that the firmware button did not show.

I then just let it do it’s thing and everything seems to work ok.
Just lucky this time I guess.

I wish I could get some of those games in Piplay to work though. Anyone managed to do that?

Also, does anyone know of a vive hand controller emulation for XBox 360 controller.
Most games for Vive on SteanVR seem to ignore XBox the controller and hence not playable.


1 Like

It’s really fun because I have found de firmware update button in extended mode. In direct mode there isn’t button for me.

Some time before i get popup messagin from Piplay saying that ·the network is with problem, sorry"

The china servers for pimax aren’t very good for europa.

I have deactivated the antivirus and firewall for get the update conection.

Very good ~!
In fact, many of the odd symptoms that occur while using the PC are often solved simply.
If your Internet connection problem solves, the Update button will appear after background download is completed during use.

1 Like