Index Controller (Knuckles) - Easy Working Solution!

with more investigation I was able to find a copy of the drivers

install (if not already done) the NEW driver from SteamDB

download the OLD driver

overwrite the folder that contains EmptySteamDepot (steamapps\common\SteamVRKnucklesDriver)

That’s all! Tested with MoonDust, everything works


Do I extract the whole old driver archive into that folder: steamapps\common\SteamVRKnucklesDriver?

1 Like

yes, content of unzipped SteamVRKnucklesDriver goes into original SteamVRKnucklesDriver folder


If you don’t already have Knuckles/Index controllers. Don’t worry about trying any fix.

Wait & try it as Cas & Chary didn’t need these fixes.

The problem looks to have been generated due to renaming.


It works!! great job my friend!


Edit the openvr file as pointed out by @XabbuSwe any indexcontroller updates will need to be manually moved each time with @mmorselli fix. But yes great work.

Cool both solutions were presented quickly & are quite simple. Power of community! Wonder what fix(es) was attempted for pitool.

1 Like

Our solution still needs to be verified though. But yeah should most likely work


Did the index controllers have a press to buttons simultaniusly pairing mode ?

1 Like

B + SYSTEM for pairing


thanks now they are working with pitool :slight_smile:


Just verifying this also worked for me. Have a few glitches but I don’t think they’re related.


Well Fedex delivered my Knuckles but no Lighthouses, GRRR.

How do you guys install the driver over steamdb? If i use the link in steamdb, my steamclient download the knucklesdriver but the folder in steamapps is absolutly empty. Their is a folder inside “SteamVrKnucklesDriver” called “EmptySteamDepot” but also no files there. Please help :frowning:

1 Like

That’s fine, this driver is deprecated, it’s only a placeholder, but Pimax search some graphics files in this folder

You need to overwrite this folder with the provided zip file

1 Like

confirming of working solution for the knuckles! Just have done this and it works. Knuckles icon isn’t visible on steam but who cares. Thumbs up

Yepp, thank you. First time i copied the content of the zip file into the EmptySteamDepot Folder. Second time i´ve done it right and now it works. Precision of Finger Tracking seems a little klunky for me, but maybe this gets better with newer pitool version.

This is not PiTool related (thankfully)

Index Controllers need some time to auto-calibrate… make sure to have the latest firmware (connect them with the cable, or pair with the dongle if you have them, without the PiTool services active) and over time the accuracy will improve


@mmorselli i didn’t update the firmware of knuckles cause the steamvr showed it’s updated already. I was pretty sure something is off tho. How should i connect them with a dongle and update the firmware without pitool running?

Close PiTool, from task manager stop pimax services ( PiServiceLauncher and PiService ), if you have dongle (Vive Trackers dongles or Steam Controller reflashed dongle) … or Vive headeset, pair knuckles from SteamVR e see if new firmware is available

PiTool prevents firmware check…

Or connect with USB cable and do the same (I never paired controller via USB, so I don’t know the exact procedure)

1 Like

Just updated the Index Controller Firmware, so the exact procedure is:

  1. Edit



“Program Files (x86)\Steam\steamapps\common\SteamVR\resources\settings”

and set requireHmd to false (to avoid “no hmd” error)

"requireHmd": false,

  1. make sure that


are not running (from task manager - taskmgr)

  1. start SteamVR

  2. Connect Index Controller with USB (even turned off)

  3. wait for controller icon, no pairing needed, but icon MUST be the Index Controller icon and not the generic “C” icon


“i” circle means update is available, mouse over to icon and select update