Importing FS2020 (Gamepass version) into PE

If anyone uses the Microsoft Store version of FS2020 and wants to manually import it into PE under the “Imported” category, the game has no exe file.
And currently, PE does not import Microsoft Store games automatically (we will look into that).

But there is a solution:

Create a bat file to start MFS with the FastLaunch option which looks like:

C:\Windows\System32\cmd.exe /C start shell:AppsFolder\Microsoft.FlightSimulator_8wekyb3d8bbwe!App “-FastLaunch”

Then import the .bat file in PE (Add New Import)

(Thanks to @hashjime on the FS2020 forums)


This is VERY important to me. Cheers


What is the advantage, if any, in launching MSFS through PE ? Will it improve game performance?

No performance advantage from what I have seen so far. The CPU bottleneck in FS2020 is the real issue and that cant be fixed by PiTool nor PE. Even upgrading your CPU wont help much…

1 Like

Hi @SweViver,

Thank you for your input!

Looks like we will have to wait for MS/Asobo to improve MSFS for VR use…

1 Like


I can’t get msfs2020 to detect my pimax 8KX ( pitool and SteamVR is running) I´v also tried using the bat file via PE and it still does not work? ( worked about a year ago) any suggestions?

Kindly J

Are you running SteamVR Beta version? If not, try it.


Can you check if MSFS is using the correct SteamVR OpenXR runtime?
You can check (and fix) that in the registry. It should look like this:

1 Like

Thanks for your help

But i still cant get it to work with msfs2020… it work great in all other VR games i have…

Good morning

I fixed it…

Hi all,

I tried the bat file approach to get MSFS from the MS Store run on my system but it wont work.

I literally copy pasted the two lines from Sweviver’s post above into a batch file (with a random name) and imported that into the “Imported” section in PE. It does start MSFS whioch then loads but continues to state “Game is now starting in VR Please wait”. Once MSFS has completed its start-up, I can initiate a flight on the desktop and when the view switches to the plane with the Reverb G2 I would whitch to the VR view - at this point it will just tell me “no VR headset recognized”. Within the 8KX the PE screen with the above-mentioned message continues to show.

Any ideas ?