Image separation on lateral or vertical head movement since Brainwarp Beta's

Since the Brainwarp Beta’s, whenever I move my head vertically or laterally, the image on my 5k+ separates slightly, so it makes the screen look as though it is “juddering” or jittery, even though the framerates aren’t dropping/ ie maintaining 90 etc.- hardware = 2080Ti/8700k/32Gb Ram - and am getting this on everything, including the default SteamVR loading in screen (the room with the lines off into the distance and on the roof etc - the basic, default one; not the “beta home”). It makes all experiences unplayable, and given that the previous version of Pitools added the firmware update that breaks backwards compatibility, I am stuck with this now, hoping that every new version of Pitools will fix the problem (which they haven’t to date). I also have an 8k but haven’t tested it (dont want to upgrade the firmware and break pre-Brainwarp pitool compatibility). I have a Vive Pro and there are none of these issues with it - have gone back and forth between the headsets trying to compare - so I am confident that the lighthouses etc are all working fine and the issue is with the Pimax headset.

I get it that it is Beta software etc - but it is an unusable product at this point and it is not getting better with any of the iterative versions that have come out. I have pretty early Pimax hardware (received mine in Dec 2018) so was wondering whether I might be a candidate for the thing where Pimax remote access into your computer and upgrade some settings on the headset - does anyone have any details on how I can talk to someone about whether that would be helpful ? I can’t seem to make an account on the support portal - I get stuck in some kind of logging in loop. Any help appreciated - thanks @moz @Matthew.Xu


have the same problem.
After the arrival of the headset, I immediately installed the new Pitool and the headset updated the firmware to version 193
When turning the head, there is a sort of image shifting, it looks like jerking.
I first thought that the reason in tracking lighthouses.
I also tried the beta versions of Pitool 111 and 112, but this did not help. Tried various settings Brainwarp, also without effect.
Then I downloaded the previous version of firmware P2.1.255.181. The firmware process is very simple. Also replacing Pitool on 95 and all the twitching completely gone. I didn’t even believe at once, tried the new firmware again, then back the old one. As a result, all problems with twitching start with firmware 193 and Pitool 109

Man you could be my saviour - I will try it and let you know how I get on.

Of course
Let me know if there are questions about downgrade.