Huge performance boost in beat saber with large fov?

I did a test with the new PiTool Beta and I got some strange results, I would like to compare them with you

With this setup:

GTX 2080Ti - 8700K

  • normal FOV
  • Pitool SS = 1.0
  • SteamVR SS = 130%
  • brainwarp = NO
  • FFR = YES
  • Parallel Projection = YES

in Beat Saber i get about 65 fps (15ms GPU frametime)

Same setup, but with Large FOV … 90 fps with 5ms GPU Frametime !!!

how is that possible? SteamVR Home has a low resolution bug with Large FOV, but supersampling works very well in Beat Saber, with fpsVR you can change it in realtime, from 20% (minecraft like resolution) to 130% (reaching the 8192 resolution limit I set in SteamVR). Image is clear and crisp, can’t be better, but performance increase is about 3X !!

Can someone replicate this test and confirm that I’m not crazy?


Lol, I was searching forum to question why Beat Saber perform so poorly compare to other game. Guess I need to go try Large FOV and see. Steam VR report I should set my SS to 66% (I have 1080Ti). And yet I still can’t keep 90 fps in beat saber (smooth motion enable and lock down at 45 fps). I tried other simple game like Fruit Ninja and Angry Bird, and both stay at 90 FPS easily.


Edit - PP was off. And Pitool SS = 1.0. Normal FOV.

1 Like

Idk, maybe the motion smoothing is slightly broken in the new Pitool and is tricking Steamvr into thinking it’s running at native 90fps. That would explain why you appear to get better fps when it’s on large. Sounds unlikely, but it’s my best guess.

Something is wrong with this particular config for Normal FOV. The resolution for Large FOV reaching 8192 does not sound right either.

Do you see the same behavior on 5k+ and 8k?

SteamVR was updated some days ago, it means “maxRecommendedResolution” is back to 4096 in your config file.

1 Like

maybe “maxRecommendedResolution” got reset to 4096 when updating steamvr and the res reduction results in higher performance?
"maxRecommendedResolution" : 8192,
should be added to
“C:\Program Files (x86)\Steam\config\steamvr.vrsettings”
and “C:\Program Files (x86)\Steam\steamapps\common\SteamVR\resources\settings\default.vrsettings” should be left alone as it will be reset on steamvr updates (the value was back to 4096 in “default.vrsettings” as i checked my config yesterday)


For 5k +, is there any need to change maxRecommendedResolution higher than default one? I know 8k benefit from it but not sure if 5k+ needed too…

Checked, my 8192 hard limit is stil here (I recently reset it), Steam reports 7924 x 3751 per eye, and my eyes used to VR since DK2 report the same. I can see image changing at 100% - 110% - 120% - 130% in real time.

I have GPU frametime between 4 and 5ms… If someone with 2080Ti could try it, it would be a nice confirmation

I just tried large FOV on Beat Saber with latest beta PiTool. On my 1080 Ti it lag so hard until game crashes… So no, large FOV did not increase performance for me.

maybe it is something related to the FFR, which is evident in Beat Saber with 2080Ti (ballanced setting)

the game is stable and smooth for me in large fov and 7924 x 3751 for eye, I’ve been playing for over an hour without issue

at least i can see the same here (ryzen 2700x, 2080Ti, large fov, ffr conservative, pp on, smart smoothing off, hidden area mask on, render 1.0, in steam 130% render) in steam home room >11ms (~16ms), when starting beat saber its more or less half of whats in steam vr home room
even without FFR its that way

edit: maybe beat saber does not user the the “recommended” res and caps it to keep things at good performance?

Couldn’t that be the solution of the mistery?

I have a mod installed that fires a debug window.

UnityEngine: Requested VR texture of dimension (22187, 5251) at render scale 1.40 exceed max texture size 16384 on one or booth dimensions. Reducing render scale to 0.70 and retrying…

other games could have silently this behavior, under similar conditions.

A while ago I had something similar with a test build of The Wizard, right with the LARGE FOV



Wow. I have to try this because the lag and tracking issues have been getting much worse and so inconsistent.