Hubris on Pimax

Hubris is available on Steam from yesterday. I was waiting it several months, and have already several hours in it. The game is beautiful and fast. I highly recommend it.

EDIT: It works over StemVR too, my system had problems before. Now do not panic if you buy it, and it does not work; it is OpenXR game, and currently I can not start it with Pimax on StemVR. But you can start it directly in OpenXR, and even make it better with OpenXR Toolkit from mbucchia.

My settings in pimax:
Pitool ss=1 (3160pixels vertical), no paralel projection, normal fov (140deg), 90Hz with smart smoothing on 45Hz
Game: all max, ss and sharpening too
OpenXR toolkit; resolution override to ca 4500x4000 per eye, FSR scaling active but with 100% - that means without scaling, but I enable it for FSR sharpening max 100%. I tried scaling 90%, it is much faster game, but I like eye candy picture :slight_smile:
The brightness +10%, same as for all 3 colors.
Unfortunately fixed foveated is slightly misaligned.

HMD Pimax8KX, Index controllers, CPU 8700k, GPU nvidia 3090, 32GB ram, ssd

This is my steam review of the game:

SHORT VERSION: Beautiful game, better then Alyx. Game has swimm, jump, run and even drive with hands on wheel :slight_smile: If hubris had 3rd party mods, that would be the lead vr game.

LONGER VERSION: This game reminds me a lot on VR Halo (The master chief), Alyx, Cyberpunk (driving, but better), Into the radius, Doom 3 and VFR, Seeking dawn, Red matter, Naked sun, The forest, Subnautica and Kayak VR Mirage (visuals). This game has everythig in it, and that everything works great :slight_smile:
Longer I play it, more I love it.
Highly, highly, highly recommended!

Ps: a little glitchy currently on openxr, but that is just 1 day after release. I play it directly with OpenXR, maybe over SteamVR is different.


Are there any special methods you have used to fix the shadows? I’m launching Hubris through PitTool and I’ve been unable to get the shadows to render properly regardless of PP setting.

1 Like

No, sorry, I mostly do not see errors, jus a few vizual mistakes. Mostly my problem was droping down from cliffs, balcony and similar :slight_smile:

Anyone else having this problem? This is is the second title I’ve seen recently that can’t be fixed using PP. The other one is Kayak VR: Mirage, in which there are a handful of dynamic shadows that don’t get fixed even with PP on (they are hard to spot; I believe one example is under a snake in Australia?) In Kayak the dynamic shadows can be turned off so it’s fine, but in Hubris the shadows in the very first outdoor scene are totally wrong in some areas, and PP appears to make this no better at all.
Would love to fix this if anyone has a solution as I was really looking forward this title. Do we have to wait for Pimax to update their PP method to correct this? I’ll see if the devs have a feedback page and/or will post the issue on Steam as well.

1 Like

I was paying attention for errors on last session, and there indeed are some errors. In water some shadows in medium distance (ca 10m away) are different on L and R eye. Underwater effect also is a bit strange. Some reflections later in game are also wrong.

I saw such behavior on many games. Mostly pp=off works, and some things do not work good on Pimax at all. It is often haze (moisture from air makes distant objects less visible), mist, shadows, shining of things.
And those features are correct only if they are in the middle of the screen - as pimax screens are canted, left and right eye have those features slightly different. In Pimax, I can see full dark shaddow with left eye if my head is slightly to right. On other eye at same time that shaddow is brighter, and less visible. Turning head left right will show constant transition of that shaddow.

I assume that is more general problem in VR, maybe in pimax driver, or regular vr engines for games - I dont now where, but I saw it often.
In some games I can tolerate that (Hubris), in some unfortunately not (Elite dangerous)…

@hammerhead_gal @PimaxUSA @Heliosurge If you are one of the lucky people who can ignore the issues you might still consider Hubris, but IMHO this title should be considered currently incompatible with Pimax HMDs. The shadow issues are pretty awful and I certainly can’t even begin to play Hubris this way.
Hopefully Pimax and the dev can figure out what went wrong and get it fixed.


The game “Wandering in space” has same problem: after first level, when I go to shuttle, I can see from the shuttle some wrong shadows on the rest of space station. Those are probably dynamic shadows.

I know this is “Hubris” thread, but I really think this issue is more than 1 game problem. It would be excellent if Pimax engineers look on that.


So we are now at 3 games and counting. Doesn’t bode well.


Are any of these games Unity Based?

I received a notice from the devs that this has been fixed on Pimax’s end. They claim it is an incorrect implementation of OpenXR rendering standards (on the Pimax end). I’m already on the v.284 PiTool revision, so I’m unsure how or where to get the supposedly fixed version if it is publicly available. It’s also possible I may have to install the Pimax Client software, but I hope not as I am not a big fan.
Anyone here actually have a working Hubris? Do we know what version of PiTool we need?

1 Like

I would poke @mbucchia as he is the author of the unofficial pimax openxr runtime.

I’m a little confused here because the top post says that this game doesn’t start up at all with OpenXR set to SteamVR. Though there is no mention of PimaxXR anywhere, just OpenXR Toolkit. So it’s unclear to me whether PimaxXR is even at play here. It sounds to me like @mr_spongeworthy is not using PimaxXR, but instead using OpenXR for SteamVR with the official Pimax SteamVR driver. The mention of “They claim it is an incorrect implementation of OpenXR rendering standards (on the Pimax end).” sounds like this is an issue somehow fixed in the Pimax SteamVR driver. I’m not really sure where PimaxXR and I come in the picture here. Also, they are mentioning Kayak VR and Elite Dangerous, both not OpenXR games.

With the (confusing) information listed above, there is nothing I can contribute atm. Perhaps someone can confirm whether the game does work with SteamVR, and when testing Pimax fix, please be sure to use SteamVR and not PimaxXR.

I think I happen to have access to a free copy of the game, so I might try it later.


Hubris still does not start with steamvr (with latest pitool, should be same as latest pimax client).
Hubris currently starts only with PimaxXR, and I use OpenXR Toolkit with it.

We were talking about other games because some graphical errors are really similar in them, like when pp=off works on games but 1 feature is off (i.e. shaddows, or fog, haze, shining…). That was repeating from game to game, OpenVR or OpenComposite/OpenXR - it was the same.

I didn’treport that emediatelly as that was minor problem, I could tolerate that on some games, and didn’t know how to isolate and explain problem.
But lately I figured that more games have same minor errors on pp=off, and I was thinking what can be the cause?
It can be something simple, like maybe mistake in vr guides how to implement fog in games. As mostly VR goggles have parallel screens, people do not see every mistake with fog. We with canted displays can see all mistakes :frowning:

Once in Morrowind VR mod I saw one interesting setting, a radial fog. When I saw it, I knew emediatelly it was made for canted displays.
Maybe here in Hubris we need something similar for active shaddows?


I see. If the game only runs on PimaxXR, then this comment won’t help:

It sounds like Pimax made a change to their SteamVR driver to address that, and PimaxXR doesn’t use it (it bypasses SteamVR).

Tbh I am a little skeptical because shadow issues sounds like a game engine issue and I’m not sure how OpenXR API is involved in that type of bugs. I do agree though that PP should fix that in most cases, unless the issue is related to large FOV.

If Pimax wants to share what was it that they fixed in their driver, I’m happy to look into how to add that to PimaxXR, but without further info at this time, and no evidence that it is fixed (since the game won’t start with SteamVR), there is no time I can spend on this.

1 Like

The game Hubris actually starts with OpenVR (SteamVR), I had some issue with room calibration that prevented several games to start. But the issue with some (just some) shadows is still present there.

@mbucchia I can start openXR games over SteamVR, and still use yout OpenXR Toolkit!!!
I didn´t know that was possible. Now I can use your FSR scalling, and change buttons on controllers at same time. Nice :slight_smile:

1 Like

@PimaxQuorra can you have the team look into this?

1 Like

I think you are mixing up. The game doesn’t seem to have OpenVR at all. I think you mean that you are setting SteamVR as your OpenXR runtime. Especially if you are saying that OpenXR Toolkit works, then it’s definitely not using OpenVR. Or are you using OpenComposite?

Anyway, game finished downloading here so I’ll give it a try at some point.


To be clear, for me Hubris is opening through Steam VR. I am not currently using any of the alternatives as I’m waiting for them mature. I had some excellent results in Dirt Rally 2, but pretty much everywhere else I had one problem or another (Index controllers not working quite right, for one thing.) I do have PimaxXR v0.2.8 installed but have it set to “SteamVR” for the OpenXR runtime. I’ve actually been considering uninstalling it completely just in case it was somehow causing issues even though it is supposedly disabled.
EDIT: No change. I uninstalled PimaxXR and made sure the Steam VR was indeed my OpenXR runtime. Shadows still render incorrectly. Even tried Small FOV just in case that was the issue. No luck. As far as I can tell their response was incorrect and this title remains incompatible with Pimax HMDs.

Thanks for checking and clarifying what you see. As mentioned in my post earlier, I hardly see how Pimax could be be fixing a shadow bug through their driver, this is definitely something wrong in Unreal or in the game. What I cannot understand though is why PP isn’t helping.

1 Like

Hi All

Hubris engineer here.
It’s clear there is a lot of speculation about this issue, while only a few things have been confirmed. What we can confirm is that there is an issue in AO rendering on all devices running through Steam OpenXR.
Whether this is an non-conformity in Steam’s OpenXR rendering or in our rendering pipeline is still under investigation. We do know however, that we can patch it since we don’t have the issue on some builds we made for SteamNextfest back in June.

We’ll look into the issues with PimaxXR as well and we’ll report back to you (@mbucchia) if we would be able to track down the problem.