How to use the Sword Controllers?

I got a sword controller today.
I charged them and launched PiTool, but the controller is not recognized.

I checked the pairing item. There is no description of the sword controller there.

I checked the FAQ. There is no description of the pairing method.

So how do I set it up?

Pair as Index controllers.

1 Like

By updating to PiTool version V275 and firmware V299, the Device Pair page was displayed and the controller was recognized.
By the way, when I pull out the USB cable from the controller, the power turns off. Do I need to use it by wire?

No need to use cable. Just make sure that They are fully charged. Our batteries arrived charged so there was no need.
After you remove the cable then just restart the controllers.
A stupid question, you did insert the batteries?

The battery was inserted in reverse. :innocent:

I have tried Sword Controller.


Almost all games recognize it as a vive controller, and some of them don’t have good key mapping.

BigScreen:Can be used without problems.

NoMan’sSky: Most of the buttons seem to work, but the key mapping is weird and not playable.
You can use the pad to jump, the buttons to move, and the placement is not clear.
You will need to relocate the keymap in steamVR settings. (It’s not in the game)

GoogleEarthVR: Worked flawlessly. It’s fun to be able to control it freely.
One problem is that zooming in and out sometimes freezes momentarily and operates in reverse. (Trackpad)

DCS: It was possible to display a hand in the game and show a pointer. However, I could not touch any of the switches. Even with the option to use a hand controller, the trigger was unresponsive and could not be operated. I can’t grab it at all. It’s a mystery.

MSFS2020: The VR controllers seem to work well after last night’s update. I was able to turn the knobs and move the throttle on the 747-8.Key assignments seem to be available in the ingame options. I haven’t tried many things, but it appears to be working correctly. The unofficial mod plane does not fit the VR world scale and the controller is buried in the plane. Difficult to control. Wait for an update.