How to run games form Oculus?

Hi,
I cannot seem to figure out how to run games from Oculus. There are so me answers on this forum but none of them work so I started new topic.

What I have already done:

  1. Installed Oculus Store app from: https://www.oculus.com/setup/
  2. Installed newest Revive Library from: https://github.com/LibreVR/Revive/releases
  3. Purchased few free games & apps in Oculus Store (they are visible in my Oculus library)
  4. Installed purchased games via Oculus App

I also have latest SteamVR, PiTool, Pimax Experience and I’m running Pimax 8KX hmd if it matters.
I don’t have any Oculus headset.
First time I run Revive i got message that it will automatically add Oculus apps to Steam library (it doesn’t, it also doesn’t run automatically with SteamVR like some people suggested)
Also if it does matter when I run Oculus App I get info that I need to “Configure Rift + Touch setup to be able to able to unlock free games and apps”

Result is that I cannot see my Oculus items listed neither in PiTool nor in Pimax Experience hence I am unable to run them.

Is there any step I am missing here? Maybe I need to add some Oculus HMD/Controller stub for this to work?

EDIT: I managed to get one game to show in my PimaxExperience dashboard but when I run it I see it displayed on my PC screen but my HMD says “loading” forever without showing the game.

1 Like

I did install revive from here: https://github.com/LibreVR/Revive/releases

I also have Oculus Store installed.
Yet I can see my Oculus Library games in neither in Pimax Experience dashboard nor in PITool.

Is there any additional step I’m missing here?

just make a shortcut/batch file that runs the baked in revive of pitool you shouldnt need all that other stuff, heres a post with the syntax

1 Like

Hello,

Maybe you could try this method.

  1. Create a txt.file and type in
    (“C:\Program Files\Pimax\Plugin\OCSupport\OVR_Launcher_x64.exe” F:\Steam\steamapps\common\Project CARS 2\pCARS2.exe)
    2.Please change the game folder path according to your PC*
  2. Save the file and change it to BAT.file

You may try to open the game and run in oculus mode.

Sincerely.

1 Like

I just tried my first Oculus game yesterday myself and I’m also having little luck.

From what I’ve found, the process should be:

  1. Install the Oculus app (done)
  2. Buy and install an Oculus game (done)
  3. Game will be added to PiTool (yes, this worked)
  4. Launch game through PiTool, SteamVR not needed (problem)

At step 4 unless I also have SteamVR running the game will not launch, reporting that the Oculus Tool is not loaded.

If I open SteamVR the Oculus game will run, but my Index controllers barely work and I get no sound.

What do I need to do to get this ecosystem working properly?

Did you reinstall pitool after installing Oculus? If not try that as pitool needs to add some files to Oculus home. Monitor your AV as this maybe flagged as suspicious and prevent pitool from installing needed files in Oculus Home.

I start simple my pitool (to activate the hmd), open revive dashboard and start the game in the dashboard… thats all

@mr_spongeworthy you must install revive

GitHub - LibreVR/Revive: Play Oculus-exclusive games on the HTC Vive or Valve Index, scroll down for downloads and installation instructions.

1 Like

OK, thanks for those two suggestions. I’ll give them a try. I’ve been wanting to avoid installing Revive unless the regular method no longer works, as my understanding is that it has a considerable overhead?

1 Like

No need for revive. Just turn on controllers before game.
If you want to change some bindings, then you need steam to be open too (before game).
Oculus will start automatically.

Some games (mods) start just from pitool, some from desktop shortcut, some just from that pimax experience, there you have more options to try.

2 Likes

What game did you get?

Index Controllers usually imitate Touch well but there can be slight differences.
There was an update recently in the Oculus version of In Death and I found my ICs totally out of calibration and button mapping was wrong. I had hook up my CV1 and Touch controllers and play the game to re-establish parity. Made me glad i kept my Rift.

Lucky’s Tale has a similar behavior but only supports “Touch as a gamepad” so maybe not the same issue. I tried it on ICs and controls were messed up. I actually only had the XBone last time I played it. Don’t think i ever played it with Touch). I may need to play it once on the Touch controllers as well but haven’t tried that yet.

Most but not every Oculus game has worked on Pimax. I think Pimax fixed a few like The Climb which had pooched graphics. Good idea to search the gameplay on a Pimax.

1 Like

Thanks, looks like a lot of good tips here. I snagged “Lone Echo” which seems to be highly regarded. I should have time tomorrow to try some of these solutions.

2 Likes

I haven’t played Lone Echo for some time. The game runs well on the Pimax’ The ICs work well. A near match to Touch iirc.
Echo Arena wasn’t working on the Pimax last I heard.

1 Like

I remember now, after installing oculus software, try to run it once. There you have to click on something in settings (eula? or info that you may fell dizzy/sick? I do not know any more).
Sometimes after oculus software update you need to do this step again.

1 Like

Yep. Only did that once and caused my issue. Since i wasn’t launching from OH it was not necessary. I was just checking something on my CV1 which i had not used. since getting my Pimax.

Thanks for the help! All I ended up having to do was an in-place reinstall of PiTool and it’s working as I expected it to.

Is there a performance-monitoring tool for Oculus games I can get that’s similar to FPSVR? I can monitor on my screen of course, but that’s relatively useless when wearing an HMD.

2 Likes

Oculus Debug tool but that’s an app for Oculus hardware. Nothing that works on a Pimax that i know of.

1 Like

Thanks again. Looks like all my issues are solved for now. I’ll be able to try some other games soon. For those who don’t have it yet, Lone Echo is running and looking fantastic and it’s a fairly interesting title thus far.

3 Likes

I am totally blown away by Lone Echo 1 on the Varjo Aero . I didnt know this game has THAT much detail.
Never noticed it on the g2 , and the g2 is already crazy sharp but eye cancer compared to the aero.
Really crazy hmd that aero

3 Likes