How to pair Pimax 8k x with HTC SteamVR Base Station 2.0

Any siggestions? thanks


HTC SteamVR Base Station 2.0 how to pair with the Pimax 8k x? thanks


Moved Your reply from another thread here as it had nothing to do with the other discussion.

Maybe You could describe the problem You’re facing?

Oh, and welcome to the forum… :+1::wink:

EDIT: @SweViver’s reply below should have You covered and if not, let us know… :wink:


All you need to do is make sure the base stations are using correct channels.
Just turn on the base stations while your Pimax is up and running, then:

  1. Grab a needle or something sharp
  2. Push once with the needle inside the small hole at the back of your base station (see image below).
  3. Now wait a few seconds
  4. If channel is correct, your base station icon in PiTool will blink and then become blue (active) in PiTool.
  5. If channel is not correct, the base station will stay grey in Pitool. Then try pushing one more time with the needle, and repeat step 2 to 5 until both your base stations are detected in PiTool.

This is only required to be made once, and the channels will be saved for all later use.


Thank you so much.:pray::pray::pray::pray::pray:


If you start steam vr you will se the basestation (at least you do with the one from valve direct) even do they are on wrong channel and there check channel so you know how many time to push.


Thanks, I will try that as I can’t see the station on the pitool.

If that dont work install the android app Lighthouse PM on your phone. Its a app so you can put bs to sleep and so.

1 Like


Perhaps it’s time of a new installation video of Pimax 8K X, basestations, controllers from zero including upgrade firmware , installation pitool and PE, improving audio etc. and at the end troubleshooting

but i would postpone this video until firmware, pitool and PE are stable


I have an iPhone, thanks anyway. :pray:

Yep thats on my schedule. Some PiTool + PE stuff needs to be added first though, to make the guide complete.

I assume you have two 2.0 base stations, right?

  1. Make sure Pimax 8KX is connected and OK in pitool. The base stations should be greyed out.

  2. Make sure Lighthouse tracking is enabled in PiTool.

  3. Power on the first base station. Keep it at a distance of 2 meters or more, standing still on a table or whatever and pointing towards the headset.

  4. Wait for 10 seconds or more.

  5. If both of the base stations are still grey, push the button in the small hole at the back of the base station. The light on the base station will change for a second.

  6. Now wait 10-15 seconds. One of the base station icons in PiTool should start to blink and eventually just stay blue.

  7. If both base station icons are still grey, repeat step 5 and 6 again. And wait 10-15 seconds.

  8. There are 16 channels on a 2.0 base station, and as far as I know, currently only 4 of them will work with PiTool. So keep repeating step 5 and 6 at least 6-7 times.

  9. Once you get one of the base station icons blue and tracking, do the same thing with the second base station. Power it on, push the button, wait, push again etc… until the second base station icon in PiTool starts blinking and eventually turns blue.

It might take a couple of minutes, but I have never seen this failing before.

Remember, as soon as any of the base station icons in PiTool starts to blink blue, you have found the correct channel. So dont press that button in the hole anymore. And it might take a moment until it settles and stops blinking, and turns blue. Thats when your headset starts tracking.

The button im talking about is just a tiny hole at the bak side of the base station, with a button inside. So use something sharp to press the button inside. Just like on the photo below, where a stiff yellow cable or something is used to press the button.


Thank you, I will try this today.
PS I really like your videos.:+1::heart_eyes:


Thanks man, glad to hear!
Good luck :slight_smile:


Just an update, I got everything up and running, it looks absolutely amazing, and thanks to all of you guys.
Just a note of how I got them to work: on the SteamVR go to Developer/setting scroll down and unbind all USB devices unplug the Pimax(all 3 cables) restart PC and plug it back in, it recognized all the station without any other steps.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.