How to exceed the maximum resolution of 4096px imposed by SteamVR

A few days ago talking to a friend of a group of Telegram in Spain that we have for the sponsors of pimax 8k, he told us that he saw a default.vrsettings file in the configuration of SteamVR with a parameter maxRecommendedResolution: 4096, he modified that value and now if it admits an SS greater than a resolution of 4096.

It would be nice if more people ( @Mixedrealitytv , @Voodoode , @Sweviver , @Cdaked ) could try it and leave their comments here.


You mean he saw a value of 4096 and changed it to 40096.

No, by default the value is 4096 , what you did was put a value greater than 4096 , for example 40096.

The default value is 4096. I set it to 8096. Bingo! application resolution elite dangerous at 6100x3000: super sharp @ large FOV!! In addition I set rendertarget multiplier to 2:0.

Great finding! Many thanks!!


What do you have a 3080ti?


It was a test ;). 1080 ti @2.1Ghz, 30fps in elite with this res.


The default is 4096. Your friend probably said to add the 0 because there’s no way anyone would go that high, so there’s no need to go back in to edit it.


In steamVR are you manually setting the SS setting?
Also what do you have pi tool quality set at?

Also, this doesn’t seem to work for me. Tested with newest PiTool, parallel projections on, kept Steam SS at 100% and Pitool at 1.0. Normal looks good, Large FOV looks worse. I only tested in SteamVR Home. Maybe actual games show a difference?

pitool: 1.5 (manual): 38% 70% = 6186x3020
with large FOV in elite dangerous as sharp as

normal FOV @
pitool: 1.5 38% 70% = 3429x3020.

1 Like

Did you restart steam after modifying the settings file?

1 Like

Is that multiplier to setting?

Exactly, that’s right , the default value is 4096

Yep. Restarted Steam going back and forth. That’s how I knew the settings didn’t work, since the rendered resolution was worse with Large. I usually go to Normal then start SteamVR, and then go to Large. That still looks better than Large --> Start SteamVR.


Might be an idea if not tried to test on a low demanding program.

I set it to “maxRecommendedResolution”: 6144,


The default vrsettings file seems to be written to every time steamVR is launched when pitool is running. This does not happen steamVR is launched on its own (without pi tool running)


Hmmm… May need to try making it read only & see if it works.

1 Like

I have added the link to: Davebobman’s Wiki
under Software Solutions.


Did you tried to revert to 4096 to see if the resolution sinks ?

I saw this setting some time ago, but deduce that “MaxRecomendedResolution” was to stop SteamVR to auto move the slider to resolutions that the Vive/VivePro display can´t render and waste GPU resources (100% diminished returns).

But i will try to test it tonight.


@PimaxUSA @Heliosurge

I managed to run Chronos. But i had to run it thru SteamVR and because of that it needs PP on, so the image loses some clarity. But work anyways !

I literally used the revive injector that can, somehow, bypass the “Entitlement check”.

1 Like