How do i play ED without going into steam

Hi Guys,

How can I play Elite Dangerous at 2560x1440 without going into steam or using steamVR

I do have a EDTracker I can use for positional and head movement.




i think you cannot play ED without steam VR but i know that you can disable the PIMAX gyro in the PIPLAY settings if you want to use an other tracker like TrackIR.

I can get it to run in the selected mode, but the images are compressed ?? and too narrow making everything slim line so to speak, have tried the FOV but that didn’t make any difference, images are very clear but need to be wider.

Hi Shaun,

What version of PiPlay are you using?

If its the current beta; the resolution has been reported to have been reduced. If so download the previous non-beta.

Hi Shaun,
How did you get it to start outside of Steam?
Is it on Pimax display or just PC monitor?
I can start ED directly via EDLanuch.exe (ED directory), but it only displays on the PC screen.
SteamVR starts when the game starts but doesn’t seem to do anything.

Would really like to know how to get it to run in HMD outside of Steam because Steam prevents my X52Pro HOTAS from being seen in ED and have to use XBox360 controller in VR HMD.

HOTAS works fine when game is started via EDLaunch.exe, but only displayed PC screen.


What version Elite do you have, steam or non steam.

Hi Shaun,
I have the Steam version.
It’s really got me scratching my head.

I’m not sure if you can play it out of steam, I bought the pc version that also comes with a steam key, you need to check if frontier provided a pc key with the steam version, if so let me know. If you can launch the game outside of steam just by the .exe file, then you need to have the primax in extended mode, go into the game and click option, grphics and look at the display, click on the + button and see if you can change it to secondary monitor, scroll down and select 3D, click on side by side and FOV off, click on quality and select VR and click on either low, high or and exit, reboot system and launch game, disregard the steam popup for the headset and see if the game launches in the headset.

Hi Shaun,
Thanks for your reply and it seemed to do the trick.
As soon as I changed the 3D from OFF to ON the HMD burst into life and the HOTAS works perfectly.

I also got a reply from Elite Dangerous support and they said that Steam has made some changes to the way it interacts with controllers and that has caused some issues.
Apparently they are working to fix it.

Anyway, it is possible to play outside of Steam by launching the game directly via EDLaunch.exe from the Elite Dangerous directory.

It’s amazing the difference between playing the game on a PC monitor and in VR.
It’s so much more natural in VR having the freedom to look around.

Thanks for your help and hopefully it will keep working.


what resolution have you got, and what is the picture like

Resolution 2560 X 1440. Checked in Piplay, PC monitor and also in ED.

The picture is very good, but it could be better if it were possible to properly focus Pimax.

I need to have extra lenses over the Pimax lenses which reduces the field of view, but in game it still excellent since usually a person only focus at objects directly ahead.

Do you find the graphics seem to be compresses in the width as everything seems to be slimmer than usual ?? if not what are your settings and setup ?

Hi Shaun,
The graphics look normal to me. All suns and planets are perfectly round, something I wouldn’t expect if the image was compressed.
The cockpit looks normal also as do all the menus.
It all looks pretty much the same as on the PC monitor.

I haven’t really changed my settings other than what I had to do to get the HOTAS working.
The in game graphics are set to 2560 X 1440 at very high quality and full screen.
If there is any particular setting you would like me to check, let me know.

My PC setup is as follows.

Windows 10 Pro 64-bit. All up to date.
i7 6700K 4.5GHz CPU
ASUS Maximus VIII HeroAlpha motherboard.
16GBytes Corsair Vengeance system RAM
ASUS Strix GEForce GTX1080 8GB GPU. Nvidia up to date drivers
HyperX Predator 480GB SSDrive for operating system
Samsung 512GB SSD for apps and games


Thanks for the reply Luke, What drivers do you have installed and what firmware are you using on the Pimax, does yours connect as a HMD in your settings and menus for the game, if you could get a screenshot I would like to see it, how did you set up your Pimax software and any additional software.

I too have the following:

Windows 10 64 bit all the updates up to date
I5 4750K 3.75Ghz
16GB Ram
Gigabyte Sniper motherboard, with the Gigabyte 1070 GTX all drivers up to date
2 x 500GB Seagate SSD,s



Hi Shaun,
What drivers do you mean? I don’t have any drivers other than what would be normal for the hardware I have.

I don’t have any additional software for Pimax other than what is installed with Piplay.

I don’t have any Oculus software or drivers installed. These cause me too much trouble for little gain.
I just use SteamVR and most of my games are through Steam. Although I play ED outside of Steam otherwise my HOTAS doesn’t work.

This is what I do to play ED.
Pimax is in Pimax mode
I start SteamVR first. Then I launch ED via EDLaunch.exe. (I made a short cut for it).
The game’s main launch opens (server I think) and I select the game version I want to play (Elite Dangerous or Horizons).
That’s it. Although my confidence level is low that my HOTAS will work each time as it seem to forget some of the settings.
For example if I check the controls menu, it always opens at Custom although I always select X52 Pro and apply it.
Also the binding for the HMD re-centring has to be set each time as it seems to forget it when I exit the game.
Other than that, it seems to work OK.

Here are some screen shots. Hope their helpful.
I had to reduce the game monitor resolution setting and set it to windowed so that the screen grabs were small enough.
The display in the HMD is about the same as the frame grabs but with a wider field ov view and don’t appear curved like the PC monitor grabs.


I beleive he was looking for PiPlay version.

F/W in your Pic.

PiPlay 1.1.92? Current Stable PiPlay. All new versions have reduced Resolution. Tho think newest version while reduced might not have as much compressed look. Fer said would test more.

Yep. I was on the Beta .23 version, uninstalled it and changed to .92 version and yes its now what it should look like, thanks Luke and Heliosurge.



Your welcome Shaun!

My steamertag is same as here.

Though admittedly not on as often as would prefer. But be good as Luke mention to setup a PiMax user group in steam.