Help! new Pimax 8kx user. controller hands reversed/mirrored?

So I’m almost at my wits end trying to figure this out…
After I do the room setup using pitool and enter steam VR, the controller “hands” are out in space about 6 feet away and mirrored opposite the actions I do with them. It’s virtually impossible to do anything like this. What am I doing wrong?

Please help!

Stop Steam VR, disconnect usb3 from pc>choose another port, plug in usb3 from headset. If all going right pitool will make automatically a room setup. Fixed it for me many times.

1 Like

thanks so much! I will try your magic spell tomorrow, hopefully it works!

OK I tried this and still no luck. I’ve tried doing room setup about 10 different ways and the controllers are still nowhere near me in VR. This is unbelievably frustrating! I’ve now spent about 2 hours just trying to get this thing functional. Is there any way to reset EVERYTHING and start over?

OK I finally figured it out… Not just Steam VR but also Steam needs to be shutdown for this to work… Thanks again for the tip!

1 Like

OK its all messed up again! Do I need to do this EVERY TIME I use this headset???

1 Like

When this happens to me I just switch usb ports around and it works fine again. Did you also notice when you move the headset around it doesn’t track movement too?

1 Like

Yes, this happens as well…

I have to say I thought switching from my old WMR Lenovo explorer to this would be a huge improvement in tracking but it actually seems to be worse now.

It also seems that one of my tracking stations is only intermittently working and I can’t figure out what to do to get it stay on reliably, This is all just unpacked hardware too.

I’m using a GTX 3080 with a new computer as well. Hardware should not be an issue…

1 Like

yes, I have to disconnect and reconnect it very often. it would be good if pimax would turn off the absolutely annoying little things. the little more fov isn’t worth all the trouble, unless you’re really tough.

Well after a one hour elite dangerous session, I had to recenter the display about 10 times. Tracking is absolutely terrible. I never need to do this with my potato Lenovo Explorer. I really hope this is fixable.

Have not done the roomsetup in pitools.

Ya, I’ve done the roomsetup in pitools about 15,000 times now (well, not really, but it does feel that way… realistically probably about 30 times in the last 2 days)

I ment I have never done the roomsetup in pitools.

If headset fimware and Pitool updates aren’t working for you to fix the problem aftter switching USB ports and the problem still persists, then you might have faulty steamvr watchmen USB dongles inside the headset or faulty gyroscope/accelerometer as the frequency of lost tracking you’re describing doesn’t sound normal.

Thanks again everyone for trying to help!

Just to be clear, while playing Elite I was not using lighthouse tracking as the VR controllers are not used. I may try to use them today, but I’m afraid that won’t work because I think lighthouse requires the VR controllers to be active (let me know if I’m wrong please) and the index controllers will shut off after some period of inactivity.

I’ve also checked that I’m using the latest versions of pitool and the headset firmware is the latest version.

How do I determine if the gyros are faulty?

Sounds like headset drift from the lack of lighthouses actually. Drift when playing without lighthouses is normal.

You would need to try your setup with lighthouses and then for the tracking to have problems whilst lighthouses are working in order to rule out the possibility that not having lighthouses could be the source of the problem, and to be sure that it’s more likely a steamVR watchmen dongle issue inside the actual headset causing the problem instead of an issue caused by not having lighthouses which work fine with other headsets in use, or from using faulty lighthouses.

OK thanks I’ll try this. Do the controllers need to remain on for lighthouse to function? In setup, it seems the base stations don’t appear on unless the controllers are on, and this would seem to be a problem with auto-shutoff due to inactivity.

these steps are great for tracking issues…

Thanks… wow looks like you need an advanced degree to solve these issues. To be clear, I don’t think I have jitter issues (which is what most of the thread is about), but one of my base stations is not consistently on (probably only on about 10% of the time, it seems). I will go through this and attempt to figure it out. Thanks again for the tips.

Update: well I figured out that both base stations shipped to me were configured for channel 1 (seems like a fairly basic QC issue), so hopefully that fixes some of my issues. Thanks again everyone for your help! Onwards to see if I can fix more…

1 Like