Help, my Pimax 5K+ cannot power on via 12V, but via USB-C is semi-working

My Pimax 5K+ suddenly died and no longer powers on even if I plug in the adapter. I read that the red light should come on even if everything else is disconnected, but there is totally no light. I’ve tried swapping with two other known working power adapters, but still no go.

However, if I connect it via the USB-C port on the bottom of the headset as well as the normal USB and Displayport, it powers on just fine and PiTool detects it ok, green light and all. But the display is still off in the headset and the main triple cable junction and the top part of the headset gets really hot so something is still wrong.

Anything else I can try? Just when Pimax is finally sending me my replacement cable for the sparkles issue, this happens. Sigh… the problems never end. Maybe the new cable will resolve this. I’m quite handy with disassembling and soldering stuff so if there is any way to fix this, I’d like to know.

EDIT: My replacement cable fixed the issue, as well as the sparkles. Thankfully I didn’t end up with an expensive paperweight. See my later post below, the defective cable was fried inside.

Those were rated at 12V and the plug and polarity was compatible?
If yes, then I suggest you should file a support ticket…


Yes, 12V 2A and the other is a beefy 10A one. Polarity is correct and I’ve got a DC barrel plug adapter so it fits. Measured every one with a multimeter too.

I was hoping not having to deal with support again. It’s going to take months. Will enter a ticket if there is no way to fix this.


Indeed you could try the new cable to make sure.
Afaik the Pimax headset is not very user friendly to disassemble.

1 Like

If you decide to open it, take a look at this first:

However, you might not be allowed to RMA the headset afterwards.


I would as @TrevorVR mentioned file a ticket in the meantime. It is possible the new cable will resolve the issue. But if not you at least have your ticket started.

1 Like

Update: My new cable has arrived and everything works flawlessly now, no more white sparkles either.

So I cut open my defective cable and this is the result. Totally fried inside near the 12V input, so that explains why my headset wasn’t getting power. Everything is encased in epoxy, wrapped in copper foil, then wrapped in a rubber casing, so it is impossible to repair.


So that’s the point where the culprit is located.

I always thought the cable issues were due to twisting and breaking of the cabelage, but instead it was a problem in there. Quite interesting.


@Alex.liu @PimaxQuorra


Hello TrevorVR,

Thanks for the mention!

We will forward this to our Project Manager.
Looks like it burnt up in there and caused some issues.
Will definitely take care of this matter.

Best regards,