Help! 10 FPS in project cars 2 on lowest settings! - 2080ti 8kx

Hi, something changed recently. PC2 was running perfectly on medium settings at 75 FPS. Now down to 10 FPS on lowest settings!

Anybody know what happened?

Welcome to the Forum!

Maybe @MikeJeffries might have some ideas I think he plays that one.

Can you share the rest if your system specs please?

Also if you could post your Pitool settings with steam and PJ cars settings may help.

Thanks!

Intel i9 9900
32 GB RAM
Nvidia 2080ti

1 Like

1 Like

Your problem is right in front of you. SteamVR SS at 100% is too high.
When you turn on PP the resolution increases like 2x or so. You need to try SteamVR SS 50% or so.

3 Likes

I recommend first setting pitool render quality to 1.0 or 1.25 or even 1.5, and than afterwards, setting steam resolution multiplier to some vaue so you get resolution per eye like shown like yyyy x 3330 (I always target this second number to be about 3300) Depending on game this can be at multiplier value of 20-30%. Even with my 1080ti I get acceptable frame rates with very good/sharp image.

Thank you! I’ll try that.

On large with PP and resolution yyyy x 3300? I find this hard to believe.

1 Like

i overlooked “large”, but on “normal”, yes, I can enjoy the game. reprojection/smart smoothing activated and reduced ingame graphics settings, of course.

2 Likes

Please update Pitool . Your 261 is lacking performance anyway. Since 264 gpu utylization is up to 98 %

2 Likes

Ok, new pitool (264) and @vorinami settings.

It’s an improvement…but I used to be able to get 75 fps on medium settings…what has changed??

1 Like

In-game supersampling under the VR settings?

Did You change any global settings in Nvidia Control panel?

Do You have Nvidia Geforce Experience installed and if yes, are You sure it isn’t set to automatically “optimize” settings (it doesn’t work well for Pimax headsets)?

2 Likes

Supersampling in game is set to 1.
I haven’t changed anything in the Nvidia control panel, but just in case, I have clicked ‘restore’
Geforce experience is saying ‘game isn’t optimized’…and showing suggested optimum settings that I know would slow it to a slideshow.

1 Like

OK. Then at least that’s ruled out as the cause… :wink:

Thanks for the suggestions. I’m sure there’s something I’ve missed somewhere!

1 Like

Set steam vr resolution not to automatic. Always to manual lets say 50% (if you use pimax 1.5 quality setting). Then as vorinami said, keep an eye on your vertical pixel settings. 3300v is a little optimistic for pc2 even with an 2080ti. If you have an 5k+ or 8k/+ your native vertical resolution rendered is 1440p and for the lens correction add another 15-20% and add some supersampling and you are fine with around 2000v. Anything more is hardly an visual improvement but taxing the gpu. If you have an 8kX then target 2700v (sweetspot is around 30% more than native). And reduce to normal or small in titles where parallel projection is needed. The amount of wasted pixel is enormous and the benefit of the extra fov (especial the blurry mess in large not worth it).

After a steamvr and/or pimax update the resolution automaticly chosen can change significantly. That was very likely the cause.

You can try to play pc2 in oculus mode to not need pp on. For this you need to copy two oculus dlls into the pc2 directory, add a text file there too and import the game in the pimax games launcher tab. Search in this forum in games and pc2 thread.

I could play this way at full 72Hz without smart smoothing (it has issues in pp titles) on my 8k used at that time. Try to avoid smart smoothing. Turn it off and adjust ingame setting. Mine were mostly medium and a few high.

And set motion smoothing to off in steam vr. That does not work and is not needed with pimax headsets.
And advanced ss filter to off. Somwhere i read it is better to turn it off. Can’t remember why. But since then i have it always off.

Edit: to find the performance sweetspot for the vertical resolution for each game activate the performance overlay graph in the steamvr/developer menu and play around with different ingame quality and steamvr-ss resolution setting. Turn the ingame resolution setting to 720 or 768p. This is for the mirror view only and did give me some performance boost. I recall that the ingame menu resolution was reduced by it, so readability was worse.

3 Likes

The drop to 10fps makes me think about another issue: gpu issues.

Download gpu-z (free) and open the harware monitor window of it, leave it open and watch all the sensors plotted. Total power, frequencys, ventilation rpm, even cpu temps… play a little an then go to the steamvr menu-desktop view and check the values…

3 Likes

@mr.uu

Many thanks for this! It has been very helpful. Tuning the pimax is a real pain! Pitools, SteamVR, In game settings… they all overlap!

I am now getting just about acceptable framerate and just about acceptable clarity. I will continue to tweak and monitor!

Thank you for taking the time to help. It is much appreciated.

3 Likes