Hand tracker not working

Hi all,

finally got around to testing hand tracking module on my pimax 5k and just cannot get it working.

It is detected and I install the orion software, however the pitool status states that the

“leap motion device not ready”

I have tried connecting to all my usb ports on my pc, connected the hand tracking module via usb cable directly to my pc also.

The leap motion control panel also states that the device status is disconnected. I really dont know what else to try now?

Can anyone please help me.



I have successfully got the hand tracker working on an old laptop, it appears to use a different set of drivers.

However, my main pc just will not recognise the tracking module. I cant change the drivers or do anything to impact how the module is recognised etc in device manager. Its definitely a driver/usb driver issue as the module definitely works.

At a total loss as to what to do now.

1 Like

Have you tried to uninstall via the device manager?


yes I have uninstalled via device manager, tried updating drivers through there.

The leap motion shows up as a web cam, but simply will not be detected through the leap motion software and therefore cannot be used with the headset. I really dont get it as it is correctly detected and functional on windows 8.

Not sure have you file a support ticket? Sounds like the Leap Motion is being incorrectly installed by windows 10? As you mention it is being detected as a webcam?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.