Getting more and more frustrated with my Pimax 5K+

I just can’t get the damn thing to work anymore. Its always been a bit hit an miss, but its slowly getting worse.

I have been an hour trying to get the thing to work this evening and still no luck.

I switch it on, it can see the base station, but no tracking.

I restart my PC. It can see the base station and track, but no image from the screens.

I restart the service. I get image in the screens but now can’t see the base station at all.

I restart the HMD. No help.

I restart the computer, It can see the base station and track, but no image from the screens.

And so it continues.

Anyone got any suggestions?

Do you have lots of usb devices?
Did you try to remove them all and keep only the hmd?


Do you have a second monitor? I have to always disconnect mine or the system gets confused as to which is the hmd.


Not many. Just a Joystick and Throttle. I have it working now, but its taken me an hour this evening.

It never used to me like that, but it seems to be getting worse.

1 Like

I only have the one.

1 Like

Oh the friction is real with 3rd party pcvr. Reason why psvr2 quest 2 will probably be much larger user base. Plug and play or just put on and play if both get wireless as expected.

I have no fundamental solution for those but one.
If your HMD does not track base stations, cover your HMD and uncover it. Then it will start to track.


Enjoy what you get out of it when its running good. Thats how it is sometimes. Frustrating yes, fun when it all clicks. Enjoy!:grimacing::blush::crazy_face::grin::+1:


This is how I got rid of most of my frustrations.

Also sometimes I need to restart PiserviceLauncher - if I do it from services, one restart is enough, but if I do it from Pitool, usually I need to restart twice.


Are You using extension cables? I wore a set out it seems. They worked fine for a while but I started having issues similar to You.

You can also try a different displayport port and/or USB port or just reseat the cables.

1 Like

Does “Diagnose” in PiTool say anything useful? Did you turn off the Pimax Home Unity thing?

Thanks all. I did get it working, but boy is it frustrating. There doesn’t seem to be any reasoning behind it. After the 5th restart it worked perfectly. Seems very hit and miss whether it works.

Pimax tracking is buggy as hell, until you get it track. You need to find a position in the room where it starts tracking quickly (usually, around 3-4 meters in front of the lighthouse) and use it all the time. Currently, it is the only way.

1 Like

Haven’t made that experience. It’s rock solid here - I start 2 Lighthouse stations and the Pimax Headsets via a press of a button (power switches slaved to one remote). As soon as the 2 LH stations have synced, it tracks within 5-10 seconds and then remains solid.

PiTool .180 though. You need to use this.


I have some hopes, that with 2 base stations it will be better. Thanks for confirming. I’m talking about single V1 lighthouse.


I use a single v1 basestation for seated gaming (and two for room scale in an adjacent room), and I hide the headset behind the chair and as soon as I reveal it again it tracks… :face_with_monocle:

When using two basestations it “just works” as @JoCool says… :+1:

1 Like

I only have one but have not had any ongoing connection issues.

One thing I find though, same as you, is on first connect each day once all services are up and running, the headset needs to be held further back from the LH to make the initial connection, and takes longer too. Maybe 1 minute or more. I can only hold it 2 metres away at most because the room is small, but that seems enough.

Once this is established however, any drop in connection due to loss of LoS is very quickly restored as soon as it is re-established, and the headset can be quite close to the LH to do this.

Given everyone will have slightly different positions and angles for LHs relative to the headsets, not to mention hardware configs, it’s hard to know the definitive cause.