Game Related Bug 2019

Issue Title:

HMD Model:
First 3 Numbers Serial:
Pitool Version:
HMD Firmware:

System Info

  • Windows Version:
  • CPU:
  • RAM:
  • Motherboard:
  • GPU Model:
  • GPU Driver:
  • SteamVR Version:
  • Oculus Version:

Attachments (Pics/Video etc…)


Date: 23/12/19
Issue Title: Game FPS cap does not match headset refresh rate, always capped to 90 or 45 even at 120hz and 65hz.
Description: I’m not sure if others are experiencing this or if it is an issue with other games outside of iRacing. But in iRacing it does not matter what refresh rate I select, the in game frame rate is always either 90 or 45. So at 120hz in the headset I am locked to 90 fps in game. At 90hz I am locked to 90 fps and at 65hz I am locked to 45 fps in game.

I have tried ticking and unticking every feature in Pitool. I’ve tried restarting the tool, the service and my whole PC. It does not seem to be related to motion smoothing as I turned that off as well.

I have no idea if this is an issue with Pitool/Pimax reporting refresh rates incorrectly or if it is a SteamVR issue or if it is on iRacing’s end.

SteamVR does indicate the correct refresh rate in the settings. It is only in game the incorrect fps cap is being applied.

HMD Model: 5k+
First 3 Numbers Serial: 204
Pitool Version: 249
HMD Firmware: 255
Tracking: No tracking

System Info

  • Windows Version : Windows 10 Pro 1909
  • CPU: 4790k @ 4.6
  • RAM: 24GB DDR3
  • Motherboard: Asus Maximus VII Ranger
  • GPU Model: Sapphire Radeon 5700 XT
  • GPU Driver: 19.12.3
  • SteamVR Version: 1.9.15
1 Like

@Alex.liu please Review This Topic.

Closed to start Q1 2020 Topic.