Fresh Windows 10 install - PiTool 275 works, but 277, 280 and 283 all fail to connect DP

Date: 10/20/2022
Issue Title: Fresh Windows 10 install - PiTool 275 works, but 277, 280 and 283 all fail to connect DP
Description: The same computer works fine with PiTool 280 but adding a hard drive for a second windows installation only PiTool 275 has worked so far.

HMD Model: 2x8KX 2x5K+
First 3 Numbers Serial: 8KXs: 2075xxx 2076xxx
Pitool Version: 280
HMD Firmware: V2.1.255.2002
Tracking: V2 Lighthouses

System Info

  • Windows Version: 10 Pro
  • CPU: AMD 5600X
  • RAM: 32GB G.Skill 3600/CL14 DDR4 RAM
  • Motherboard: ASUS ROG Strix X570-F
  • GPU Model: Zotac 3090
  • GPU Driver: 522.25
  • SteamVR Version: 1.24.6
  • Oculus Version: N/A

Attachments (Pics/Video etc…)

I have a computer that I use for sim racing and it works fine with my Pimax headsets (I have four) running PiTool 280. I have not had issues with previous versions.

The configuration of the computer is something I do not want to mess with since I use it for competitions, but I do want to do some experiments with the 120Hz mode and PiTool 283.

So I installed a second hard drive in the computer and setup a separate Windows 10 installation on that drive so I can try things out.

After doing the Windows installation, all the system updates and optional driver updates I tried to install PiTool 280 - the same version that works fine for me in my main setup.

It fails to connect to DP with any of the Pimax headsets I have (2x5K+ and 2x8KX).

Going back all the way to PiTool 275 - that does work, and all the headsets connect and work fine.

So far I have been unable to run any later version of PiTool on the new Windows installation. They all fail to connect the headsets to displayport with error code 20300.

The headsets do connect via USB and show up in the DFU.exe with their serial numbers and firmware versions properly. Here is a schreenshot with all the pertinent version information for the Windows install, PiTool, Nvidia drivers, SteamVR and one of the 8KX’s.

The most frustrating thing is that the same computer works fine with 280 if I boot it back to my normal hard drive and its configuration. The failure is only happening on the new install.

Has anyone seen behavior like this where 275 works, but none of the newer versions do? I’ve tried fresh installs as well as installing the newer versions on top of 275 but so far nothing has worked.

Here is a somewhat rambling unedited video showing that 280 does not work on the fresh install, and then booting back into the other installation on the same PC and showing that it does work there:

283beta works for me, 5k+
(version 27x and 280 before that)

Windows Version : Win10 Pro 21H2, updated to 2022-10
CPU: AMD 2700X
Motherboard: X470 chipset
GPU Model: Nvidia 2080Ti
GPU Driver: 522.25
SteamVR Version: 1.24.6
Oculus Version: N/A

kind of genereic but remove dp extension if connected, try direct usb on board (different ports), try using a powered usb hub

Salut a tous , Jai exactement le même problème après une réinstallation de mon pc , marche avec le 275 mais pas avec le 277 . error 20300.