Fixing the flashing, or a bricked 8Kx

Hi all- Someone responded to my Pimax VR Guide in the iRacing forums with a question about the flickering issue so many people had with the latest firmware. I had the time so I created a guide, with links to everything needed to not only fix the flickering, but also FIX BRICKED 8Kx HMDs that had firmware flashing errors like me. Here is a copy/paste of my guide:

I had the exact issue you are describing with the latest firmware and latest PiTools. When they released the very latest PiTool version MANY people had this issue. I reverted back to the previous working firmware, and of course when I opened PiTools it simply tried to reflash the firmware back to one causing the flickering. I tried to cancel it and actually bricked my 8Kx in the process. Here is how I fixed it personally, which fixed the flickering - which for me, was awful, constant flickering even on the boot-up screen showing the Pimax logo.

Here is how I fixed it personally:

  1. Download the very latest PiTools software suite here:

  2. Download this special Firmware fixing tool ( also works on Bricked 8Kx HMDs! ): - Google Drive

  3. Uninstall EVERYTHING related to your current install of PiTools.

  4. Use a Program like CCleaner to remove all orphan files the uninstaller leaves behind in the Registry. You can download the free version here: Download CCleaner | Clean, optimize & tune up your PC, free!

  5. Double-check there are no leftover PiTool folders in the following locations: *(Make sure you have Windows set to show you hidden folders and files.)

  6. C:\Program Files(x86)

  7. C:\Program Files

  8. C:\Users\Ryan Pietroski\AppData\Local — (Obviously it will be your name)

  9. C:\Users\Ryan Pietroski\AppData\LocalLow — (Obviously it will be your name)

  10. C:\Users\Ryan Pietroski\AppData\Roaming — (Obviously it will be your name)

^^If you find ANY folders or files in those locations after uninstalling EVERYTHING PIMAX RELATED, then go ahead and delete them. I would run another registry cleaning and then reboot.

  1. Now unzip the special firmware fixing tool DFUupgrade1
  2. Inside is DFU.exe. as well as Upgrade_tool_for_Pimax.exe

I can’t honestly remember if I used Upgrade_tool_forPimax.exe or simply Dfu.exe and then directed it to the Firmware inside that special tools folder, which is the file, P2_D262.dfu, but you basically want to it to flash itself back to that old firmware.

  1. Try Dfu.exe first, direct it to use the file P2_D262.dfu file and have it flash the firmware. If it wont flash the older version over the newer, use the Upgrade_tool_for_Pimax.exe route.

Here is a command based way to do the fix with the special tool as well from a Pimax support article:

  1. Press the windows key+ R on the keyboard to run CMD

  2. Drag the“DfuSeCommand.exe” from DFU Tool into the command window, then input “0”

  3. Drag the 262 firmware directly to the windows as below, press the “Enter” key, & the upgrade will be conducted and finished.

The command line is DfuSeCommand.exe 0 file name like this example below:

C:*\DFUupgrade\dfuSeCommand.exe 0 “C: \Program Files\Pimax\Runtime\dfudriver\p2.dfu”



Once you have it flashed to the old 262 Firmware using this tool, restart your PC and open the special DFU tool folder again.

  1. Double click on Dfu.exe to start the firmware update process again, and this time direct it to the latest/newest Firmware version for the 8Kx. Have it manually flash the firmware to the latest version.
  2. Once thats all completed. Restart your PC and install the latest version of PiTools.
  3. Once everything is installed, restart your PC and give the headset a shot in Native 90hz mode. The flickering should be gone.
  4. Personally I would reboot yet again, run CCleaner one last time to do a complete clean and registry clean, and then reboot one last time and go at it!

This should fix the flickering, but if you want to check ALL the bases at the same time to ensure it gets completely fixed:

It never hurts to do a complete wipe and reinstall of the latest Nvidia drivers, but you want to do that using DisplayDriverUninstaller.

Download the latest Nvidia driver here: Official Drivers | NVIDIA

Download DisplayDriverUninstaller here: Display Driver Uninstaller Download version

Reboot into safe mode by holding down the shift key while hitting REBOOT.

*When the blue screen comes up navigate to Startup settings to have it reboot into safe mode. I believe you’ll select Troubleshooting, Advance Settings, Startup Settings, and then Reboot to Safe Mode and click the reboot button on that screen - (I might have mixed up the order on those instructions above, but the path to enable Safe Mode is very similar to what I listed. )

When the PC comes up next, hit “4” and then log in normally. It should be in safe mode now. If you’re in Safe Mode you’ll know it.

  1. Open DisplayDriverUninstaller and go into the program settings. Set it to NOT download updates from the Microsoft store automatically, set it to GPU and have it do a complete uninstall and reboot.
  2. Once it reboots and comes back up, run CCleaner clean as well as Registry clean, and then reinstall the latest Nvidia driver.
  3. Just remember that you’ll need to re-setup the Nvidia Control Panel settings, as well as your iRacing specific profile within it

*Lastly - to reallllly cover all bases, you can uninstall SteamVR and reinstall it. Again I would use CCleaner after uninstalling it, and then reboot before reinstalling.

If all this doesn’t fix it - revert back to the previous version of PiTools and the previous Firmware. It works JUST as well really, and no flickering.

Adding this poke to you guys, so you know this guide has been created - @Heliosurge @PimaxQuorra @PimaxUSA

Good luck all!


Thank you will see about creating a Temporary Topic in Guide repository for your fix.

@Rygar1976 thanks for this!
I’m on a P8kx. I was able to follow your method, up until launching Pitool again. It wants to flash some firmware upon starting, and will fail.
I’m on a plain Windows 11, just submitted a case for Tech Support, hope this can be fixed.
Got the headset yesterday, you can imagine the initial experience I am having.


Hey bud - no worries.
Sometimes it doesnt like updating the firmware through PiTools.

  1. Download the latest Firmware here: P2_RELEASE_8KX_M296.dfu - Google Drive

  2. Unzip the file, and then go to your PiTools Install to find the Dfu.exe firmware updater.
    Typically thats:
    C:\Program Files\Pimax\Runtime\Dfu.exe

  3. Right-click on the Dfu.exe file in that folder and click RUN AS ADMINISTRATOR, and then direct it to the attached Firmware. Allow it to update manually.

That should do the trick.

Youll also want to turn off Hardware GPU Scheduling:
Click on the windows button and type in:
Settings, System, Display, Graphics Settings - and then disable HARDWARE-ACCELERATED GPU Scheduling.
Reboot and give it a go.
Good luck!
Ryan Pietroski


I’ve received m2001 firmware from Pimax support, this has flashed successfully.
But… when Pitool is launched after connecting headset, graphics in the OS will freeze.
If headset is connected after Pitool has been started, OS will not freeze, but Windows UI will keep crashing.
This will stop as soon as I disconnect the headset.
If this effect has been observed, OS will not freeze when starting Pitool with HMD connected.
Application/System events do not contain anything extraordinary.

Quick update for everyone in case they read this:

  1. Much like the Reverb, the Pimax may have issues with a GPU running in PCIe 4.0 or 5.0 Mode. AGS was able to solve his issues by changing the BIOS setting on his z690 Asus F-Gaming Mobo so that his 3090 GPU is using PCIe 3.0 rather than 5.0.
  2. He also made sure that all power management settings for PCIe slots were disabled in the BIOS.

Apparently, this is a known issue with the Reverb as well, so MANY THANKS to AGS!
After speaking with him, I can say he is definitely a power-user like most of us. My thanks to him for putting his brainpower to good use to help solve this issue. Hopefully, it helps other users out there.

I will be passing this fix on to Pimax so they are aware of the issue, and can hopefully fix it in future firmware revisions.

1 Like

Decided to mess around w/ VR after months of non-use.
Went straight for 511.79 Drivers and PiTool

After connecting the X, followed by launching PiTool, Firmware flash starts with haste only to fail, LOL.
The screens refused to turn on.

Manually flashed P2_RELEASE_8KX_M296 and the screens turned back on but was short lived…
Upon relaunching PiTool, off it goes to try another flash upgrade.

No-go, back to no display.

That really annoyed so went to C:\Program Files\Pimax\Runtime\dfudriver and deleted p1/p2.

And so-again, went for yet another manual flash of P2_RELEASE_8KX_M296 and after launching PiTool, it tried to update but failed, perhaps deleting p1/p2 prevented the upgrade flash.

Anyway, noticed 90hz was not available.

Manually flashed P2_8KX_M298_EngineerTest and 90hz became available but was unstable, The display would randomly black out.

Manually flashed P2_RELEASE_8KX_M299_t20210922093742_r6066b70 but got the no-display issue.

Try 262 as described in first post.

Manually flashing P2_D262 resulted in PiTool_1.0.1.274/PiTool_1.0.1.275 still not being able to upgrade the firmware.

The upgrade fails.

After the firmware upgrade fail, the no display symptom returns.

Manually flashing P2_RELEASE_8KX_M296 and deleting p1/p2 at least keeps it semi-functional.

1 Like

It’s a shame Pimax can’t get their s**t together and write a usable firmware updater. I have the flashing issue when trying to use the 90hz option, but why should I have to go through all of the bs that @Rygar1976 lays out just to update to a usable firmware? Is this just not a priority at Pimax?

1 Like

I think a lot of firmware failures is related to download integrity which is a simple fix using crc checksum verification.

But yes it is baffling that they listen but don’t.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.