Every windows update seems to lose my 8kx

After the last two windows updates, the system has ‘lost’ my 8KX. Both times I’ve had to reinstall the firmware. (dfu.exe). Is there a causal relationship? Anybody else having this issue?

reinstall the firmware??? The firmware has nothing to with the system.

No probs for me, but, plug in and out should solve every win problem.

1 Like

I unplugged and replugged every connection. I switched to my fibre optic cable. Unplugged anc replugged and tried different USB and display ports. Zilch.
Finally reinstalled the firmware. That worked. So…it clearly has something to do with the problem,

sorcery. Illogical, but if it works for you…

I suggest to power off the PC, unplug and wait a couple of minutes for the capacitors to discharge. It fixed for me every time I had an issue with the headset after an update and/or the lighthouse not tracking.


That is very odd. Firmware is not part of your Windows OS. I am not experiencing this on the 8kX, og 8k or 5k+.

There must be something in your set up causing a conflict.

It IS odd. And there may not be a causal link. However, it’s happened three times now after Windows updates. I wonder how windows 11 will handle VR gaming.

I am on Windows 11 since weeks already on developer builds and the 8KX just works. So does pretty much everything about the OS minus some language inconsistencies and UI problems. The UX guys arent quite done it seems, but the core works and its just as stable as Windows 10, because pretty much it is



This is odd situation, as the windows update has nothing to do with the headset’s firmware. You can try to replug the cable or maybe remove the USB trusted device and reinstall it.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.