Euro Truck Simulator 2 HELP!


Has anyone managed to get euro truck simulator 2 working. I’m using version 1.1.75

MB 1.2.75?
At me on 1.1.92 works without problems.

Sorry, yes it is 1.2.75

Is it easier to make games work in 1.1.92. I see most people on hear seem to prefer 1.1.92.

Have you got euro truck simulator 2 working in 1.1.92

You are wrong, as in 1.2.75 compatibility is better.
Maybe you just have a version of the game not suitable because I know for sure that at 1.2.75 they play in ETs2.


Do you do anything different to get it working. I just click play in steam and it starts on the monitor but nothing on the hmd. I’m not techie enough to know why it doesn’t work in the hmd.

I also have downloaded a couple of free demo’s and they worked on the monitor and not in the hmd.

Elite dangerous I just click play in vr and away we go. Just how I like it

Hi. Maybe you need to set -vr in games launch option?
I’ve fallen for that one a few times.

Hi luke

I know I’m going to sound dim here ( I am ). How do I set that option :smiley:

Right click on game in your Steam library, click on properties and General tab, click on Launch options and type in -vr in the text box.
Cheers :slight_smile:

Thanks Luke

I will give that a go. I tried the -oculus and changing the thing on the beta tab but that didn’t work.

I have Also read pressing F11 also works I will try that too.


Hi Luke

Tried both the suggestions but still not getting it to work in the hmd.

Is it because I am running 1.2.75

Aaahhh what am I doing wrong. This thing is frustrating the shite out of me.


Nothing I do works. Is someone out there playing ETS2, if so how. What version of piplay and what steps.

No I don’t think that the Piplay version would prevent it from running in the HMD.

I haven’t tried ETS so I can’t speak from experience, but I’m sure that someone on this forum would have tried it and maybe they can chime in.

I assume that it is a SteamVR game and so Pimax is in Pimax Mode and SteamVR is running?
Or does Pimax need to be in Video Mode without SteamVR running?

Hopefully someone with experience with this game will chime in.

Something you may try is using the Open Local feature of Piplay (main screen) to run the game’s .exe directly. If SteamVR is required it should open automatically.

Good luck.

Hi Luke

Yeah it is a steam game. I run steamvr start the game. The hmd goes to the dark screen with the box that shows an image of what game is starting but there’s no image in the box just the flashing white bars and the game starts on the monitor

I have not tried pimax video mode. I thought that was for just watching films. I will give it a try though.

Cheers Matey

I think if it’s a SteamVR game then Video mode won’t work. Need to be Pimax Mode for SteamVR.
Sounds a bit strange though.

Now this may sound funny, but I mention it because it happened to me a while ago.

I would start a game in SteamVR and like you I would see the loading bars and then nothing but grey.
After scratching my head for a good while, I realised that the game had actually started and it was being displayed behind me. Turning my head 180 degrees allowed me to find it.
May sound silly, but it actually happened and all I had to do was recenter the display.

It’s worth a try.
I do seem to have problems with the centre. When I enter the steam room I’m looking out of the doors to the left


I have the steam version of ETS2 so it is up to date.

Can you give me the steps you use to get it to work please

I have been downloading the newest version of this via appnaz. Link for someone interested: Google Classroom

Maybe this way can help as below:

  1. Right click ETS 2 in Steam and select Property, select Betas and then select “Oculus-Experimantal Oculus support (1.4.0)” from drop-down box.
  2. Click General - Uncheck the checkbox of “Use Desktop Game Theatre while SteamVR is active”. “Set launch options” - input “-openvr”

Hello everybody :slight_smile:

I already got to work most of my games with the Pimax, i.e. Elite Dangerous, Project Cars, Skyrim @VorpX, Witcher @VorpX, WorldOfTanks @VorpX

But one game still refuses to show any image in the Pimax: Euro Truck Simulator 2

I already tried many suggestions and tutorials I found for the Vive (i.e. “-openvr” and SteamVR DirectMode) and the Rift (i.e. with Oculus Setup & Drivers, ReviveInjector and “-oculus”). With explicit DirectX 64bit and without. The “flat” start options (-“openvr” or “-oculus”) first of course as well.
But nothing worked so far: The HMD screen launches, I also get the blue SteamVR grid, the game image on my TV still shows the Windows10 task bar below, so it seems as if somehow the game knows there’s a HMD attached with SteamVR launched. But apart from this, the game itself only shows up on the TV screen. Nothing but the blue SteamVR grid inside the Pimax itself.

With the Rift CV1 in December, there was no problem at all - VR HMD right from the start as soon as the VR-beta for ETS2 was installed and I added “-oculus” to the start options.

Has anybody got Euro Truck Simulator 2 run on the Pimax so far?

If so, I would be glad for some information and experiences shared :slight_smile:


Did you get it working elin77?

I have got as far as seeing the opening ETS menu in the HMD but as soon as I click “drive” ETS crashes.