DX11 Titles With Vorpx - Very High CPU Frametime

Edit: Determined to be with any DX11 title through Vorpx, more testing needed if it affects non Vorpx DX11 native VR titles.

Trying to run Bioshock Infinite using Vorpx on my 5k XR and my CPU Frametime is hitting 30-60 constantly no matter my resolution, SS, or FOV setting when using Geometry Mode. Z Mode is much better but still not perfect.

I have a 2080 ti, a brand new Windows 10 1903 install and a 9900k so hardware should not be an issue. I have absolutely no issues running Bioshock Infinite at 4k/90fps with Geometry 3d mode using my Odyssey + or Vive Pro and I even have extra overhead to push SS to 130% at 4k.

I am at a loss as to why the Pimax headset causes massive CPU Frametime lag even at 1080p resolution and 30% SS setting. My graphics card rarely goes over 40% usage (way less at 1080p) but no matter what my CPU frame timing is hitting 30ms and killing my fps.


Same here with Bioshock, Prey and Borderlands.

Bought vorpX yesterday so I thought it was “normal”.

9900K + 2080Ti.

Using custom 16:10 resolutions as recommended (but at 144Hz, wonder if that’s the problem?).

1 Like

if gpu under-utilization is a problem then you might try this if its not to uncomfortable



Weird stuff. Tried again today. No issues at all… :+1::wink:

72Hz low GPU (below 11) and CPU (below 1) frametime… :face_with_monocle:

EDIT: Remember to run the DirectVR Scan (Alt-L) when in game… I.e. not in the menu but when You’re playing.

Thank you for the .dll fix but that did not change anything. I am even sitting at 30 ms CPU frame time before I even load in to the game world and once in the world enabling direct VR does not help.

I am going to try an older version of pitool now since I was running the latest beta.

Older pitool did not change anything.

I am starting to wonder if I have a bad headset as I am unable to downgrade the firmware without the headset bricking and requiring me to reflash to latest and reseat the cable.

you install the older pitool, install the firmware that comes with this pitool version by using dfu.exe, restart computer and power cycle the hmd

Which worked perfectly fine on the first headset Amazon sent me but I had to get a replacement to get the Prime Day pricing. The new one will not accept an older firmware and every time I try to flash an older firmware the headset bricks itself (no DFU, nothing in device manager). I then have to force DFU, flash back to the latest firmware and re-seat the cable or the headset will show up as a bad device in device manager.

I had 0 issues flashing my original headset to multiple versions and back while never requiring a cable re-seat.

are you using the same usb connector on the computer as before?

instead of the cable on the headset it should be enough to cut the power to the hmd and if that’s not enough also try to unplug usb
i don’t know how often the connector of the hmd should be used, might wear out or gets loose like the audio connector if used to often (after the cracks and the loose audio connection i don’t trust that housing that much)

My concern also, same USB port and everything even though I am sure I have swapped the USB a few times in my testing.

It actually appears to be with any Vorpx (and possibly non Vorpx) DX11 titles. I tested a few more DX9 Vorpx titles with no issues but every DX11 title has major CPU reproduction. I am trying to find non regular VR DX11 games to see I have this issue there also but still working on good way of determining the DX on those titles. Skyrim VR and Trover both run perfect but Serious Sam 3 seems to be having issues but I have not spent any time looking in to known issues for that title.

It seems like Smart Smoothing being on makes the issue much worse. With it disabled games are now playable but I need to wait up to a minute or two after a level loads and direct VR scan to load before CPU timings go back down. With Smart Smoothing on they never go back and the CPU timings always stay high.

Now I am curious if the firmware flash problem is a real issue or maybe my headset simply wont accept older firmware?