DP detection woes and PiTool official/beta confusion

So, I was taking my 8KX to the office today to give a colleage a proper introduction to “VR2.0”
Now, ok goggles here download PiTool, but, what the dang…271 is still beta but the only available as “official” PiTool for download??? anyway, download install, connect 8KX (Titan X, clearly filling the requirement of DP 1.2 and running latest DSC 1.2 updtae, too plus latest drivers) - not detected, pug out plug in, 3 DP ports on the card, neither work. Reboot HMD, restart services, shut down PC remove mains, start fresh, same procedure, no avail.
So, where is “official” PiTool - browse the community, logical approach, no? So, uninstall PiTool, reinstall 270… sad story all over again.- bummer, VR 0.3 instead “2.0”.

Last call tomorrow, so any advise dearly appreciated… but I have a feeling I will not be able to evangelize.

Btw. I had this on my 1080To at home as well but there at some point at some DP port I could make it happen, I still think there is a major flaw in PiTool detecting the DP connection. And please (!) put official releaeses in official download places and clearly mark betas as what they are.


MMMMaxwell Card, not sure if the card are good enought.
The specs says pascal minimum, i mean

Says DP 1.2, Maxwell did 1.2a from start and nvidia pushed an update to make it compatible with DP1.3/1.4 displays, which is on that card (NVIDIA Graphics Firmware Update Tool for DisplayPort 1.3 and 1.4 Displays).
Then, again, I experienced the same initial issues on my 1080Ti which is why I assume a general detection problem. For what it’s worth, it’s my previous gaming rig sans the card, will bring in my 1080Ti over tomorrow just to check.

1 Like

yeah, but the titan x is 20% slower then the minimum required.

Your 1080ti is nearly 80% faster (withouit OC) as this old Titan.

Is it or just the recommended?

SweViver said himself that the 8kX is easier to drive than the 8k and 8k+.

If that is true then it should be possible to run on a 980ti as @Fresco did on his og 8k and @Ludiks did on a 1060 6g. I haven’t fired up my old beast with the Amd r9 390 8g but am curious to try as had ran both the og 8k and 5k+ with decent results.

Regardless of gpu power it should minimally connect to the headset.

I do know pimax headsets cam be picky on the DP as my main system with the 1080ti the og 8k runs on the top DP where as the 5k+ for some reason wants the DP beside it. Yes 8k is fully disconnected and rebooted. For whatever reason the 5k+ on that system only likes that 2nd DP.

1 Like

maybe can @Lucivr help. Have you ever tried the X on your old Maxwell Titan?

@Heliosurge the specs says minimum 2060

The specs also used to say 980ti then 1070 now 2060.

The specs are minimum recommended and change overtime.


2021 manual link


The min spec will not prevent the headset from being detected. Just how well it might run if at all in a vr program.

Plus sometimes to fix a firmware flash has been to connect to a system that might not be strong enough for VR; but used to flash the headset when a user has had issues on there main machine.

1 Like

I had not had good experiences with the older graphics card. GTX Titan (780ti), GTX 980 + 5k plus. Windows always recognized the Hmd and also displayed it. I remember that as soon as I started pitool, the desktop was displayed in the hmd for a short moment and then the hmd was ejected as a display device. > No VR for me

1 Like

Not intend to run any game but PE/virtual desktop/big screen to show SDE and FoV. So, just detect would save the day. Meanwhile, I tried to duplicate this at my machine at home which beside the 1080Ti ago has a Maxwell to assist rendering with my KX 8K. Alas, I stowed it with 2 PSUs which both would fit the connector but ones 5V the other 12V. My suspect was the 5V but not going to try blindly. Does anyone happen to know which of the right one?


I’m not certain, but I think 5V is the correct one. I seem to remember a post, warning people to avoid 12V power. Yep, found it…


1 Like


There’s an official ver 271 on the Pimax site.

1 Like

@neal_white_iii thanks, I was aware of this thread, but it’s towards the 8KX. I’m referring to the original Kickstarter 8k and further digging might actually hint 12V.

@PimaxQuorra hopefully might be able to briefly clarify on this as with the missing into 271 has been now designed stable. One minor comment on that, though: having installed 270 it says to be the latest when checking for updates.


I also have an 8K (in addition to my 8KX). I think the adapter that goes with the 8K is 12V. I thought it was 5V, but the “AMEGO Switching Adapter” stored with my 8K cable appears to be 12V 2.0A, model AMS115 -1202000FU. I hope that helps.


Amego, 12V 2A…that’s what mine is, too! Thanks!

1 Like

5k+, 8k = 12v
8kx = 5v (usb power)


and can confirm at least the 8K gets detected on Maxwell Titan, so will bring this to the office and once it gets detected continue with 8KX tests.

Update: 8K detected on Maxwell Titan X detects 8K KS ED, doesn’nt 8KX, funnily I can run 2 4K DP 1.4 displays on that card.

Thanks everyone for assisting.


Seems you actually ended up showing him the real 2.0 experience we all know about. :rofl:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.