Double Vision Stutters ONLY with Pimax Headset (Oculus/Vive ok), DCS World Beta 2.5

Apparently, PiTool Beta and associated firmware breaks DCS World Beta 2.5. If you want to run DCS, for now, do NOT use PiTool Beta, or SteamVR Beta. If you have already upgraded headset firmware with PiTool beta, you may need to downgrade for now. See a few posts down for software/driver versions known to work.

Also, be realistic about what your CPU/GPU can handle in terms of resolution/quality.

Just received my Pimax 5k+ today. Extremely impressed by the extraordinary clarity in DCS World… even the small ADI gauge in the FA-18/C is actually readable. Comfort is a huge bonus too… never felt a VR headset so lightweight.

Unfortunately, even with 16ms frametimes, in fact even when the frametimes are mostly below the 13.8ms cutoff for 72Hz FPS, DCS World shows two images whenever the headset is moved. This is ghosting, seeing two frames at the same time, not a cross eyed effect.

With Oculus, this kind of problem could be resolved by toggling ASW on/off. With Vive, NVIDIA hardware or a solid 90FPS framerate was needed. With Pimax, I have tried various software versions and settings without success.

This kind of artifact usually indicates inappropriately reprojected frames being inserted into the pipeline.

As it is, I am very glad Pimax has managed to bring such top-end hardware to marked, so the last thing I want to do is complain. This does seem to be a Pimax specific issue though, so I am reporting it here. Thank you again for the hardware, and hoping for a solution soon.

Also, I am requesting reports as to not/working computer hardware at Eagle Dynamics (DCS) forums. My CPU/GPU is AMD Ryzen 2700X and NVIDIA 2080 GTX Ti .


Have you tried with Smart Smoothing off? Some users find it turns itself back on between uses(startup)


Here, and I thought that it seemed to me when my frame rate was blocked. And it turns out - SmartSmoothing turned on by itself …:roll_eyes:

And one more thing I noticed recently.
I had the frequency of 72Hz blocked, but in PiTool it was displayed as 80Hz. At the same time, I could not switch to 80HZ until I switched to 64 and back.

Yes, by the way, you should never include SmartSmoothing at all. I need to remove this function from my PiTool somehow … :neutral_face:


Downgrading firmware, PiTool, and SteamVR, all to non-beta versions, and maybe disabling/uninstalling hardware virtualization/VirtualBox, seems to fix it, at least temporarily. Still narrowing it down.

Specifically, I downgraded to the firmware used by .91 version of PiTool. This does not work, but subsequently installing the stable version of PiTool (which upgrades to that version), apparently does work. At least if SteamVR is also non-beta version.

Turning “Smart Smoothing” on/off definitely has effect. I don’t think that is the problem, and I don’t think the feature should be removed. Though it might or might not need improvement - SteamVR “motion smoothing” does look somewhat better, albeit driving far less pixels into the Vive.


Fortunately, I have resolved the problem now. Basically, at minimal graphical settings, with below-refresh frametimes, the double vision effect should NOT occur. This is a bug.

  • DO NOT use PiTool Beta, SteamVR Beta.

  • DOWNGRADE, or DO NOT USE, PiTool Beta Firmware.

  • PiTool version PiToolSetup_1.0.1.109_R193 .

  • SteamVR 1.3.23 .

  • NVIDIA Drivers 430.39

  • Headset Firmware: V2.1.255.193

  • Hidden Area Mask OFF

  • Smart Smoothing ON

  • Compatible with parallel projections ON

  • Field Of View NORMAL

  • Refresh Rate 72Hz

Unlikely to be relevant, but not specifically tested.

  • Firmware was previously downgraded specifically to PiTool .91 version.

Ruled out.

  • Hardware virtualization and presence of VirtualBox installation do not have any effect.

Super-resolution, and other graphics settings, in DCS and elsewhere, may be set as appropriate for the GPU available. For a NVIDIA RTX 2080 Ti clocked at 1750MHz, rendering quality may be set to 1.25, with SteamVR Video resolution set to 80%. DCS World graphics settings are generally best set to low/off, except Textures (High), Preload Radius (High), Trees (60%), and anisotropic filtering set to 8x. Especially, experienced DCS VR users should know view distance settings do not change visibility of other airborne aircraft.

More details posted here.