Doom 3 BFG VR anyone got it working?

So, not sure if this is the right section. Just wondering if anyone made it work with 5k+. The screen on my TV shows the game and when i look around with the headset it’s tracking but inside the headset it’s stuck loading the game. :S Would love to play it :frowning:

I havnt messed with Doom 3 BFG VR on my Pimax but i still have the installation which was working on my Vive, just tried starting it up and i get the same as you.
This isnt much help but more data is more data.

I’ve had that for a while too. It began happening before I got the Pimax (i.e. still on my Vive).

Hmm, strange… Could it be a patch that messed it up maybe? I will try some things and see, would be nice to try it :confused:

1 Like

got the same problem :frowning:

This has to be fixed somehow !!

Not working here either, which version is everyone using? I’m using Fully Possessed mod.

Thats the one i have as well.

I tried that mod as well + another one. I’m in steam vr beta. Anyone else? Dunno if that could be the problem

Tried both version of the mod with no result. The fixing shouldnt be that hard through because the Headset is tracking on the desktop screen …just not in the Headset itself

It works well. I will share a way to do it soon.


Awesome, thx Park. Glad someone figured it out! :slightly_smiling_face:

Cant wait to play this with my oled pimax xr :heart_eyes:

Huge thanks for solving this !!! ( waiting …:slight_smile:

Saw a Doom 3 update today(?), tried to run it again and got the same. I tried stable/beta but get the same results. I did notice the desktop displaying a ‘move to play space/face forward’ message, so I’m thinking it has something to do with that @Park?

Are you sure we are talking about the same game?

Doom 3 BFG is the game that came out a couple of years ago and does not natively have VR support, the game this topic is about.

If you got a message telling you to move to playspace/face forward you were most likely trying to play Doom VFR.

@ziddan Doom 3 BFG Fully Possessed mod, I don’t own, and never even played Doom VFR.

Huh, cool, i did not realize that VR cues had been added into it.

I hope Park means bfg and not vfr :S


When I saw you had a solution I tried this. I didn’t have any appid(which you didn’t use this time), but I didn’t get it working. Even if I got it working with this method, I was using OVRIE with a tracker on a Top Shot Elite controller.

I didn’t either, it must only show up in this instance. I was going to try using OVRAS to ‘move’ to the ‘play area’, but I looked around and didn’t see the game screen in the compositor.