Does not work at all

So after 4-5 hours of endless fiddling, i just cant get this working, not sure if the unit itself is faulty, but i have followed everything 100% and i cannot get this crap working.

980Ti (have tried pretty much all drivers from 362.00 and onwards)
Windows 10 x64

It doesnt even get recognized as monitor in windows (screen properties), so i cannot put it as extended and start installing drivers. It shows up in Geforce drivers monitor properties as second monitor, but when i enable it and accept new settings, it just reverts back (then blue light lits up on the headset). After ignoring this that i cant see it in monitor properties, i installed everything and the headset software is searching the unit all the time and disconnecting/connecting endlessly, i have uninstalled the software like 10 times and reinstalled, no luck. Headset uses latest international firmware and i have english version of the software installed (have tried also chinse, but no luck).

First impressions are not good at all for sure.

Hi, we’re glad to provide assistance for you by skype: at the present. Or please click “export logs” of Piplay and then transfer to us, we will analyze it and reply you soon.